Monday, 17 April 2017

MPLS L3VPN CE-PE Static

Assalamualaikum,

Pada kali ini, saya akan melanjutkan materi mengenai MPLS VPN dimana sebelumnya, saya sudah memposting artikel mengenai Build MPLS Backbone using Cisco, dan sekarang saya akan membahas materi dan masih berkaitan dengan CCIE, dan materi yang akan dibahas adalah materi MPLS L3VPN.


Seperti yang dketahui sebelumnya, bahwa L3VPN sendiri merupakan tunnel yang bekerja pada L3 yang tentunya tugas utamanya adalah menghubungkan sebuah network dengan network lainnya, akajn tetapi bukan dengan perantara routing, melainkan menggunakan perantara private network yang dibuat pada kedua sisi.

Oke tanpa berlama lama, berikut topologi yang digunakan.

Topologi


Berdasarkan topologi diatas, kita akan menggunakan 7 router dimana 3 router akan berperan di dalam MPlS Backbone, dan 4 router lainnya akan beroeran sebagai CE. Berikut skenario pada topologi tersebut.

  1. Ada 2 site pada jaringan tersebut yaitu site CE1 dan juga CE2. Dalam hal ini, kita akan membuat agar CE1 hanya akan dapat berkomunikasi dengan router yang merupakan CE1 juga dan CE2 hanya akan dapat berkomunikasi dengan router yang merupakan CE2 juga. 
  2. CE menggunakan default route dan menggunakan PE sebagai gateway. 
Oke jika sudah mengetahui skenario yang akan di jalankan pada topologi tersebut, selanjutnya kita akan melakukan konfigurasi. 

Konfigurasi

Pertama tama, tentunya konfigurasikan ip address pada setiap interface yang akan digunakan pada router. Untuk ip address, kita akan menggunakan ip address standart IDN. Jika sudah, maka selanjutnya adalah melakukan konfigurasi pada router yang berada pada MPLS Backbone. 

Konfigurasikan terlebih dahulu MPLS LDP pada backbone tersebut. Untuk konfigurasi MPLS LDP, saya tidak menunjukkan pada artikel ini, namun anda dapat melihat pada artikel saya sebelumnya pada artikel Build MPLS Backbone using Cisco.  

Pastikan terlebih dahulu bahwa sudah terjalin hubungan MPLS dengan router lainnya. 



Jika sudah, selanjutnya kita akan mulai melakukan konfigurasi L3VPN. L3VPN sendiri menggunakan BGP untuk mendistribusikan vpnv4 yang nantinya akan digunakan untuk membuat L3VPN. Dalam hal ini, disebut dengan MP-BGP. 

Oleh karena itu, kita perlu melakukan konfigurasi peering terlebih dahulu pada router BGP. Buat peering antar PE1 dan juga PE2. Untuk P sendiri kita tidak akan melakukan konfigurasi routing dikaernakan tugasnya hanyalah menforward label yang akan dikirimkan. 

Router PE1
!
router bgp 100
 neighbor 4.4.4.4 remote-as 100
 neighbor 4.4.4.4 update-source Loopback0
 !
Router PE2
!
router bgp 100
 neighbor 2.2.2.2 remote-as 100
 neighbor 2.2.2.2 update-source Loopback0
 !
Berdasarkan konfigurasi diatas, kita akan membuat peering BGP menggunakan loopback. Untuk ASnya, kita juga menggunakan AS yang sama pada kedua router tersebut. Oke jika sudah, kita harus mendefinisikan address family pada BGP. Address family dikonfigurasikan agar mendefinisikan apa yang akan dibawa oleh BGP tersebut. Dalam hal ini, kita akan menggunakan L3VPN, oleh karena itu kita harus mendefinisikan address familynya vpnv4. 

Router PE1
!
router bgp 100
 address-family vpnv4
  neighbor 4.4.4.4 activate
 !
Router PE2
 !
router bgp 100
 address-family vpnv4
  neighbor 2.2.2.2 activate
 !
Berdasarkan konfigurasi diatas, kita melakukan konfigurasi untuk mendefinisikan bahwa routing BGP 100 menggunakan address family vpnv4. Lalu kita juga harus mendefinisikan mana neigbor yang sama sama akan membuat hubungan vpnv4 dengannya. Jika sudah dikonfigurasikan pada keduanya, maka bgp akan membuat ulang adjaceny keduanya. 

Untuk melakukan verifikasi, dapat diverifikasi dengan menggunakan perintah berikut. 



Berdasarkan verifikasi diatas, menandakan bahwa hubungan vpnv4 keduanya sudah terjalin. Jika sudah, selanjutnya kita akan menambahkan vrf pada router. vrf digunakan untuk membuat hubungan L3VPN. Untuk teori vrf nanti insya allah menyusul hehehe. 

Router PE1
!
ip vrf CE1
 rd 100:100
 route-target export 100:100
 route-target import 100:100
!      
ip vrf CE2
 rd 100:200
 route-target export 100:200
 route-target import 100:200
!
Router PE2
 !
ip vrf CE1
 rd 100:100
 route-target export 100:100
 route-target import 100:100
!      
ip vrf CE2
 rd 100:200
 route-target export 100:200
 route-target import 100:200
!
Berdasarkan konfigurasi diatas, kita menambahkan 2 vrf dikarenakan pada kali ini kita akan membuat agar CE router hanya dapat berkomunikasi dengan community yang sama dengannya. Untuk RD dan RT, dapat di lihat pada artikel saya mengenai RD dan juga RT. 

Lalu untuk konfigurasi selanjutnya, kita harus mendefinisikan interface mana yang akan dipasangkan vrf yang sudah kita buat tadi, Hal ini digunakan untuk mendefinisikan interface mana saja yang termasuk ke vrf CE1 dan juga interface mana saja yang termasuk ke vrf CE2. 

Router PE1
!
interface GigabitEthernet1/0
 ip vrf forwarding CE1
 ip address 12.12.12.2 255.255.255.0
 negotiation auto
!
interface GigabitEthernet2/0
 ip vrf forwarding CE2
 ip address 26.26.26.2 255.255.255.0
 negotiation auto
!
Router PE2
!
interface GigabitEthernet1/0
 ip vrf forwarding CE1
 ip address 45.45.45.4 255.255.255.0
 negotiation auto
!
interface GigabitEthernet2/0
 ip vrf forwarding CE2
 ip address 47.47.47.4 255.255.255.0
 negotiation auto
!
Berdasarkan konfigurasi diatas, kita melakukan konfigurasi untuk mendefinisikan interface mana yang termasuk ke dalam CE1, dan juga interface mana yang termasu ke dalam CE2. Lalu jika sudah, coba konfigurasi ip address pada client terlebih dahulu. Kemudian coba lakukan verifikasi ping dari PE router ke CE router. 


Kenapa gagal? dikarenakan, apabila kita telah melakukan konfigurasi vrf pada sebuah interface, dan ketika kita coba, itu tidak akan bisa, dikarenakan dalam interface vrf, kita tidak dapat melakukan ping regular. Dalam artian, kita tidak dapat ping seperti biasanya. Coba ping dengan cara lain. 


Maka dengan cara itu baru bisa, dikarenakan address yang kita ping tadi, merupakan address yang berada pada interface vrf. Maka kita harus ping dengan cara mendefinisikan terlebih dahulu vrf yang digunakan pada address tersebut. 

Setelah itu, agar antar CE dapat berkomunikasi satu sama lainnya, kita harus menambahkan static routing pada CE tersebut. Oleh karena itu, tambahkan static routing terlebih dahulu pada setiap CE yang ada. 

Router CE1_1
!
ip route 0.0.0.0 0.0.0.0 12.12.12.2
!
Router CE1_2
!
ip route 0.0.0.0 0.0.0.0 45.45.45.4
!
Router CE2_1
!
ip route 0.0.0.0 0.0.0.0 26.26.26.2
!
Router CE2_2
!
ip route 0.0.0.0 0.0.0.0 47.47.47.4
!
Lalu jika sudah, apakah sudah dapat terhubung? Jawabannya adalah belum. Dikarenakan masih ada konfigurasi selanjutnya. Pada router PE, konfigurasikan route vrf untuk mengadvertise network apa yang dimiliki oleh dirinya. 

Router PE1
!ip route vrf CE1 1.1.1.1 255.255.255.255 12.12.12.1
ip route vrf CE2 6.6.6.6 255.255.255.255 26.26.26.6
!
Router PE2
!
ip route vrf CE1 5.5.5.5 255.255.255.255 45.45.45.5
ip route vrf CE2 7.7.7.7 255.255.255.255 47.47.47.7
!
Selanjutnya, coba lakukan verifikasi pada PE router untuk melakukan ping ke loopback yang dimiliki oleh  CE Router. 



Mengapa tetap tidak bisa? Jangan lupakan apa yang sebelumnya sudah saya katakan, dimana PE router tidak dapat melakukan ping regular. Oleh karena itu, coba lakukan ping dengan mendefinisikan vrf yang digunakan. 



Maka akan berhasil. Lalu apakah sudah bisa? Belum, kita masih perlu melakukan konfigurasi kembali. Lakukan konfigurasi untuk meredistribusikan static routing yang di konfigurasikan tadi, pada BGP. Redistribute connected juga. 

Router PE1
!
router bgp 100
 !
 address-family ipv4 vrf CE1
  redistribute connected
  redistribute static
 !
 address-family ipv4 vrf CE2
  redistribute connected
  redistribute static
!
Router PE2
!
router bgp 100
 !
 address-family ipv4 vrf CE1
  redistribute connected
  redistribute static
 !
 address-family ipv4 vrf CE2
  redistribute connected
  redistribute static
!
Jika sudah, coba lakukan veirfikasi pada router PE bahwa ada routing BGP yang menuju ke loopback router lainnya. 

CE1 pada PE2








CE2 pada PE2















Oke berdasarkan verifikasi diatas, setiap CE memiliki pasangannya masing masing. Jika sudah, coba lakukan verifikasi ping ke sesama CE. 

CE1



CE2


Berdasarkan hasil verifikasi diatas, maka akan terlihat bahwa sama sama dapat ping tanpa adanya nat. Lalu mengapa tetap bisa melakukan komunikasi? Hal ini dikarenakan adanya L3VPN yang akan menghubungkan network yang berbeda, akan tetapi menerima adanya community yang ia kehendaki. 

Oke sampai sini dulu, Wassalamualaikum. 

Share this

0 Comment to "MPLS L3VPN CE-PE Static "