Sunday, 16 April 2017

Build MPLS Backbone using Cisco

Assalamualaikum, 

Setelah berlama lama di MTCINE, sekarang kita beralih ke CCIE hehehe.. Oke pada materi pertama, kita akan membahas mengenai MPLS pada Cisco. Materi MPLS sendiri sebenarnya sudah ada pada bab CCNP, akan tetapi pada CCIE, MPLS dikupas lebih mendalam lagi. 


Untuk pengertian dari MPLS sendiri, dapat di lihat di artikel What is MPLS. Oke jika sudah, kita langsung lanjut ke lab MPLS 

Topologi 
Oke berdasarkan topologi diatas, kita akan membuat agar jaringan tersebut menjadi MPLS Backbone. Dalam jaringan tersebut, nantinya akan bekerja 1 router sebagai Provider router (P) dan juga 2 router sebagai Provider Edge (PE). 

Konfigurasi

Untuk konfigurasi, pertama tama tentunya buat agar router dapat saling terhubung ke networknya. Oleh karena itu, kita harus menambahkan ip address terlebih dahulu. Berikut IP address yang akan digunakan pada router. 

Router PE1
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface GigabitEthernet0/0
ip address 12.12.12.1 255.255.255.0
media-type gbic
speed 1000
duplex full
negotiation auto
!
Router P
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface GigabitEthernet0/0
 ip address 12.12.12.2 255.255.255.0
 media-type gbic
 speed 1000
 duplex full
 negotiation auto
!
Router PE2
!
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface GigabitEthernet0/0
 ip address 23.23.23.3 255.255.255.0
 media-type gbic
 speed 1000
 duplex full
 negotiation auto
!
Lalu jika sudah, selanjutnya kita akan melakukan konfigurasi routing. Lalu apabila ada yang bertanya, mengapa kita harus menggunakan routing? Hal ini dikarenakan sebelum kita membuat MPLS Backbone, kita harus memastikan terlebih dahulu agar setiap router sudah dapat terhubung. Lalu apabila sudah, baru kita dapat melakukan konfigurasi MPLS. 

Untuk pemilihan routing sebenernya bebas bisa static routing ataupun dynamic routing, dikarenakan yang terpenting adalah membuat agar router yang ada saling terhubung. Dan pada kali ini, saya akan menggunakan routting OSPF sebagai perantara penghubung antar setiap router yang ada. 

Router PE1 
PE1(config)#router os 10
PE1(config-router)#net 1.1.1.1 0.0.0.0 area 0
PE1(config-router)#net 12.12.12.1 0.0.0.0 area 0
PE1(config-router)#ex
Router P
P(config)#router os 10
P(config-router)#net 2.2.2.2 0.0.0.0 area 0
P(config-router)#net 12.12.12.2 0.0.0.0 area 0
P(config-router)#net 23.23.23.2 0.0.0.0 area 0
P(config-router)#ex
Router PE2
PE2(config)#router os 10
PE2(config-router)#net 3.3.3.3 0.0.0.0 area 0
PE2(config-router)#net 23.23.23.3 0.0.0.0 area 0
PE2(config-router)#ex
Jika sudah, pastikan semuanya sudah dapat terhubung, termasuk untuk melakukan ping ke loopback. Lalu pada lab kali ini, kita akan menggunakan MPLS IP sebagai mode pendistribusian MPLS Label itu sendiri. 

Router PE1
PE1(config)#mpls ip
PE1(config)#int g0/0
PE1(config-if)#mpls ip
PE1(config-if)#ex
Router P
P(config)#mpls ip
P(config)#int g0/0
P(config-if)#mpls ip
P(config-if)#ex
P(config)#int g1/0
P(config-if)#mpls ip
P(config-if)#ex
Router PE2
PE2(config)#mpls ip
PE2(config)#int g0/0
PE2(config-if)#mpls ip
PE2(config-if)#ex
Berdasarkan konfigurasi diatas, pertama tentunya kita harus mengaktifkan service MPLS pada router terlebih dahulu. Perintah mpls ip dikonfigurasikan untuk mengaktifkan MPLS dengan mode dynamic mpls forwarding dengan menggunakan ip. Dengan diaktifkannya mpls ip, akan mendefinisikan bahwa router tersebut akan membuat jaringan MPLS dengan router lainnya berdasarkan IP yang ada pada routing tablenya. Jadi IP akan dijadikan perantara label tersebut di distribusikan. 

Lalu kita harus memilih interface mana yang akan kita aktifkan service MPLSnya. Dengan mendefinisikan interface mana yang akan diaktifkan service MPLSnya, dia akan dapat membuat hubungan MPLS dengan router lainnya yang directly connected dengan dirinya, yang juga menggunakan service MPLS. 

Oke sampai sini, konfigurasi sudah selesai. Coba kita lakukan verifikasi. 

Router PE1


Router P


Router PE2


Berdasarkan yang terlihat diatas, ada label label yang digunakan untuk menuju sebuah network. Sebuah packet yang dikirimkan, akan disertai dengan label, dan setiap packet yang di sertakan label tersebut akan di abaikan pembacaan melalui ip address, akan tetapi yang akan dibaca hanyalah label yang digunakan. Untuk penjelasan lebih mendalam dapat dilihat pada artikel How MPLS Work

Lalu cara untuk melakukan verifikasi selanjutnya adalah dengan melakukan traceroute. Coba lakukan traceroute dari PE2 ke PE1. 


Berdasarkan verifikasi diatas, PE2 ketika akan menuju PE1, akan menggunakan label 16 sebelum sampai ke tujuan. Hal ini menandakan bahwa label sudah berjalan dengan baik. 

Oke sekian dari saya, Wassalamualaikum. 

Share this

0 Comment to "Build MPLS Backbone using Cisco"