Friday, 17 March 2017

VPLS Mikrotik

Assalamualaikum,
Pada kali ini, saya akan melanjutkan materi tunneling selanjutnya, yaitu VPLS. VPLS sendiri merupakan tunneling layer2 yang menggunakan MPLS sebagai perantara pembuatan tunneling. Dengan menggunakan VPLS sebagai tunneling, akan memungkinkan kita menghubungkan jaringan local yang berada dalam network tersebut agar seolah olah terhubung secara langsung. 

 

Konsep kerja VPLS, sama dengan EoIP, namun dalam penggunakan VPLS, kecepatan dalam tunneling tersebut lebih cepat 60% dibandingkan dengan EoIP. Oke langsung saja ke TKP..

Topology






Konfigurasi
Untuk konfigurasi sendiri, konfigurasi address untuk setiap interface terlebih dahulu. Untuk interface ether3 pada R1 dan juga R4, tidak usah ditambahkan ip address, dikarenakan nantinya kita akan menghubungkan R5 dan R6 menggunakan layer2. Untuk R5 dan R6 juga tidak usah ditambahkan routing, hanya perlu menambahkan ip address saja. Jika sudah, sekarang kita akan melakukan konfigurasi routing RIP.

[admin@R1] > /routing rip network
add network=13.13.13.0/24
add network=12.12.12.0/24
add network=1.1.1.1/32
[admin@R2] > /routing rip network
add network=12.12.12.0/24
add network=24.24.24.0/24
add network=2.2.2.2/32
[admin@R3] > /routing rip network
add network=13.13.13.0/24
add network=34.34.34.0/24
add network=3.3.3.3/32
[admin@R4] > /routing rip network
add network=34.34.34.0/24
add network=24.24.24.0/24
add network=4.4.4.4/32
Mengapa kita menambahkan routing RIP untuk jaringan tersebut? Hal ini dikarenakan nantinya kita akan menggunakan MPLS dimana, untuk VPLS sendiri menggunakan MPLS agar dapat berjalan. Jika sudah, lakukan konfigurasi MPLS LDP.

[admin@Rx] > /mpls ldp
set enabled=yes lsr-id=x.x.x.x transport-address=x.x.x.x
[admin@Rx] > /mpls ldp interface
add interface=ether1
add interface=ether2
Untuk konfigurasi MPLS, kita aktifkan service MPLS LDP terlebih dahulu, selanjutnya tambahkan lsr-id dan juga transport address yang merupakan address loopback yang dimiliki oleh sebuah router. Setelah itu definisikan interface yang akan digunakan untuk MPLS tersebut. Selanjutnya, konfigurasi VPLS.

[admin@R1] > /interface vpls
add disabled=no name=vpls1 remote-peer=4.4.4.4 vpls-id=100:100 
[admin@R4] > /interface vpls
add disabled=no name=vpls1 remote-peer=1.1.1.1 vpls-id=100:100
Berdasarkan konfigurasi diatas, yang perlu dikonfigurasi dalam pembuatan vpls hanyalah remote address dan juga vpls id. Remote address sendiri merupakan address router yan nantinya akan membuat tunneling vpls juga dengan kita. Sedangkan vpls id sendiri, merupakan unique number yang ada dalam vpls untuk mendefinisikan wilayah yang ditempatinya. Jadi apabila sebuah router dengan router lainnya sama sama ingin membuat tunneling, maka keduanya harus mendefinisikan vpls id yang sama. Jika sudah, lakukan verifikasi.




Berdasarkan verifikasi diatas, terlihat bahwa ada neighbor vpls yang ditambahkan dalam table mpls ldp neighbor. Apabila sudah seperti itu, maka dipastikan hubungan VPLS sudah terbentuk. Namun jika hanya sampai sini, client masih belum dapat berkomunikasi. Mengapa? Dikarenakan VPLS sendiri merupakan tunneling yang bekerja pada layer2, sehingga dibutuhkan interface bridge. Oleh karena itu, buat interface bridge dan definisikan VPLS yang sudah dibuat dengan interface yang menuju ke jaringan local.

[admin@R1] > /interface bridge
add name=vpls
[admin@R1] > /interface bridge port
add bridge=vpls interface=vpls1
add bridge=vpls interface=ether3
[admin@R4] > /interface bridge
add name=vpls
[admin@R4] > /interface bridge port
add bridge=vpls interface=vpls1
add bridge=vpls interface=ether3
Jika sudah, lakukan verifikasi pada client yang sudah ditambahkan ip address.
[admin@R5] > ping 56.56.56.6
SEQ HOST            SIZE TTL TIME STATUS
0      56.56.56.6     56     64    42ms
1      56.56.56.6     56     64    3ms
sent=2 received=2 packet-loss=0% min-rtt=3ms avg-rtt=22ms max-rtt=42ms
[admin@R6] > ping 56.56.56.5
SEQ HOST            SIZE TTL TIME STATUS
0 56.56.56.5          56     64    7ms
1 56.56.56.5          56     64    8ms
sent=2 received=2 packet-loss=0% min-rtt=7ms avg-rtt=7ms max-rtt=8ms
Maka jika sudah seperti itu, maka tunneling sudah sukses.

Share this