Thursday, 9 March 2017

Tunneling PPTP Mikrotik

Assalamualaikum,

Pada kali ini, saya akan sharing materi mengenai Tunneling PPTP yang ada pada mikrotik.  Jaringan private sendiri akan memungkinkan sebuah network membentuk pseudowire antar network dan lewat pseudowire itulah network tersebut saling berhubungan. 


Dalam implementasi PPTP sendiri, nantinya akan ada yang bertindak sebagai PPTP Client dan juga PPTP Server. Oleh karena itulah tunneling ini disebut dengan Point to Point Tunnel Protocol (PPTP) dikarenakan hubungan antara kedua network nantinya memang point to point. Untuk berkomunikasi, PPTP akan menggunakan protocol TCP. Oke langsung saja ke TKP..

Topologi


Konfigurasi

Seperti yang kita lihat pada topologi diatas, sebelumnya kita akan membuat seluruh router dapat mengakses internet terlebih dahulu. Lalu kita akan membuat agar seluruh device dapat saling berkomunikasi terlebih dahulu dengan hanya memanfaatkan static routing. Lalu selanjutnya kita akan membuat agar R3 dapat terhubung dengan R4 menggunakan PPTP. Kita akan menjadikan R3 sebagai PPTP Server dan R4 sebagai PPTP Client. 

Oke langsung saja konfigurasikan agar seluruh router dapat terhubung ke internet. Tambahkan ip address terlebih dahulu. Untuk konfigurasi ip address, gunakan format ip address standart dari IDN. 

Langsung saja, konfigurasikan NAT dan juga DNS pada setiap router. 
[admin@ISP] > /ip firewall nat
add action=masquerade chain=srcnat out-interface=ether1
[admin@ISP] > /ip dns
set allow-remote-requests=yes servers=8.8.8.8,8.8.4.4
[admin@R1] > /ip firewall nat
add action=masquerade chain=srcnat out-interface=ether1
[admin@R1] > /ip dns
set allow-remote-requests=yes servers=8.8.8.8,8.8.4.4
[admin@R2] > /ip firewall nat
add action=masquerade chain=srcnat out-interface=ether1
[admin@R2] > /ip dns
set servers=8.8.8.8,8.8.4.4
Untuk R3 dan R4, tambahkan DNS saja.
[admin@R3] > /ip dns
set allow-remote-requests=yes servers=8.8.8.8,8.8.4.4
[admin@R4] > /ip dns
set allow-remote-requests=yes servers=8.8.8.8,8.8.4.4
Selanjutnya tambahkan defaut route pada setiap router.
[admin@ISP] > /ip route
add distance=1 gateway=19.19.19.4
[admin@R1] > /ip route
add distance=1 gateway=10.10.10.10
[admin@R2] > /ip route
add distance=1 gateway=20.20.20.20
[admin@R3] > /ip route
add distance=1 gateway=13.13.13.1
[admin@R4] > /ip route
add distance=1 gateway=24.24.24.2
Jika sudah, sekarang kita akan membuat agar R3 dapat berhubungan dengan R4. Perlu diketahui sebelumnya, untuk membuat hubungan tunneling antar router, diperlukan adanya hubungan yang dijalin oleh kedua router tersebut. Dikarenakan kita akan membuat tunneling, maka konfigurasikan agar keduanya saling dapat berhubungan. Kita akan menggunakan Static Route. 
[admin@ISP] > /ip route
add distance=1 dst-address=13.13.13.0/24 gateway=10.10.10.1
add distance=1 dst-address=24.24.24.0/24 gateway=20.20.20.2
Jika sudah, lakukan verifikasi jika keduanya sudah dapat berhubungan. Selanjutnya, konfigurasikan PPTP Server terlebih dahulu. 
[admin@R3] > /interface pptp-server server
set enabled=yes
Dikarenakan kita akan menggunakan PPTP, maka pastikan PPTP Server dalam keadaan aktif. Selanjutnya tambahkan PPP Secret. 
[admin@R3] > /ppp secret
add local-address=100.100.100.1 name=idn password=idn remote-address=100.100.100.2 service=pptp
Berdasarkan konfigurasi diatas, kita akan membuat autentikasi baru apabila ada yang ingin berhubungan dengan router tersebut menggunakan PPTP. Sedangkan local address dan remote address sendiri, akan memungkinkan R3 dan R4 mendapatkan dynamic ip address apabila PPTP keduanya sudah berjalan. 

IP address yang di konfigurasi merupakan ip address untuk hubungan tunnel nantinya. Jadi ketika keduanya saling terhubung menggunakan PPTP, maka secara otomatis akan terbentuk pseudowire antara kedua router tersebut dikarenakan menggunakan tunneling. Lalu ip address tersebut digunakan untuk pseudowire yang terbuat tadi. 

Jika sudah, lakukan konfigurasi pada R4, dikarenakan ia akan menjadi client dari PPTP yang ada pada R3. 
[admin@R4] > /interface pptp-client
add connect-to=13.13.13.3 disabled=no name=pptp-out1 password=idn user=idn
Berdasarkan konfigurasi diatas, kita akan mendefinisikan router mana yang akan ingin kita hubungkan. Dikarenakan R3 yang bertindak sebagai PPTP Server, dan interface yang terhubung ke internet memiliki address 13.13.13.3 yang bertindak juga sebagai ip publik, oleh karena itu kita definisikan connect to kepada ip publik yang dimiliki oleh R3. 

Selanjutnya pada password dan juga user, definisikan berdasarkan PPP Secret yang sudah kita buat sebelumnya pada R3.  Sebenarnya masih ada konfigurasi yang sekiranya berfungsi untuk penggunaan PPTP yaitu add default route pada konfigurasi PPTP Client. Apabila ada client yang dimiliki oleh server tersebut, maka kita dapat menggunakan add default route tersebut agar sekiranya default route tersebut berguna untuk menuju client yang ada pada server tanpa harus menambahkan static routing.

Jika sudah, lakukan verifikasi. Pastikan status pada PPTP running. 
[admin@R3] > interface pptp-server print       
Flags: X - disabled, D - dynamic, R - running
 #     NAME             USER   MTU   CLIENT-ADDRESS         
 0  DR <pptp-idn>   idn       1450    20.20.20.2  
Lalu lakukan verifikasi untuk ping. Dikarenakan saya lupa untuk menambahkan client pada R3 agar dapat melakukan verifikasi, jadi verifikasi ping address tunnelnya aja :D
[admin@R4] > ping 100.100.100.1
SEQ  HOST                           SIZE TTL TIME STATUS
  0     100.100.100.1              56     64   3ms 
  1     100.100.100.1              56     64   3ms 
    sent=2 received=2 packet-loss=0% min-rtt=3ms avg-rtt=3ms max-rtt=3ms 
Maka PPTP sudah berhasil. 

Share this