Friday, 31 March 2017

Static Routing Mikrotik

Assalamualaikum, 

Pada kali ini, saya akan share materi mengenai routing. Akan tetapi, materi routing yang akan saya share ini mengenai materi static routing. Materi static routing sendiri merupakan materi routing yang ada pada MTCNA. Jadi pada kali ini, saya akan menunjukkan langkah demi langkah untuk melakukan konfigurasi static routing. 


Static routing sendiri merupakan routing yang menambahkan secara static/manual destination maupun gateway yang akan digunakan. Jadi administrator jaringan dapat menentukan mana destination yang akan dituju, dan juga mana gateway yang akan digunakan untuk menuju gateway tersebut. 

Oke langsung saja, kita akan menggunakan topologi sebagai berikut. 


Konfigurasi

Oke pertama tama, tentunya tambahkan address kepada interface yang akan digunakan pada setiap router. Setelah itu, konfigurasikan static routing. Seperti yang sudah kita ketahui sebelumnya bahwa static routing sendiri merupakan routing yang menambahkan secara manual destinasi dan juga gateway yang nantinya akan digunakan oleh sebuah router untuk mencapai tujuan. 

Pada skenario kali ini, R3 akan menuju network 12.12.12.0/24. Lalu bagaimana caranya? Oke, konfigurasikan static routing pada R3. 
[admin@R3] > /ip route
add distance=1 dst-address=12.12.12.0/24 gateway=23.23.23.2


Berdasarkan konfigurasi diatas, kita mendefinsikan mana yang jadi tujuan dan juga mana yang jadi gateway. Untuk destination sendiri, merupakan network yang akan kita tuju. Jangan lupa untuk mendefinisikan subnet yang digunakan oleh network tersebut. Mengapa? Dikarenakan secara default, network yang sudah ditambahkan tersebut apabila tidak disertakan subnet masknya, maka akan secara otomatis menggunakan subnet /32. Oleh karena itu kita harus mengkonfigurasikannya. 

Setelah itu untuk gateway, kita melakukan konfigurasi gateway berdasarkan jalan keluar yang digunakan oleh sebuah router untuk menuju network yang di tuju. Seperti contoh R3 ingin menuju ke R1. Oleh karena itu kita harus mendefinisikan gatewaynya agar R3 menggunakan R2 sebagai gateway menuju ke R1.

Jika sudah, lakukan konfigurasi static routing juga pada R1. Dikarenakan apabila 1 sisi saja, maka tidak akan bisa. 
[admin@R1] > /ip route
add distance=1 dst-address=23.23.23.0/24 gateway=12.12.12.2
Lalu lakukan bahwa R3 dapat menuju ke R1. 


Berdasarkan hasil verifikasi diatas, maka R3 sudah dapat berkomunikasi dengan R1. Oke mungkin sampai sini saja, untuk konfigurasi mendetilnya mengenai static routing pada Mikrotik, insya allah akan saya tambahkan pada materi MTCRE. 

Terimakasih, 
Wassalamualaikum.

Mikrotik as DHCP Server and DHCP Client

Assalamualaikum,

Pada kali ini saya akan share materi mengenai DHCP pada Mikrotik. Seperti yang kita ketahui sebelumnya bahwa DHCP merupakan singkatan dari Dynamic Host Configuration Protocol yang merupakan sebuah service yang ada di dalam sebuah jaringan yang memungkinkan perangkat dapat mendistribusikan ip address secara dynamic dalam sebuah jaringan.


Apabila di sebuah jaringan dijumpai sebuah kasus dimana di dalam jaringan tersebut terdapat banyak sekali perangkat yang masing masing perangkat ingin terhubung ke internet. Tentunya hal tersebut akan sangat menbebani network engineer yang bekerja untuk jaringan tersebut dikarenakan harus mengatur address, DNS, dan juga gateway agar client tersebut dapat terkoneksi ke internet. Namun penggunaan DHCP akan mempermudah agar perangkat yang ada di dalam jaringan tersebut terkoneksi ke internet. 

Hal ini dikarenakan, DHCP akan mendistribusikan ip address ke setiap perangkat. Dan selain itu, DNS dan juga gateway dapat ditambahkan secara otomatis ke dalam sebuah perangkat. Jadi network engineer tidak susah repot repot untuk mengatur semua perangkat. 

Pada artikel kali ini, saya akan menjadikan Mikrotik menjadi DHCP Server dan juga DHCP Client. Perlu diketahui juga, pada Mikrotik kita dapat menggunakan DHCP Server dan juga DHCP Client yang berjalan bersamaan. Akan tetapi perlu diingat, DHCP Server dan DHCP Client tidak bisa dijalankan di interface yang sama. 
Untuk konfigurasi kali ini, saya akan menggunakan topologi seperti yang diatas. Nantinya akan ada yang berfungsi sebagai DHCP Server, dan juga DHCP Client.

DHCP Server


Pada skenario kali ini, R1 akan bertugas seperti DHCP Server. Untuk DHCP Server sendiri, nantinya dia yang akan bertugas untuk mendistribusikan address kepada R2. Sebelum melakukan konfigurasi DHCP Server, tambahkan terlebih dahulu address pada interface ether1 yang berada pada R1. Nantinya, address yang ada di interface ether1 tersebut akan digunakan sebagai gateway untuk client.

[admin@R1] > /ip address
add address=12.12.12.1/24 interface=ether1 network=12.12.12.0
Setelah itu konfigurasikan DHCP Server yang ada pada R1.
[admin@R1] > /ip pooladd name=dhcp_pool2 ranges=12.12.12.2-12.12.12.254

Berdasarkan konfigurasi diatas, yang harus kita buat terlebih dahulu adalah ip pool yang ada pada /ip pool. Pada konfigurasi ip pool, kita bisa menentukan address yang nantinya akan kita berikan kepada client. 

Jika sudah, langkah selanjutnya menambahkan network yang ada pada DHCP Server. Network yang ditambahkan pada DHCP Server, nantinya akan digunakan untuk network pada ip pool. 
[admin@R1] > /ip dhcp-server network

add address=12.12.12.0/24 dns-server=12.12.12.1,8.8.8.8 gateway=12.12.12.1

Setelah itu, definisikan ip pool yang sudah dibuat tadi pada DHCP Server. Didefinisikannya ip pool pada DHCP Server, agar nantinya DHCP Server yang kita buat menggunakan ip pool yang sudah kita buat. 
[admin@R1] > /ip dhcp-server
add address-pool=dhcp_pool2 disabled=no interface=ether1 name=dhcp1

Berdasarkan konfigurasi DHCP Server yang diatas, kita juga perlu mendefinisikan interface yang ingin digunakan sebagai pendistribusian DHCP yang kita buat. Seperti contoh apabila interface yang menuju jaringan local yang menggunakan switch adalah ether1. Maka kita perlu mendifinisikan ether1 sebagai DHCP Server. 

Lalu ada juga lease time. Lease time sendiri digunakan sebagai waktu batasan ip DHCP diberikan kepada client. Apabila address yang diberikan sudah habis lease timenya, maka device tersebut akan secara otomatis untuk memperbarui address yang ada pada interface yang dimilikinya. 

Untuk konfigurasi mengenai syntax yang ada pada DHCP Server, akan saya jelaskan pada penggunaan DHCP yang lebih advance lagi hehehe. 

DHCP Client

Setelah melakukan konfigurasi pada DHCP Server, selanjutnya kita akan melakukan konfigurasi pada client. Seperti yang sudah pada ada topologi yang sebelumnya, mikrotik akan menjadi client. Oke langsung saja ke konfigurasi. 
[admin@R2] > /ip dhcp-client
add disabled=no interface=ether1

Berdasarkan konfigurasi diatas, interface digunakan untuk mendefinisikan sumber interface yang akan mendapatkan DHCP Client. Dikarenakan pada R2 terhubung dengan R1 menggunakan ether1, oleh karena itu kita perlu mendefinisikannya pada R2. 

Setelah itu juga ada use peer dns dan use peer ntp. Saya aktifkan keduanya agar nantinya client selain mendapatkan ip address, maka client juga akan mendapatkan DNS dan juga NTP yang diberikan oleh DHCP Server. 

Lalu juga ada default route yang nantinya pada routing table yang ada pada client, akan secara otomatis ada default route yang akan digunakan apabila client ingin menuju ke network lainnya dan menjadikan R1 sebagai gateway. 

Jangan lupa juga untuk enable DHCP Client yang sudah dibuat. Hal ini dikarenakan secara default, DHCP Client yang dibuat tersebut masih dalam keadaan tidak aktif. Maka kita harus mengaktifkannya.

Jika sudah melakukan konfigurasi DHCP Server dan juga DHCP Client, mari kita lakukan verifikasi pada client terlebih dahulu mengenai address yang di dapatkan. 


Berdasarkan verifikasi diatas, menandakan bahwa DHCP Client yang ada pada R2 sudah mendapatkan ip address yang diberikan pada R1. Selain melihat dari client, lakukan verifikasi juga pada server. 


Berdasarkan verifikasi diatas, menandakan bahwa ada client yang sudah merequest address dari server. Dan juga DHCP Server telah mengirimkan address kepada client tersebut. Apabila kita menggunakan real device, maka akan terlihat mac address dan address yang di dapatkan oleh client. Namun dikarenakan kita menggunakan GNS3, saya juga gatau itu kenapa hehehe. 

Oke pada materi kali ini sampai sini saja, nantinya saya akan menambahkan materi lebih lanjut mengenai DHCP. 

Terimakasih, 
Wassalamualaikum. 

Wednesday, 29 March 2017

Network Time Protocol (NTP)

Assalamualaikum, 


Pada kali ini, saya akan share mengenai NTP. Sebenernya, apasih itu NTP? 
NTP merupakan kepanjangan dari Network Time Protocol yang akan memungkinkan adanya mekanisme yang akan melakukan sinkronisasi terhadap waktu yang ada pada dalam sebuah jaringan. 
Dari pengertian tersebut, kita dapat mengambil kesimpulan bahwa NTP akan melakukan sinkronisasi waktu kepada device yang ada pada sebuah jaringan. Untuk melakukan sinkronisasi dengan device lainnya, NTP menggunakan UDP dengan port 123. 

NTP sendiri digunakan dalam sebuah jaringan agar waktu dalam jaringan tersebut tersinkronisasi dengan waktu sebenarnya. Jadi kita dapat mengetahui waktu yang tepat dari setiap perangkat yang ada. Lalu apakah setiap device harus di konfigurasi NTP Server agar semuanya tersinkronisasi? Jawabannya tidak. Dikarenakan menggunakan sebuah NTP Server saja juga sudah cukup agar jaringan local tersebut dapat saling tersinkronisasi waktunya. 

NTP untuk router sendiri juga akan membantu untuk membangun jaringan yang baik. Seperti contoh di dalam sebuah perusahaan ingin agar karyawannya dapat mengakses internet hanya dalam waktu waktu tertentu saja. Sebelum di buat rulenya, tentunya kita harus membuat agar waktu yang ada pada router agar tersinkronisasi secara realtime dengan waktu yang sebenarnya. Oleh karena itu, pada postingan kali ini, saya akan menunjukkan cara agar mikrotik bekerja sebagai NTP Server dan juga sebagai NTP Client. 

NTP Client

Seperti yang diketahui sebelumnya bahwa di dalam jaringan sendiri, akan ada yang bertindak sebagai client dan sebagai server, dan hal itu juga berlaku dalam NTP. Dalam penggunaan NTP, kita memerlukan adanya server di dalam jaringan tersebut, dan client yang akan melakukan sinkronisasi waktu yang ada pada server. Mikrotik sendiri dapat menjalankan keduanya secara bersamaan. Jadi sebelum kita melakukan konfigurasi NTP Server, kita konfigurasikan NTP Client terlebih dahulu agar waktu pada router tersinkronasi dengan public server. 

Untuk NTP pada Mikrotik , akan memanfaatkan SNTP (Simple Network Time Protocol) Client, dan packagenya sudah ada sebelumnya, jadi kita dapat memanfaatkannya dengan melakukan konfigurasi secara langsung. 

Sebelum melakukan konfigurasi, kita tentunya harus menentukan terlebih dahulu, akan memilih public server yang mana yang akan dijadikan NTP server yang nantinya akan di definisikan pada Mikrotik. Untuk server sendiri, anda dapat melihatnya pada website http://www.pool.ntp.org/en/

Jika sudah menemukan server yang kira kiranya cocok untuk digunakan, selanjutnya melakukan konfigurasi NTP Client pada Mikrotik. 


Seperti yang terlihat pada gambar diatas, untuk melakukan konfigurasi sendiri, kita dapat melakukan konfigurasi pada System > NTP Client. Setelah itu akan muncul tab NTP Client. Dikarenakan kita ingin mengaktifkan NTP Client pada Mikrotik, tentu saja enable terlebih dahulu NTP Client yang akan digunakan. 

Jika sudah, ada mode yang dapat digunakan. Untuk mode sendiri, kita dapat menentukan mode yang akan di operasikan oleh Mikrotik itu sendiri.  Saya sendiri kurang tau sih hehehe. Selanjutnya, definisikan public server yang sudah kita pilih tadi. Untuk penggunaannya, kita dapat menggunakan address ataupun domain dari server tersebut. Jika sudah, apply. 


Jika sudah, kita tinggal mendefinisikan dimana kita tinggal. Seperti misalkan saya yang berada di jonggol yang masih menggunakan waktu jakarta. Jika sudah, apply. Lalu waktu akan sinkron dengan waktu yang sebenarnya. *Disini udah jam 1 ya hehehe. 

NTP Server

Sebelumnya kita sudah melakukan konfigurasi NTP Client pada mikrotik. Selanjutnya, kita akan mempergunakan mikrotik sebagai NTP Server untuk jaringan local. Oleh karena itu kita akan melakukan konfigurasi NTP Server. Namun sebelumnya perlu di ketahui sebelumnya, Mikrotik secara default tidak memiliki fungsi NTP Server, oleh karena itu download terlebih dahulu package ntp.npk.

Jika sudah sekarang kita akan melakukan konfigurasi NTP Server. 


Berdasarkan konfigurasi diatas, kita tentunya harus enable terlebih dahulu service NTP Server yang nantinya akan digunakan. Selanjutnya, kita dapat memilih metode penyebarannya, apakah broadcast, multicast, atau manycast. Lalu ada broadcast address yang dipergunakan untuk mendefinisikann tujuan utama NTP Server itu dibuat untuk siapa. Hal ini akan memungkinkan agar NTP Server tidak digunakan dari jaringan public. 

Tuesday, 28 March 2017

PPP Dynamic Simple Queue

Assalamualaikum,


Pada kali ini saya akan share materi lanjutan mengenai PPP. Sebelumnya saya sudah posting materi PPP yang dapat di lihat disini

Seperti yang kita ketahui sebelumnya, queue merupakan limitasi yang dapat diterapkan pada sebuah traffic untuk membatasi traffic yang ada pada dalam jaringan. Dan pada mikrotik sendiri, kita dapat menggunakn simple queue dan juga queue tree. 

Namun pada kali ini, kita akan menerapkan queue pada PPP Profile. Dalam penerapannya, nantinya sebuah user akan mendapatkan limitasi dari konfigurasi yang dibuat di PPP Profile. 

Dalam penggunaan queue yang diterapkan pada PPP Profile akan ada saatnya apabila sebuah administrator jaringan akan melimit pada tunneling PPP yang ada. Apabila ada suatu kasus yang mengharuskan kita melimit berdasarkan grup yang ada, maka kita dapat melakukan konfigurasi pada PPP Profile. 


Seperti yang terlihat pada diatas, kita dapat melakukan konfigurasi pada PPP Profile > Limits. Dalam penentuan limit juga kita perlu mempertimbangkan apa saja yang akan di tambahkan limitasinya. 

Dalam hal ini, PPP Profile sendiri mempunyai format untuk menentukan queue yang akan diterapkan pada PPP Profilenya. 
rx-rate/tr-rate rx-burst-rate/tx-burst-rate rx-burst-threshold/tx-burst-threshold rx-burst-time/tx-burst-time priority rx-rate-min/tx-rate-min
Sesuai dengan namanya dynamic simple queue maka nantinya limitasi yang sudah kita buat akan ada secara otomatis pada simple queue.  Namun perlu diketahui, yang kita buat adalah dynamic simple queue. Untuk queuenya sendiri, akan muncul apabila ada user yang connect dengan secret yang menggunakan profile yang sudah di limit tadi. Jadi apabila tidak ada user yang connect, maka tidak akan muncul queue yang kita buat tadi. 

Apabila saya menerapkan rate limit seperti contoh diatas, dan berikut hasil dynamic simple queue yang ada secara otomatis.


Seperti yang terlihat pada gambar diatas, terlihat bahwa queue tersebut sifatnya dynamic. Jadi hanya ada apabila ada client yang connect. Mungkin hanya sampai sini saja. 

Terimakasih, 
Wassalamualaikum.

PPP (Point to Point Protocol)

Assalamualaikum,


Sebelumnya masih pada materi MTCUME, kita sudah mengenal banyak tunneling protocol yang umum digunakan di dalam dunia jaringan. Namun pada sebelum sebelumnya, masih belum mengenal PPP di dalam mikrotik. Seharusnya dijelaskan dari awal, tapi saya lupa hehehe. 

Oke sesuai dengan judul artikel kali ini, kita akan membahas mengenai Point to point protocol. Seperti namanya sendiri yaitu point to point, PPP merupakan sebuah platform yang digunakan untuk menghubungkan sebuah titik dengan titik lainnya yang saling membuat jaringan private dalam hubungan keduanya. Hal ini berarti akan memungkinkan jaringan private dibentuk dalam jaringan point to point. 

PPP sendiri menggunakan beberapa jenis autentikasi yang dapat digunakan, yaitu ada PAP dan CHAP. PAP (Password Authentication Protocol) sendiri merupakan jenis autentikasi yang akan membutuhkan user dan password dalam pembentukan kedua titik yang akan saling terhubung. Sedangkan CHAP (Challange Handshake Authentication Protocol) sendiri, merupakan sebuah autentikasi yang akan membutuhkan dial up sebagai proses autentikasi.

Dalam penggunaannya sendiri, ada beberapa jenis PPP tunnel yang dapat dibentuk, diantaranya sebagai berikut. 
  1. PPPoE (Point to Point over Ethernet)
  2. PPTP (Point to Point Tunneling Protocol)
  3. L2TP (Layer 2 Tunneling Protocol)
  4. SSTP (Secure Socket Tunneling Protocol) 
Seperti yang terlihat pada daftar diatas, ada beberapa tunneling yang akan membuat point to point dari suatu perangkat ke perangkat lainnya. Dalam daftar di atas juga tersedia tutorial untuk membuat servernya di mikrotik dan konfigurasi mikrotik sebagai clientnya, jadi visit ya hehehe. 

Cara kerja

Cara kerja PPP sendiri yaitu akan menggunakan dial up yang akan dikonfigurasikan kepada device yang ingin terhubung ke server. Dial up ini nantinya akan mengirimkan permintaan hubungan point to point dengan server. Lalu apabila server tersebut memiliki autentikasi, entah itu menggunakan PAP atau CHAP, maka client akan mengirimkan juga autentikasi agar dapat terhubung dengan server. 

Apabila sudah, maka kedua device tersebut akan membuat hubungan point to point menggunakan sebuah jalur yang di bentuk dari hubungan point to point tersebut. 

PPP Mikrotik

Mikrotik dapat dijadikan sebagai server dari hubungan tunneling tersebut. Jadi nantinya apabila ada client yang ingin melakukan hubungan point to point tersebut, maka akan terdaftar di mikrotik. Untuk konfigurasi sendiri, anda dapat melihat daftar tunneling yang ada di atas. 
Lalu pada kali ini saya akan membahas tentang PPP yang ada di mikrotik. Dalam membuat hubungan PPP, tentunya sebuah server dibutuhkan agar hubungan antar kedua device tersebut dapat terjalin, dan dalam kasus ini mikrotik dapat digunakan sebagai PPP server. 


Seperti yang terlihat pada gambar di atas, terlihat untuk melakukan konfigurasi PPP Profile. PPP Profile sendiri digunakan untuk mengelompokkan user berdasarkan aturan yang akan mereka gunakan. 

 

Seperti yang terlihat pada ilustrasi diatas, kita mengelompokkan beberapa user dengan aturan yang berbeda beda. Seperti contoh profile1 tidak menggunakan queue, dan sedangkan profile2 memiliki limitasi. Maka kita dapat menggunakan PPP Profile untuk mengelompokkannya. Parameter yang sering di gunakan sendiri ada beberapa, diantara lain seperti berikut
  • Local address dan Remote Address
Dalam penggunaan local address dan remote address, tentunya kita dapat menentukan address yang nantinya akan digunakan dalam hubungan tunneling. Local address merupakan address yang diberikan kepada server apabila hubungan terjalin. Dan sedangkan remote address merupakan address yang diberikan server kepada client untuk dapat berkomunikasi menggunakan tunnel yang sudah dibuat. 
  • Use Encryption    
Dari namanya tentunya kita sudah dapat mengetahui. Ya, use encryption merupakan opsi yang digunakan apabila kita ingin menggunakan enkripsi pada jaringan VPN yang dibuat itu atau tidak.
  • Only One
Hal ini akan menandakan apakah profile yang kita buat tadi akan digunakan oleh 1 user, ataupun banyak user. Seperti yang di ilustrasi sebelumnya, ada 2 user yang menggunakan profile yang sama. Apabila only one di set yes, maka hanya ada 1 user yang dapat menggunakan profile tersebut. 
  • Session Timeout 
Dalam penggunan timeout, akan menetapkan durasi maximal dari sebuah user untuk dapat menggunakan profile tersebut
  • Idle Timeout
Dalam penggunaannya, idle timeout akan memungkinkan server memutuskan hubungan dengan client apabila tidak ada traffic selama batas waktu yang ditentukan. 
Jika sudah, perlu diingat bahwa PPP Profile merupakan sebuah aturan yang dapat diterapkan kepada sebuah user. Jadi jangan beranggapan setelah membuat PPP Profile kita dapat langsung melakukan konektifitas dengan server, akan tetapikita harus membuatnya terlebih dahulu. Untuk membuatnya, kita buat pada PPP Secret. Lalu apa itu PPP Secret? 
PPP Secret
PPP Secret merupakan database yang ada pada router yang akan menyediakan user beserta databasenya agar user tersebut dapat terhubung dengan server. Jadi oleh karena itu kita harus membuat usernya pada PPP Secret
Dalam penggunaan PPP Secret sendiri, kita dapat memungkinkan untuk mendaftarkan /32 sebagai address tunnelin yang akan mereka gunakan. Jadi tidak harus /30 juga tidak apa apa. 
  
Seperti yang terlihat pada gambar diatas, konfigurasi tersebut digunakan untuk membuat PPP Secret yang nantinya akan digunakan untuk user. Mari kita jabarkan satu satu konfigurasi yang bisa digunakan untuk PPP Secret tersebut. 
  •  Name & Password
Untuk name dan password sendiri, nantinya akan digunakan oleh client sebagai autentikasi apabila ingin melakukan dial up ke server. Jadi pada client apabila sudah menambahkan kemana ia ingin melakukan konektivitas (dial up), perlu di definisikan juga usernya agar autentikasi berhasil dilewati oleh client. 
  • Service
Service sendiri merupakan parameter yang digunakan untuk menyatakan service mana yang dapat menggunakan user yang sudah dibuat tadi. Apabila kita menggunakan PPPoE ya harus mendefinisikan PPPoE. Atau apabila akan menggunakan SSTP, ya harus mendefinisikan juga pada kolom service tersebut. Apabila di set any, maka seluruh service dapat menggunakan user tersebut. 
  • Caller ID
Caller id digunakan apabila sebuah router hanya menghendaki beberapa address saja yang dapat menggunakan user tersebut. Dan perlu diingat, apabila menggunakan address, maka PPTP dan L2TP yang harus menjadi hubungan client dengan server. Lalu juga bisa menggunakan Mac address yang akan dikehendaki. Maka hanya dapat menggunakan PPPoE.  
  • Profile
Seperti yang sudah di jelaskan sebelumnya, definisikan user tersebut masuk grup yang mana. 
  • Routes
Routes sendiri akan digunakan apabila ada network yang juga di advertise oleh server kepada client. 
  • Limit Byte In
Limit Byte in sendiri digunakan apabila kita ingin membatasi upload pada client.    
  • Limit Byte Out
Limit Byte Out sendiri digunakan apabila kita ingin membatasi download pada client. 
Oke mungkin hanya segitu dulu, Insya allah nanti akan saya tambahkan kembali materi mengenai PPP. 

Terima kasih, 
Wassalamualaikum.