Saturday, 11 February 2017

MPLS VPLS

Assalamualaikum,
E:\Superlab23.png
Tujuan lab :
  1. Semua router dapat berkomunikasi
  2. Menggunakan VPLS Tunnel untuk menghubungkan R7 dan R8.

Pertama tama, tambahkan ip address terlebih dahulu kepada setiap interface yang akan digunakan pada router.
Setelah menambahkan ip address, kita akan menggunakan routing rip untuk menghubungkan setiap router yang ada. Namun untuk router 7 dan 8, nantinya keduanya akan menggunakan static route saja.
[admin@R1] > /routing rip
set default redistribute-connected=yes
[admin@R1] > /routing rip network
add disabled=no network=12.12.12.0/24
add disabled=no network=14.14.14.0/24
[admin@R2] > /routing rip
set redistribute-connected=yes
[admin@R2] > /routing rip network
add disabled=no network=12.12.12.0/24
add disabled=no network=26.26.26.0/24
add disabled=no network=23.23.23.0/24
[admin@R3] > /routing rip
set redistribute-connected=yes
[admin@R3] > /routing rip network
add disabled=no network=23.23.23.0/24
add disabled=no network=34.34.34.0/24
add disabled=no network=35.35.35.0/24
[admin@R4] > /routing rip
set redistribute-connected=yes
[admin@R4] > /routing rip network
add disabled=no network=34.34.34.0/24
add disabled=no network=14.14.14.0/24
[admin@R5] > /routing rip
set redistribute-connected=yes
[admin@R5] > /routing rip network
add disabled=no network=35.35.35.0/24
[admin@R6] > /routing rip
set redistribute-connected=yes
[admin@R6] > /routing rip network
add disabled=no network=26.26.26.0/24
Berdasarkan konfigurasi routing rip diatas, kita akan redistribute loopback yang ada pada router agar nanti semuanya dapat mengetahui loopback dari setiap router. Setelah itu, kita akan melakukan konfigurasi MPLS. MPLS yang akan kita gunakan pada kali ini adalah MPLS LDP dimana MPLS tersebut akan memberikan label terhadap setiap packet yang ada di dalam jaringan tersebut secara dinamis sehingga kita tidak perlu mendefinisikan satu persatu packet yang nantinya akan diterima ataupun dikirimkan. 
[admin@R1] > /mpls ldp
set enabled=yes lsr-id=1.1.1.1 transport-address=1.1.1.1
[admin@R1] > /mpls ldp interface
add interface=ether1
add interface=ether2
[admin@R2] > /mpls ldp
set enabled=yes lsr-id=2.2.2.2 transport-address=2.2.2.2
/mpls ldp interface
add interface=ether1
add interface=ether2
add interface=ether3
[admin@R3] > /mpls ldp
set enabled=yes lsr-id=3.3.3.3 transport-address=3.3.3.3
[admin@R3] > /mpls ldp interface
add interface=ether1
add interface=ether2
add interface=ether3
[admin@R4] > /mpls ldp
set enabled=yes lsr-id=4.4.4.4 transport-address=4.4.4.4
[admin@R4] > /mpls ldp interface
add interface=ether2
add interface=ether1
[admin@R5] > /mpls ldp
set enabled=yes lsr-id=5.5.5.5 transport-address=5.5.5.5
[admin@R5] > /mpls ldp interface
add interface=ether1
[admin@R6] > /mpls ldp
set enabled=yes lsr-id=6.6.6.6 transport-address=6.6.6.6
[admin@R6] > /mpls ldp interface
add interface=ether1
Berdasarkan konfigurasi diatas, LSR-ID akan digunakan sebagai identitas router tersebut dalam jaringan MPLS. Dan sedangkan transport address sendiri, merupakan identitas sebuah packet yang dikirimkan oleh router terseut kepada router MPLS lainnya. Biasanya, lsr-id dan juga transport address menggunakan loopback. Setelah itu kita akan menggunakan VPLS.

VPLS sendiri merupakan sebuah protocol tunneling layer 2 yang berjalan diatas MPLS. Dalam penggunaannya, VPLS akan memanfaatkan label LDP yang telah kita konfigurasi tadi untuk negosiasi antar host. Dalam VPLS, koneksi virtual yang menghubungkan antar router disebut dengan pseudowire. Nantinya, pseudowire ini yang akan menghubungkan antar jaringan local. Lalu untuk konfigurasi sendiri tidak jauh berbeda dengan eoip, hanya perlu menambahkan vpls pada kedua sisi. Untuk perbedaan sendiri, VPLS lebih cepat 60% dibandingkan dengan eoip.
[admin@R5] > /interface vpls
add name=vpls1 remote-peer=6.6.6.6 vpls-id=10:10

[admin@R6] > /interface vpls
add name=vpls1 remote-peer=5.5.5.5 vpls-id=10:10
Berdasarkan konfigurasi diatas, pembuatan VPLS menggunakan vpls-id untuk menghubungkan kedua router yang ingin berhubungan. VPLS id sendiri disusun dari AS:Unique Number. Jadi apabila ada router yang ingin berhubungan, maka vpls id antara kedua router haruslah sama. 

Setelah itu kita akan melakukan konfigurasi bridge pada kedua router. Seperti yang kita ketahui sebelumnya bahwa tunnel vpls sendiri merupakan layer 2 tunneling sehingga dibutuhkan bridge port antara interface vpls dengan interface yang terhubung dengan jaringan local. 
[admin@R6] > /interface bridge
add name=vpls
[admin@R6] > /interface bridge port
add bridge=vpls interface=vpls1
add bridge=vpls interface=ether2
[admin@R5] > /interface bridge
add name=vpls
[admin@R5] > /interface bridge port
add bridge=vpls interface=vpls1
add bridge=vpls interface=ether2
Untuk verifikasi apakah tunnel sudah berhasil dibuat atau belum, dapat dilihat pada MPLS LDP neighbor. 
 
Berdasarkan hasil konfigurasi diatas, MPLS LDP neighbors mendeteksi adanya router yang menggunakan tunneling VPLS dengan VPLS id yang sama, sehingga otomatis neighbor akan ditambahkan pada MPLS LDP neighbor.

Share this