Saturday, 11 February 2017

MPLS L3VPN + TE Tunnel Lab

Assalamualaikum,
C:\Users\Rafi\Pictures\Superlab24.png

Tujuan lab :
  1. Semua router dapat terhubung
  2. MPLS TE untuk membuat tunneling
  3. L3VPN untuk menghubungkan R5-R8

Pertama tama buat interface bridge terlebih dahulu agar nantinya router dapat memiliki loopback pada drinya. 
[admin@Rx] > /interface bridge
add name=lo
Setelah itu tambahkan Ip address kepada interface yang ada pada router dan juga kepada interface loopback yang tadi sudah kita buat.
Jika sudah dibuat, selanjutnya kita akan menghubungkan router yang akan menggunakan MPLS menggunakan routing RIP. 
[admin@R1] > /routing rip
set redistribute-connected=yes
[admin@R1] > /routing rip network
add disabled=no network=12.12.12.0/24
add disabled=no network=13.13.13.0/24
[admin@R2] > /routing rip
set redistribute-connected=yes
[admin@R2] > /routing rip network
add disabled=no network=12.12.12.0/24
add disabled=no network=24.24.24.0/24
[admin@R3] > /routing rip
set redistribute-connected=yes
[admin@R3] > /routing rip network
add disabled=no network=13.13.13.0/24
add disabled=no network=34.34.34.0/24
[admin@R4] > /routing rip
set redistribute-connected=yes
[admin@R4] > /routing rip network
add disabled=no network=24.24.24.0/24
add disabled=no network=34.34.34.0/24
Jika sudah, pastikan terlebih dahulu setiap router sudah dapat saling terhubung. Setelah itu kita akan menggunakan MPLS LDP untuk penggunaan MPLS.
[admin@Rx] > /mpls ldp
set enabled=yes lsr-id=x.x.x.x transport-address=x.x.x.x
[admin@Rx] > /mpls ldp interface
add interface=ether1
add interface=ether2
Berdasarkan konfigurasi diatas, LSR ID akan dijadikan sebagai identitas sebuah router di dalam jaringan MPLS. Sedangkan transport address akan digunakan sebagai identitas sebuah packet apabila dikirimkan ke router lain. Oke selanjutnya kita akan melakukan konfigurasi MLPS Traffic Engineering.
[admin@Rx] > /mpls traffic-eng interface
add bandwidth=10Mbps interface=ether1
add bandwidth=10Mbps interface=ether2
Pada konfigurasi MPLS TE, MPLS akan memungkinkan kita untuk melakukan konfiurasi bandwith untuk interface TE tersebut. Seperti contoh pada konfigurasi diatas, kita akan memberikan bandwith untuk MPLS TE sebesar 10M kepada setiap interface yang telah di definisikan tadi. 

Selanjutnya kita akan melakukan konfigurasi tunnel path pada MPLS TE. Konfigurasi tunnel path sendiri pada MPLE TE akan memungkinkan antara router membuat hubungan tunneling dengan menggunakan MPLS TE. 
[admin@R1] > /mpls traffic-eng tunnel-path
add disabled=no hops=12.12.12.2:strict,24.24.24.2:strict,24.24.24.4:strict name=R1-R2-R4 record-route=yes reoptimize-interval=30s use-cspf=no
add disabled=no name=dynamic-tunnel use-cspf=yes
[admin@R4] /mpls traffic-eng tunnel-path
add disabled=no hops=34.34.34.3:strict,13.13.13.3:strict,13.13.13.1:strict name=R4-R3-R1 record-route=yes reoptimize-interval=30s use-cspf=no
add disabled=no name=dynamic-tunnel use-cspf=yes
Berdasarkan konfigurasi diatas, kita akan menambahkan tunnel path atau jalur tunnel untuk membuat tunnel ke router lainnya. Konfigurasi hops pada tunnel path akan mendefinisikan jalur mana saja yang akan dilewati oleh sebuah router untuk membuat hubungan tunnel dengan router lain. Seperti contoh konfigurasi hops diatas, router akan mendefinisikan address mana saja yang akan dilewati oleh tunneling.

Setelah itu ada reoptimize interval yang akan memeriksa link utama tersebut dalam keadaan up atau down. Apabila sedang down, maka jalur backup akan bekerja dan juga router akan terus memeriksa jalur utama selama waktu yang telah kita definisikan tadi. Hal ini dikarenakan jalur utama lebih di prioritaskan.

Kemudian pada konfigurasi use-cspf, pada static tunnel path, kita atur agar router tidak menggunakan jalur terpendek menuju ke tunnel lainnya. Hal ini dikarenakan sebelumnya kita sudah menambahkan hops mana saja yang akan dilewati. Apabila kita set use-cspf yes, maka hops yang tadinya sudah kita buat tidak akan berguna. 
[admin@R1] /interface traffic-eng
add bandwidth=10Mbps bandwidth-limit=100% disabled=no from-address=1.1.1.1 name=toR4 primary-path=R1- R2-R4 record-route=yes secondary-paths=dynamic- tunnel to-address=4.4.4.4
[admin@R4] /interface traffic-eng
add bandwidth=10Mbps bandwidth-limit=100% disabled=no from-address=4.4.4.4 name=toR1 primary-path=R4- R3-R1 record-route=yes secondary-paths=dynamic- tunnel to-address=1.1.1.1
Berdasarkan konfigurasi diatas, interface traffic engineering akan mendefinisikan tunnel path yang telah kita buat tadi. Untuk primary path, kita masukkan tunnel path yang menggunakan hops dan sedangkan secondary path, kita masukkan path yang menggunakan cspf. Setelah itu lakukan verifikasi.

Oke selanjutnya kita akan menggunakan protocol L3VPN untuk menghubungkan router client. Untuk protocol L3VPN sendiri hanya dapat dijalankan oleh routing BGP. Oleh karena itu, tambahkan BGP pada router 1 dan router 4. Konfigurasi BGP Instance terlebih dahulu. 
[admin@R1/R4] > /routing bgp instance
set default as=100
Jika sudah, selanjutnya buat peering antara R1 dan juga R4. 
[admin@R1] > /routing bgp peer
add address-families=vpnv4 name=peer1 remote-address=4.4.4.4 remote-as=100 update-source=lo  
[admin@R4] > /routing bgp peer
add address-families=vpnv4 name=peer1 remote-address=1.1.1.1 remote-as=100 update-source=lo 
Pada konfigurasi BGP Peer, address-families akan menandakan bahwa hubungan yang dijalin kedua router untuk VPN. Kemudian peering yang digunakan kedua router menggunakan interface loopback yang ada pada kedua router tersebut. Setelah bgp peer sudah dibuat, kemudian kita akan menggunakan route vrf. 
[admin@R1/R4] > /ip route vrf
add disabled=no export-route-targets=100:1 import-route-targets=100:1 interfaces=ether3 route-distinguisher=100:1 routing-mark=vrf1
add disabled=no export-route-targets=100:2 import-route-targets=100:2 interfaces=ether4 route-distinguisher=100:2 routing-mark=vrf2
Route VRF sendiri merupakan virtual routing forwarding yang memungkinkan network yang sama dapat saling berhubungan walaupun berada dalam interface yang berbeda beda. Oleh karena itu kita akan menggunakan vrf untuk menghubungkan network yang berada diluar router dan juga di dalam router seolah olah network network tersebut saling terhubung.
Lalu pada konfigurasi terlihat route distinguisher, import route targets, dan juga export route targets. Untuk route-distinguisher itu akan berfungsi sebagai domain router tersebut dalam vrf. Sedangkan export, router tersebut apabila ingin mengirimkan sebuah packet kepada router lainnya, maka router tersebut hanya akan mengirimkan packet tersebut kepada yang memiliki domain yang telah di definisikan. Dan apabila router tersebut menerima sebuah packet, maka router tersebut hanya akan menerima packet dari domain yang telah di definisikan.

Setelah itu lakukan konfigurasi bgp instance vrf untuk mendefinisikan vrf yang ada pada router tersebut. 
[admin@R1/R4] > /routing bgp instance vrf
add redistribute-connected=yes routing-mark=vrf1
add redistribute-connected=yes routing-mark=vrf2
Jika sudah, lakukan verifikasi ping dari router client ke client lainnya.
[admin@R5] > ping 47.47.47.7
HOST            SIZE TTL TIME STATUS
47.47.47.7     56     61    11ms
sent=1 received=1 packet-loss=0% min-rtt=11ms avg-rtt=11ms max-rtt=11ms
Dikarenakan R5 dengan R7 memiliki domain yang sama, maka keduanya dapat saling berkomunikasi satu sama lain. Lalu coba ping ke domain yang berbeda. 
[admin@R5] > ping 48.48.48.8
HOST            SIZE TTL TIME STATUS
15.15.15.1     84     64    1ms   net unreachable
sent=1 received=0 packet-loss=100%
Dikarenakan R5 dan R8 tidak berada dalam domain yang sama, maka keduanya tidak dapat saling berkomunikasi.

Share this