Saturday, 11 February 2017

MPLS L2VPN

Assalamualaikum,
C:\Users\Rafi\Documents\Superlab25.png
Tujuan lab :
  1. Menghubungkan seluruh router
  2. Menggunakan L2VPN sebagai penghubung router client.

Pertama tama, buat interface bridge terlebih dahulu agar nanti interface bridge digunakan sebagai loopback. 
[admin@Rx] > /interface bridge
add name=lo
Setelah itu, tambahkan ip address kepada interface yang nanti akan digunakan dalam lab ini. 
Apabila sudah ditambahkan, selanjutnya adalah melakukan konfigurasi routing agar jaringan MPLS dapat mengenali siapa saja rekannya. Kita akan menggunakan routing RIP.
[admin@R1] > /routing rip
set redistribute-connected=yes
[admin@R1] > /routing rip network
add disabled=no network=12.12.12.0/24
[admin@R2] > /routing rip
set redistribute-connected=yes
[admin@R2] > /routing rip network
add disabled=no network=23.23.23.0/24
add disabled=no network=12.12.12.0/24
[admin@R3] > /routing rip
set redistribute-connected=yes
[admin@R3] > /routing rip network
add disabled=no network=23.23.23.0/24
Apabla sudah selesai, selanjutnya tentu mengaktifkan MPLS pada jaringan tersebut. Saya akan menggunakan MPLS LDP.
[admin@R1] > /mpls ldp
set enabled=yes lsr-id=1.1.1.1 transport-address=1.1.1.1
[admin@R1] > /mpls ldp interface
add interface=ether1
[admin@R2] > /mpls ldp
set enabled=yes lsr-id=2.2.2.2 transport-address=2.2.2.2
[admin@R2] > /mpls ldp interface
add interface=ether1
add interface=ether2
[admin@R3] > /mpls ldp
set enabled=yes lsr-id=3.3.3.3 transport-address=3.3.3.3
[admin@R3] > /mpls ldp interface
add interface=ether1
Jika sudah, selanjutnya kita akan menghubungkan jaringan local. Dalam dunia internet, tentunya kita dapat menemukan banyak sekali router diluar sana yang menggunakan ip address dengan network yang sama. Oleh karena itu, kali ini kita akan menggunakan MPLS sebagai pengantar BGP yang akan bertugas untuk mengantarkan L2VPN karena hanya BGP yang dapat menjalankan L2VPN. Konfigurasi instance bgp terlebih dahulu pada router 1 dan router 3. 
[admin@R1/R3] > /routing bgp instance
set default as=100
Setelah itu tambahkan peering antara R1 dan juga R3. 
[admin@R3] > /routing bgp peer
add address-families=l2vpn remote-address=1.1.1.1 remote-as=100 update-source=lo
[admin@R1]  /routing bgp peer
add address-families=l2vpn remote-address=3.3.3.3 remote-as=100 update-source=lo
Terlihat pada konfigurasi bgp peer diatas, address families digunakan untuk mendefinisikan untuk apa routing bgp tersebut. Dikarenakan kita akan menggunakan routing bgp untuk penggunaan L2VPN, maka kita definisikan address families L2VPN. Selanjutnya, lakukan konfigurasi VPLS.
[admin@Rx] > /interface vpls bgp-vpls
add export-route- targets=100:1 import-route- targets=100:1 name=bgp-vpls1 route-distinguisher=100:1 site-id=x
add export-route- targets=100:2 import-route- targets=100:2 name=bgp-vpls2 route-distinguisher=100:2 site-id=x
Berdasarkan konfigurasi diatas, route-distinguisher akan berperan sebagai domain untuk network yang ia miliki. Lalu import-route akan bertugas untuk mendefinisikan darimana saja packet yang boleh diterima. Lalu ada export-route yang akan bertugas untuk mendefinisikan darimana packet tersebut berasal. Jadi router lainnya dapat mengetahui asal dari packet tersebut. Lalu ada site-id yang akan mendefinisikan dari daerah mana ia berasal. Untuk site id setiap router yang menjalankan vpls ini tidak boleh sama dikarenakan site id akan berperan sebagai identitas daerah dimana dia berada.Jika sudah, buat bridge untuk setiap domain.
[admin@Rx] > /interface bridge
add name=100:1
add name=100:2
Lalu tambahkan bridge port untuk bridge tersebut. Untuk bridge port, masukkan vpls sesuai domain yang telah kita buat sebelumnya. 
[admin@Rx] > /interface bridge port
add bridge=100:1 interface=ether2
add bridge=100:1 interface=vpls1
[admin@Rx] > /interface bridge port
add bridge=100:2 interface=ether3
add bridge=100:2 interface=vpls2
Berdasarkan konfigurasi diatas, dikarenakan kita menggunakan L2VPN, maka bridge sangat diperlukan untuk memhubungkan domain yang telah dibuat dengan interface local. Coba lakukan verifikasi ping dari salah satu router client.
[admin@R7] > ping 10.10.10.6
HOST             SIZE TTL TIME STATUS
10.10.10.6      56     64    13ms
sent=1 received=1 packet-loss=0% min-rtt=13ms avg-rtt=13ms max-rtt=13ms
[admin@R7] > ping 10.10.10.4
HOST             SIZE TTL TIME STATUS
10.10.10.4                                 timeout
sent=1 received=0 packet-loss=100%
Mengapa dari R7 tidak dapat melakukan ping kepada R4? Hal ini dikarenakan R4 dan juga R7 berbeda domain. Sedangkan R6 dan R7 berada dalam domain yang sama, sehingga kedua router tersebut dapat saling berhubungan hanya dengan konfigurasi ip address saja dan tanpa adanya routing.

Share this