Saturday, 11 February 2017

MPLS Static Labeling

Assalamualaikum,
E:\Staticlabtopo.png
Tujuan lab pada kali ini :
  • Mengubungkan setiap router
  • Menggunakan static labeling pada MPLS


Pertama tama konfigurasi ip address terlebih dahulu untuk setiap router yang ada.
Lalu setelah itu, kita akan menggunakan routing rip untuk menghubungkan network pada router yang menggunakan MPLS. 
[admin@R1] > /routing rip
set redistribute-connected=yes
[admin@R1] > /routing rip network
add disabled=no network=12.12.12.0/24
[admin@R2] > /routing rip
set redistribute-connected=yes
[admin@R2] > /routing rip network
add disabled=no network=12.12.12.0/24
add disabled=no network=23.23.23.0/24
[admin@R3] > /routing rip
set redistribute-connected=yes
[admin@R3] > /routing rip network
add disabled=no network=23.23.23.0/24
add disabled=no network=34.34.34.0/24
[admin@R4] > /routing rip
set redistribute-connected=yes
[admin@R4] > /routing rip network
add disabled=no network=34.34.34.0/24

Setelah itu konfigurasikan label range pada router. 
[admin@Rx] > /mpls
set dynamic-label- range=200-1048575

Untuk konfigurasi dynamic label range, ini mendefinisikan label dynamic yang nantinya akan diberikan kepada router apabila labeling secara dynamic digunakan. Contoh dari penggunaan labeling secara dynamic sendiri yaitu menggunakan MPLS LDP. Berdasarkan konfigurasi di atas, kita akan memberikan label dynamic range 200-1048575. Dalam artian, nantinya apabila digunakannya labeling dynamic, maka akan diberikan label dimulai dari 200 sampai dengan 1048575. Sedangkan karena kita akan melakukan konfigurasi static labeling, maka nantinya static labeling dapat dimulai dari angka 16 sampai dengan 199. 
[admin@R1] > /mpls local-bindings
add disabled=no dst-address=1.1.1.1/32 label=impl-null
[admin@R1] > /mpls remote-bindings
add disabled=no dst-address=4.4.4.4/32 label=21 nexthop=12.12.12.2
Berdasarkan konfigurasi diatas, local binding akan mendefinisikan konfigurasi apabila ada packet yang bertujuan ke address 1.1.1.1, maka address itu ditandai dengan impicit null. Implicit null sendiri merupakan label yang berapa dapat PE. Atau dalam artian, label implicit null nantinya akan dibuka oleh router PE untuk diteruskan kembali ke router CE. Dalam hal ini, router PE akan menerima label yang dikhuruskan untuk dirinya yaitu LER atau label edge router lalu label tersebut nantinya akan dibuka oleh router PE tersebut lalu dikirimkan kepada daerah yang bukan merupakan MPLS area.


Lalu ada remote-binding. Remote binding sendiri akan mendefinisikan kondigurasi apabila ada packet yang ingin menuju suatu jaringan tertentu, maka router tersebut akan mendefinisikan network yang dapat dilewati untuk menuju jaringan tersebut dan memberikan label untuk menuju jaringan tersebut. 
[admin@R2] > /mpls local-bindings
add disabled=no dst-address=1.1.1.1/32 label=33
add disabled=no dst-address=4.4.4.4/32 label=21
[admin@R2] > /mpls remote-bindings
add disabled=no dst-address=1.1.1.1/32 label=impl-null nexthop=12.12.12.1
add disabled=no dst-address=4.4.4.4/32 label=22 nexthop=23.23.23.3

Berdasarkan konfigurasi pada R2, apabila ada paket yang ingin menuju ke 1.1.1.1 namun melewati dirinya, maka label yang diberikan terhadap paket tersebut adalah 33. Dan apabila ada paket yang ingin menuju ke 4.4.4.4 namun melewati dirinya, maka label yang diberikan terhadap paket tersebut adalah 21.


Dan untuk remote binding, apabila ada network yang menuju 1.1.1.1 melewati nexthop yang telah di definisikan, maka label yang diberikan terhadap paket tersebut adalah implicit null. Dan apabila ada packet yang ingin menuju 4.4.4.4 melewati nexthop yang telah di definisikan, maka packet tersebut diberi label 22. 

[admin@R3] > /mpls local-bindings
add disabled=no dst-address=4.4.4.4/32 label=22
add disabled=no dst-address=1.1.1.1/32 label=32
[admin@R3] > /mpls remote-bindings
add disabled=no dst-address=1.1.1.1/32 label=33 nexthop=23.23.23.2
add disabled=no dst-address=4.4.4.4/32 label=impl-null nexthop=34.34.34.4
Berdasarkan konfigurasi pada R3, apabila ada paket yang ingin menuju ke 1.1.1.1 namun melewati dirinya, maka label yang diberikan terhadap paket tersebut adalah 32. Dan apabila ada paket yang ingin menuju ke 4.4.4.4 namun melewati dirinya, maka label yang diberikan terhadap paket tersebut adalah 22.


Dan untuk remote binding, apabila ada network yang menuju 1.1.1.1 melewati nexthop yang telah di definisikan, maka label yang diberikan terhadap paket tersebut adalah 33. Dan apabila ada packet yang ingin menuju 4.4.4.4 melewati nexthop yang telah di definisikan, maka packet tersebut diberi label implicit null. 

[admin@R4] > /mpls local-bindings
add disabled=no dst-address=4.4.4.4/32 label=impl-null
[admin@R4] > /mpls remote-bindings
add disabled=no dst-address=1.1.1.1/32 label=32 nexthop=34.34.34.3
Berdasarkan konfigurasi pada R2, apabila ada paket yang ingin menuju ke dirinya, maka packet tersebut akan diberi label implicit null. Dan untuk remote binding, apabila ia ingin menuju 1.1.1.1 melewati nexthop yang telah di definisikan, maka packet tersebut akan diberi label 32.


Apabila sudah selesai melakukan konfigurasi pada router MPLS, maka selanjutnya konfigurasi default route kepada setiap router yang terhubung dengan router MPLS.

[admin@R5] > /ip route
add dst-address=0.0.0.0/0 gateway=15.15.15.1

[admin@R6] > /ip route
add dst-address=0.0.0.0/0 gateway=16.16.16.1

[admin@R7] > /ip route
add dst-address=0.0.0.0/0 gateway=47.47.47.4

[admin@R8] > /ip route
add dst-address=0.0.0.0/0 gateway=48.48.48.4
Setelah itu lakukan traceroute. 
[admin@R8] > tool traceroute 1.1.1.1
# ADDRESS         RT1 RT2 RT3 STATUS
1 48.48.48.4        1ms 1ms 1ms
2 34.34.34.3        2ms 2ms 2ms <MPLS:L=32,E=0>
3 23.23.23.2        2ms 2ms 2ms <MPLS:L=33,E=0>
4 1.1.1.1              2ms 2ms 3ms
[admin@R5] &gt; tool traceroute 4.4.4.4
# ADDRESS        RT1 RT2 RT3 STATUS
1 15.15.15.1        1ms 1ms 1ms
2 12.12.12.2        3ms 3ms 3ms <MPLS:L=21,E=0>
3 23.23.23.3        3ms 2ms 2ms <MPLS:L=22,E=0>
4 4.4.4.4              4ms 2ms 2ms

Share this