Wednesday, 4 January 2017

Superlab Mikrotik ( Lab 9 )

Assalamualaikum,
Masih di dalam superlab mikrotik, pada kali ini kita akan membahas mengenai Superlab 9 Mikrotik. Berikut topologi yang akan digunakan pada Lab 9.

Topologi
Dalam Lab 9, akan ada beberapa materi yang akan dibahas, yaitu seperti berikut.
- DHCP Server
- DHCP Relay 
- Firewall Filter
- Routing OSPF
- EoIP Tunnel

Tujuan

- Semua device dapat mengakses internet
- Digunakan Eoip tunnel sebagai penghubung network Router1 dan Router5
- Firewall Filter
- Firewall Logging

Konfigurasi

Pertama lakukan konfigurasi identity dan juga ip address dari setiap router.
[admin@Mikrotik] > system identity set name=R1
[admin@R1] > ip address add address=1.1.1.2/30 interface=ether1
[admin@R1] > ip address add address=172.16.1.1/30 interface=ether3
[admin@R1] > ip address add address=3.3.3.1/30 interface=ether2
[admin@Mikrotik] > system identity set name=R2
[admin@R2] > ip address add address=2.2.2.2/30 interface=ether1
[admin@R2] > ip address add address=172.16.2.1/30 interface=ether3
[admin@R2] > ip address add address=4.4.4.1/30 interface=ether2
[admin@Mikrotik] > system identity set name=R3
[admin@R3] > ip address add address=3.3.3.2/30 interface=ether1
[admin@R3] > ip address add address=5.5.5.1/30 interface=ether2
[admin@R3] > ip address add address=6.6.6.1/30 interface=ether3
[admin@Mikrotik] > system identity set name=R4
[admin@R4] > ip address add address=4.4.4.2/30 interface=ether1
[admin@R4] > ip address add address=7.7.7.1/30 interface=ether2
[admin@R4] > ip address add address=8.8.8.1/30 interface=ether3
[admin@Mikrotik] > system identity set name=R5
[admin@R5] > ip address add address=5.5.5.2/30 interface=ether1
[admin@R5] > ip address add address=9.9.9.1/30 interface=ether3
[admin@R5] > ip address add address=192.168.1.1/24 interface=ether2
[admin@Mikrotik] > system identity set name=R6
[admin@R6] > ip address add address=6.6.6.2/30 interface=ether1
[admin@R6] > ip address add address=9.9.9.2/30 interface=ether3
[admin@R6] > ip address add address=192.168.1.2/24 interface=ether2
Untuk konfigurasi  R7 dan R8, saya akan membahasnya nanti dikarenakan kedua router tersebut akan menggunakan DHCP Relay yang diberikan oleh R2. Jika sudah mengatur ip address darisetiap router, tambahkan routing, DNS, dan juga firewall agar mereka semuua dapat mengakses internet nantinya.
[admin@R1] > ip route add gateway=1.1.1.1
[admin@R1] > ip dns set servers=8.8.8.8 allow-remote-requests=yes
[admin@R1] > ip firewall nat add chain=srcnat action=masquerade out-interface=ether1
[admin@R2] > ip route add gateway=2.2.2.1
[admin@R2] > ip dns set servers=8.8.8.8 allow-remote-requests=yes
[admin@R2] > ip firewall nat add chain=srcnat action=masquerade out-interface=ether1
[admin@R3] > ip route add gateway=3.3.3.1
[admin@R3] > ip dns set servers=8.8.8.8 allow-remote-requests=yes
[admin@R3] > ip firewall nat add chain=srcnat action=masquerade out-interface=ether1
[admin@R4] > ip route add gateway=4.4.4.1
[admin@R4] > ip dns set servers=8.8.8.8 allow-remote-requests=yes
[admin@R4] > ip firewall nat add chain=srcnat action=masquerade out-interface=ether1
[admin@R5] > ip route add gateway=5.5.5.1
[admin@R5] > ip dns set servers=8.8.8.8 allow-remote-requests=yes
[admin@R5] > ip firewall nat add chain=srcnat action=masquerade out-interface=ether1
[admin@R6] > ip route add gateway=6.6.6.1
[admin@R6] > ip dns set servers=8.8.8.8 allow-remote-requests=yes
[admin@R6] > ip firewall nat add chain=srcnat action=masquerade out-interface=ether1
Lalu pastikan semuanya sudah terhubung internet. Jika sudah, selanjutnya adalah melakukan konfigurasi pada jaringan bagian kiri terlebih dahulu.
Tidak begitu banyak konfigurasi yang akan kita tambahkan pada jaringan bagian kiri, kita akan melakukan konfigurasi agar R3, R5, dan R6 akan menjadi jaringan fail over, dimana apabila ada sebuah jalur yang sedang down, maka jaringan tersebut akan mencari jalur lainnya agar jaringan tersebut tetap dalam keadaan up.  Untuk fail over kita dapat menggunakan ip route untuk menentukan jalur mana yang akan menjadi jalur utama dalam jaringan tersebut, dan juga jalur mana yang akan menjadi backup. Distance digunakan untuk menentukan mana jalur utama dan mana jalur backup. 

Tambahkan static route terlebih dahulu pada R1yang akan menuju jaringan local. 
[admin@R1] > ip route add dst-address=5.5.5.0/30 gateway=3.3.3.2 [admin@R1] > ip route add dst-address=6.6.6.0/30 gateway=3.3.3.2 [admin@R1] > ip route add dst-address=10.10.10.0/30 gateway=3.3.3.2
[admin@R1] > ip route add dst-address=192.168.4.0/30 gateway=3.3.3.2
[admin@R3] > ip route add dst-address=192.168.4.0/30 gateway=5.5.5.2 distance=1
[admin@R3] > ip route add dst-address=192.168.4.0/30 gateway=6.6.6.2 distance=2
[admin@R3] > ip route add dst-address=192.168.5.0/30 gateway=5.5.5.2 distance=2
[admin@R3] > ip route add dst-address=192.168.5.0/30 gateway=6.6.6.2 distance=1
[admin@R3] > ip route add dst-address=10.10.10.0/30 gateway=5.5.5.2 distance=1
[admin@R3] > ip route add dst-address=10.10.10.0/30 gateway=6.6.6.2 distance=2
[admin@R5] > ip route add dst-address=192.168.2.0/30 gateway=3.3.3.1
[admin@R5] > ip route add dst-address=3.3.3.0/30 gateway=5.5.5.1 distance=1
[admin@R5] > ip route add dst-address=3.3.3.0/30 gateway=10.10.10.2 distance=2
[admin@R5] > ip route add dst-address=0.0.0.0/0 gateway=5.5.5.1 distance=1
[admin@R5] > ip route add dst-address=0.0.0.0/0 gateway=10.10.10.2 distance=2
[admin@R5] > ip route add dst-address=192.168.2.0/30 gateway=5.5.5.1 distance=1
[admin@R5] > ip route add dst-address=192.168.2.0/30 gateway=10.10.10.2 distance=2
[admin@R6] > ip route add dst-address=3.3.3.0/30 gateway=6.6.6.1 distance=1
[admin@R6] > ip route add dst-address=3.3.3.0/30 gateway=10.10.10.1 distance=2
[admin@R6] > ip route add dst-address=0.0.0.0/0 gateway=6.6.6.1 distance=1
[admin@R6] > ip route add dst-address=0.0.0.0/0 gateway=10.10.10.1 distance=2
[admin@R6] > ip route add dst-address=192.168.2.0/30 gateway=6.6.6.1 distance=1
[admin@R6] > ip route add dst-address=192.168.2.0/30 gateway=6.6.6.1 distance=2
Setelah itu lakukan konfigurasi pada jaringan bagian kanan.

Pada kali ini, R2 akan bertugas sebagai DHCP Server dan menggunakan DHCP Relay, lalu R4 akan menggunakan DHCP Relay untuk didistribusikan kepada R7 dan juga R8. Lakukan konfigurasi DHCP Server terlebih dahulu pada R2. Kita akan menambahkan dhcp server secara manual. Buat terlebih dahulu address pool, lalu tambahkan DHCP Server. 
[admin@R2] > /ip pool
add name=pool7 ranges=7.7.7.2-7.7.7.254
add name=pool8 ranges=8.8.8.2-8.8.8.254
add name=dhcp_pool1 ranges=7.7.7.2
add name=dhcp_pool2 ranges=8.8.8.2
[admin@R2] > /ip dhcp-server
add address-pool=dhcp_pool1 authoritative=after-2sec-delay bootp-support=static disabled=no interface=ether3 lease-time=3d name=dhcp1 relay=7.7.7.1
add address-pool=dhcp_pool2 authoritative=after-2sec-delay bootp-support=static disabled=no interface=ether3 lease-time=3d name=dhcp2 relay=8.8.8.1
[admin@R2] > /ip dhcp-server network
add address=7.7.7.0/30 gateway=7.7.7.1
add address=8.8.8.0/30 gateway=8.8.8.1
Jika sudah, konfigurasi DHCP Relay pada R4.
[admin@R4] > /ip dhcp-relay
add dhcp-server=4.4.4.1 disabled=no interface=ether2 local-address=7.7.7.1 name=relay1
add dhcp-server=4.4.4.1 disabled=no interface=ether3 local-address=8.8.8.1 name=relay2
Lalu lakukan konfigurasi DHCP-Client pada R7 dan R8.
[admin@R7] > /ip dhcp-client
add add-default-route=yes default-route-distance=1 disabled=no interface=ether1 use-peer-dns=yes use-peer-ntp=yes
[admin@R8] > /ip dhcp-client
add add-default-route=yes default-route-distance=1 disabled=no interface=ether1 use-peer-dns=yes use-peer-ntp=yes
Jika sudah, selanjutnya adalah melakukan konfigurasi pada R8. Pada skenario ini, R8 akan membuat bridge R8 dan juga PC4. Setelah itu, R8 akan menjadi DHCP Server dari interface bridge tersebut. Buat terlebih dahulu interface bridge, lalu tambahkan interface yang menuju R8 dan juga PC4 pada interface tersebut.
[admin@R8] > /interface bridge
add name=bridgeR7-PC4
[admin@R8] > /interface bridge port
add bridge=bridge1 disabled=no interface=ether2
add bridge=bridge1 disabled=no interface=ether3
Setelah itu lakukan konfigurasi DHCP Server.
[admin@R8] > ip dhcp-server setup
Select interface to run DHCP server on

dhcp server interface: bridge1
Select network for DHCP addresses

dhcp address space: 192.168.7.0/24
Select gateway for given network

gateway for dhcp network: 192.168.7.1
Select pool of ip addresses given out by DHCP server

addresses to give out: 192.168.7.2-192.168.7.254
Select DNS servers

dns servers: 8.8.8.8
Select lease time
 Jika sudah, aktifkan DHCP Client R7 untuk mendapatkan ip dari R8.
[admin@R7] > /ip dhcp-client
add add-default-route=yes default-route-distance=1 disabled=no interface=ether2 use-peer-dns=yes use-peer-ntp=yes
Lalu pastikan R7 dan PC4 mendapatkan ip address dari R8.
[admin@R7] > ip dhcp-client pr
Flags: X - disabled, I - invalid
 #   INTERFACE  USE-PEER-DNS ADD-DEFAULT-ROUTE STATUS   ADDRESS          
 0   ether1             yes                       yes                          bound         7.7.7.2/30
 1   ether2             yes                       yes                          bound         192.168.7.254/24
Lanjut ke skenario selanjutnya, pada kali ini jaringan bagian kiri dan kanan akan dihubungkan menggunakan EoIP Tunnel. Oleh karena itu buat EoIP Tunnel di setiap router yang menuju ke router lainnya.
[admin@R1] > /interface eoip
add disabled=no name=eoip1 remote-address=2.2.2.2 tunnel-id=1 local-address=1.1.1.2
[admin@R2] > /interface eoip
add disabled=no   name=eoip1 remote-address=1.1.1.2 tunnel-id=1 local-address=2.2.2.2
Setelah itu tambahkan ip address untuk interface EoIP.
[admin@R1] > /ip address
add address=20.20.20.1/30 disabled=no interface=eoip1 network=20.20.20.0
[admin@R2] > /ip address
add address=20.20.20.2/30 disabled=no interface=eoip1 network=20.20.20.0
Lalu coba lakukan ping ke ip address EoIP yang dimiliki router lain. Jika sudah berhasil, selanjutnya adalah membuat bridge untuk interface EoIP. Hal ini dilakukan agar jaringan local bagian kiri, dapat berkomunikasi dengan jaringan local bagian kanan dengan menggunakan tunneling.
[admin@R1] > /interface bridge
add name=bridgeEoIP
[admin@R1] > /interface bridge port
add bridge=bridgeEoIP interface=ether1
add bridge=bridgeEoIP interface=eoip1
[admin@R2] > /interface bridge
add name=bridgeEoIP
[admin@R2] > /interface bridge port
add bridge=bridgeEoIP interface=ether1
add bridge=bridgeEoIP interface=eoip1
Setelah itu tambahkan default route dengan gateway interface EoIP.
[admin@R1] > ip route add gateway=20.20.20.2
[admin@R2] > ip route add gateway=20.20.20.1
Setelah itu coba ping menuju jaringan local router lainnya. Jika sudah, tambahkan firewall pada R2 agar beberapa client di jaringan local milik R2 tidak dapat di ping oleh router lainnya.
[admin@R2] > /ip firewall filter
add action=drop chain=input disabled=no dst-address=192.168.6.0/30
add action=drop chain=input disabled=no dst-address=192.168.7.0/24
Lalu coba lakukan ping dari R1 menuju ke jaringan lokal R2.

Share this