Sunday, 1 January 2017

Superlab Mikrotik ( Lab 1 )

Assalamualaikum, 

Topologi  
Seperti yang terlihat pada gambar diatas, setiap router memiliki peran masing masing di dalam jaringan tersebut. Dari setiap peran yang dilakukan oleh router, kita dapat menentukan tujuan dari topologi tersebut. 

Tujuan 

- Setiap PC dapat mengakses internet
- Membatasi bandwith yang diterima suatu client/network
- Mencegah sebuah packet yang akan diminta/dikirimkan oleh client

Konfigurasi



Lakukan konfigurasi terlebih dahulu di router 1 dikarenakan hanya router 1 yang terhubung dengan internet.

R1
[admin@MikroTik] > system identity set name=R1
[admin@R1] > ip dhcp-client add interface=ether1 use-peer-dns=yes use-peer-ntp=yes add-default-route=yes disable=no
[admin@R1] > ip address add address=12.12.12.1/24 interface=ether2
[admin@R1] > ip dns set server=8.8.8.8 allow-remote-requests=yes
Pastikan router dapat terkoneksi dengan internet. Apabila sudah berhasil, langkah selanjutnya adalah mengatur firewall nat agar client yang berada dibawah router 1 dapat mengakses internet.
[admin@R1] > ip firewall nat add chain=srcnat action=masqurade out-interface=ether1
Seperti pada skenario diatas bahwa nantinya akan ada client yang mendapatkan network 172.16.1.0 yang didapatkan dengan dhcp relay, maka yang kita lakukan konfigurasi untuk dhcp relay tersebut adalah R1. R1 akan berperan sebagai penyedia DHCP/DHCP Server, sedangkan router yang dibawahnya akan menjadi penerus DHCP tersebut agar jaringan lokal dibawahnya bisa mendapatkan ip DHCP yang dibuat oleh DHCP Server.
[admin@R1] > ip dhcp-server setup
Select interface to run DHCP server on
dhcp server interface: ether2

Select network for DHCP addresses
dhcp address space: 172.16.1.0/24

Select gateway for given network
gateway for dhcp network: 172.16.1.1

If this is remote network, enter address of DHCP relay
There is no such IP network on selected interface
dhcp relay: 172.16.1.1

Select pool of ip addresses given out by DHCP server
addresses to give out: 172.16.1.2-172.16.1.254

Select DNS servers
dns servers: 172.16.1.1

Select lease time
lease time: 3d
 Apabila DHCP Server sudah dibuat, maka kita akan lanjut ke konfigurasi untuk R2.

R2

Pada skenario diatas, router 2 akan bertugas sebagai penghubung DHCP agar jaringan lokal yang terhubung dengan R3, bisa mendapatkan ip DHCP yang diberikan oleh R1. Oleh karena itu R2 akan dikonfigurasi sebagai bridge. 
[admin@R2] > interface bridge add name=bridge
[admin@R2] > interface bridge port add interface=ether1 bridge=bridge
[admin@R2] > interface bridge port add interface=ether2 bridge=bridge
Lalu tambahkan ip address pada interface bridge agar berfungsi sebagai loopback. 

[admin@R1] > ip address add address=12.12.12.2/24 interface=bridge
Apabila konfigurasi pada R2 sudah selesai, maka lanjut ke konfigurasi untuk R3. 

R3

Router 3 pada skenario kali ini akan menjadi perantara pemberi IP untuk jaringan lokal terhubung secara langsung dengannya. Namun sebelum pemberian ip address untuk jaringan lokal tersebut, perlu kita ketahui bahwa kedua pc tersebut tidak menggunakan perangkat seperti swtich untuk terhubung ke router, namun ini secara langsung terhubung ke router. Padahal kedua pc tersebut 1 network, namun dikarenakan terhubung dengan port yang ada di router, maka harus dihubungkan keduanya menggunakan bridge.
[admin@R3] > interface bridge add name=bridge
[admin@R3] > interface bridge port add bridge=bridge interface=ether3
[admin@R3] > interface bridge port add bridge=bridge interface=ether4
Setelah itu atur ip address.
[admin@R3] > ip address add address=12.12.12.3/24 interface=ether1
[admin@R3] > ip address add address=172.16.1.0/24 interface=bridge
[admin@R3] > ip address add address=172.16.2.0/24 interface=ether2
 Jika sudah, maka atur agar router dapat terhubung ke internet.
[admin@R3] > ip route add gateway=12.12.12.1
[admin@R3] > ip dns set servers=12.12.12.1 allow-remote-requests=yes
Lalu atur agar R3 dapat meneruskan relay yang tadi sudah dibuat di R1 dan diarahkan ke interface bridge yang tadi sudah kita buat.
[admin@R3] > ip dhcp-relay add dhcp-server=12.12.12.1 disable=no interface=bridge
Jika sudah, maka secara otomatis client akan mendapatkan ip address dhcp tersebut. Lalu selanjutnya adalah jadikann juga R3 sebagai DHCP server untuk network 172.16.2.0/24.
[admin@R3] > ip dhcp-server setup
Select interface to run DHCP server on
dhcp server interface: ether2

Select network for DHCP addresses
dhcp address space: 172.16.2.0/24

Select gateway for given network
gateway for dhcp network: 172.16.2.1

Select pool of ip addresses given out by DHCP server
addresses to give out: 172.16.2.2-172.16.2.254

Select DNS servers
dns servers: 12.12.12.1

Select lease time
lease time: 3d
Apabila semua konfigurasi sudah dilakukan sampai sini, kita mulai untuk mengkonfigurasi agar setiap pc memiliki rule masing masing yang sudah ditentukan oleh router.
[admin@R3] > ip firewall filter add chain=input src-mac-address=00:50:79:66:68:01 dst-address=172.16.1.0/24 action=drop protocol=icmp
Dalam kasus tersebut, network 2.0 tidak akan bisa mengirimkan packet icmp yang bertujuan untuk network 1.0. Setiap packet yang dikirimkan ke network 1.0, akan di drop oleh router.

Setelah itu, tambahkan pcq pada router 2 untuk melimit kecepatan dari client ke internet.
[admin@R2] > queue simple add max-limit=1M/1M name=limit-all target-addresses=172.16.1.0/24
[admin@R2] > queue simple add limit-at=256k/256k max-limit=512k/512k name=limit-pc-1 parent=limit-all target-addresses=172.16.1.254
[admin@R2] > queue simple add limit-at=256k/256k max-limit=512k/512k name=limit-pc-2 parent=limit-all target-addresses=172.16.1.253
Lalu tes kecepatan dari client. Setelah berhasil, selanjutnya kita akan buat Queue tree, pertama buat mangle untuk queue tree terlebih dahulu.
[admin@R2] /ip firewall mangle>
> add action=mark-connection chain=prerouting new-connection-mark=mark-1 src-address=172.168.2.253
> add action=mark-connection chain=prerouting new-connection-mark=mark-1 src-address=172.168.2.254
> add action=mark-connection chain=prerouting new-connection-mark=mark-2 src-address=172.168.2.253
> add action=mark-connection chain=prerouting new-connection-mark=mark-2 src-address=172.168.2.254
> add action=mark-packet chain=prerouting new-packet-mark=mark-1p connection-mark=mark-1 passthrough=no
> add action=mark-packet chain=prerouting new-packet-mark=mark-2p connection-mark=mark-2 passthrough=no
 Setelah itu buat queue treenya.
[admin@R2] /queue tree>
> add max-limit=1M name=parent parent=global-total queue=default
> add limit-at=256k max-limit=512k name=pc1 packet-mark=mark-1 parent=parent queue=default
> add limit-at=256k max-limit=512k name=pc2 packet-mark=mark-2 parent=parent queue=default
Lalu test kecepatan dari setiap client. 

Share this