Saturday, 21 January 2017

OSPF Authentication

Assalamualaikum,

Pada kali ini saya akan membahas sebuah materi yaitu mengenai OSPF Authentication.


Pada lab ini, sebah router akan diberikan pengaman atau authetikasi menggunakan md5. Oke langsung saja topologi yang kita gunakan sebagai berikut.
Tujuan yang akan kita capai pada lab kali ini adalah sebagai berikut.
  1. Selutuh router dapat berkomunikasi 
  2. Memerlukan autentikasi untuk menjalin adjacency routing OSPF
Konfigurasi

Tambahkan ip address kepada setiap router terlebih dahulu.
IDN-R1(config)#int fa0/0
IDN-R1(config-if)#no shut 
IDN-R1(config-if)#ip address 12.12.12.1 255.255.255.0
IDN-R1(config-if)#ex

IDN-R1(config)#int lo0
IDN-R1(config-if)#ip address 1.1.1.1 255.255.255.255
IDN-R1(config-if)#ex
IDN-R2(config)#int fa0/0
IDN-R2(config-if)#no shut
IDN-R2(config-if)#ip address 12.12.12.2 255.255.255.0
IDN-R2(config-if)#ex

IDN-R2(config)#int fa1/0
IDN-R2(config-if)#no shut
IDN-R2(config-if)#ip address 23.23.23.2 255.255.255.0
IDN-R2(config-if)#ex

IDN-R2(config)#int lo0
IDN-R2(config-if)#ip address 2.2.2.2 255.255.255.255
IDN-R2(config-if)#ex
IDN-R3(config)#int fa0/0
IDN-R3(config-if)#no shut
IDN-R3(config-if)#ip address 23.23.23.3 255.255.255.0
IDN-R3(config-if)#ex

IDN-R3(config)#int lo0
IDN-R3(config-if)#ip address 3.3.3.3 255.255.255.255
IDN-R3(config-if)#ex
Setelah itu konfigurasi routing OSPF pada setiap router.
IDN-R1(config)#router ospf 10
IDN-R1(config-router)#net 12.12.12.0 0.0.0.255 area 0
IDN-R1(config-router)#net 1.1.1.1 0.0.0.0 area 0
IDN-R1(config-router)#ex
IDN-R2(config)#router ospf 20
IDN-R2(config-router)#net 12.12.12.0 0.0.0.255 area 0
IDN-R2(config-router)#net 23.23.23.0 0.0.0.255 area 0
IDN-R2(config-router)#net 2.2.2.2 0.0.0.0 area 0
IDN-R2(config-router)#ex
IDN-R3(config)#router ospf 30
IDN-R3(config-router)#net 23.23.23.0 0.0.0.255 area 0
IDN-R3(config-router)#net 3.3.3.3 0.0.0.0 area 0
IDN-R3(config-router)#ex
Jika sudah tentunya setiap router akan menjalin adjacency. Lalu pada skenario kali ini, link ospf antara R1 dan R2 akan diamankan menggunakan autentikasi md5. Hal ini dilakukan sebagai pengaman apabila ada penyusup yang sengaja untuk mendapatkan informasi informasi dari routing OSPF yang digunakan.
IDN-R1(config)#int fa0/0
IDN-R1(config-if)#ip ospf authentication message-digest
IDN-R1(config-if)#ip ospf message-digest-key 1 md5 IDN
Pada konfigurasi diatas, terlihat bahwa routing OSPF diamankan dengan autentikasi jenis md5 dengan menggunakan password IDN. Jadi apabila ada router lain yang ingin menjalin adjacency ospf dengan R1, maka harus menggunakan password yang sama sebagai proses autentikasinya. Jika kita baru melakukan konfigurasi pada R1, maka akan muncul notifikasi sebagai berikut.
 *Jan 21 08:50:51.543: %OSPF-5-ADJCHG: Process 10, Nbr 2.2.2.2 on FastEthernet0/0 from FULL to DOWN, Neighbor Down: Dead timer expired
Notifikasi diatas menandakan bahwa adjacency antara R1 dan R2 telah terputus. Hal ini dikarenakan pada R2, belum dilakukan konfigurasi autentikasi. Lalu lakukan konfigurasi pada R2.
IDN-R2(config)#int fa0/0
IDN-R2(config-if)#ip ospf authentication message-digest
IDN-R2(config-if)#ip ospf message-digest-key 1 md5 IDN
 Lalu proses adjacency terjalin kembali dengan autentikasi md5.
*Jan 21 08:52:35.591: %OSPF-5-ADJCHG: Process 20, Nbr 1.1.1.1 on FastEthernet0/0 from LOADING to FULL, Loading Done
Cek apakah interface tersebut sudah terautentikasi atau belum.
 IDN-R1#sh ip ospf int fa0/0
FastEthernet0/0 is up, line protocol is up
  Internet Address 12.12.12.1/24, Area 0, Attached via Network Statement
  Process ID 10, Router ID 1.1.1.1, Network Type BROADCAST, Cost: 1
  Topology-MTID    Cost    Disabled    Shutdown      Topology Name
        0           1         no          no            Base
  Transmit Delay is 1 sec, State DR, Priority 1
  Designated Router (ID) 1.1.1.1, Interface address 12.12.12.1
  No backup designated router on this network
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:04
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 0 msec, maximum is 4 msec
  Neighbor Count is 0, Adjacent neighbor count is 0
  Suppress hello for 0 neighbor(s)
  Message digest authentication enabled
    Youngest key id is 1
Pada verifikasi diatas, terlihat bahwa authentication sudah dalam kondisi enable. 

Share this