Saturday, 28 January 2017

Lab. 19 Superlab Mikrotik

Assalamualaikum,

Pada kali ini saya akan melanjutkan materi routing yang sebelumnya saya telah memposting materi mengenai routing juga yaitu pada Lab. 18 Superlab Mikrotik. Oke langsung saja, berikut topologi yang akan saya gunakan.
Dalam materi ini saya akan membahas beberapa materi yaitu sebagai berikut.
  1. OSPF Multi Area
  2. OSPF Distribute Default 
  3. Routing Filter 
  4. RIP 
  5. MPLS LDP
  6. Redistribute 
  7. Virtual Link
Konfigurasi

Lakukan konfigurasi ip address terlebih dahulu pada setiap interface yang ada pada router. Untuk konfigurasi ip address, saya tidak akan menuliskan satu persatu padapostingan ini dan insya allah nanti akan saya update lagi dengan tabel ip address. Langsung saja konfigurasi instance pada setiap router.
[admin@R10] > /routing ospf instance
set default redistribute-connected=as-type-1 router-id=0.0.10.10
[admin@R11] > /routing ospf instance
set default redistribute-connected=as-type-1 router-id=0.0.11.11
[admin@R12] > /routing ospf instance
set default redistribute-connected=as-type-1 router-id=0.0.12.12
[admin@R13] > /routing ospf instance
set default redistribute-connected=as-type-1 router-id=0.0.13.13
[admin@R4] > /routing ospf instance
set default redistribute-connected=as-type-1 router-id=0.0.4.4
[admin@R5] > /routing ospf instance
set default redistribute-connected=as-type-1 router-id=0.0.5.5
[admin@R1] > /routing ospf instance
set default redistribute-connected=as-type-1 router-id=0.0.1.1
[admin@R2] > /routing ospf instance
set default redistribute-connected=as-type-1 router-id=0.0.2.2
[admin@R3] > /routing ospf instance
set default redistribute-connected=as-type-1 router-id=0.0.3.3
[admin@R6] > /routing ospf instance
set default redistribute-connected=as-type-1 router-id=0.0.6.6
[admin@R7] > /routing ospf instance
set default redistribute-connected=as-type-1 router-id=0.0.7.7
[admin@R14] > /routing ospf instance
set default redistribute-connected=as-type-1 router-id=0.0.14.14
[admin@R15] > /routing ospf instance
set default redistribute-connected=as-type-1 router-id=0.0.15.15
[admin@R16] > /routing ospf instance
set default redistribute-connected=as-type-1 router-id=0.0.16.16
[admin@R17] > /routing ospf instance
set default redistribute-connected=as-type-1 router-id=0.0.17.17
Oke jika sudah menambahkan mengatur instance pada router OSPF, selanjutnya konfigurasi area dikarenakan pada lab ini akan ada banyak area yang akan digunakan.
[admin@R10] > /routing ospf area
add area-id=0.0.0.2 default-cost=1 disabled=no inject-summary-lsas=yes instance=default name=area2 type=stub
[admin@R11] > /routing ospf area
add area-id=0.0.0.2 disabled=no instance=default name=area2 type=default
[admin@R12] > /routing ospf area
add area-id=0.0.0.3 default-cost=1 disabled=no inject-summary-lsas=yes instance=default name=area3 type=stub
[admin@R13] > /routing ospf area
add area-id=0.0.0.3 default-cost=1 disabled=no inject-summary-lsas=yes instance=default name=area3 type=stub
[admin@R4] > /routing ospf area
add area-id=0.0.0.1 disabled=no instance=default name=area1 type=default
add area-id=0.0.0.2 default-cost=1 disabled=no inject-summary-lsas=yes instance=default name=area2 type=stub
[admin@R5] > /routing ospf area
add area-id=0.0.0.1 disabled=no instance=default name=area1 type=default
add area-id=0.0.0.3 default-cost=1 disabled=no inject-summary-lsas=yes instance=default name=area3 type=stub
[admin@R6] > /routing ospf area
add area-id=0.0.0.4 disabled=no instance=default name=area4 type=default
add area-id=0.0.0.5 disabled=no instance=default name=area5 type=default
[admin@R7] > /routing ospf area
add area-id=0.0.0.4 disabled=no instance=default name=area4 type=default
add area-id=0.0.0.6 disabled=no instance=default name=area6 type=default
[admin@R14] > /routing ospf area
add area-id=0.0.0.5 disabled=no instance=default name=area5 type=default
[admin@R15] > /routing ospf area
add area-id=0.0.0.5 disabled=no instance=default name=area5 type=default
[admin@R16] > /routing ospf area
add area-id=0.0.0.6 disabled=no instance=default name=area6 type=default
[admin@R17] > /routing ospf area
add area-id=0.0.0.6 disabled=no instance=default name=area6 type=default
Setelah itu, tambahkan network yang terhubung dengan router OSPF.
[admin@R10] > /routing ospf network
add area=area2 disabled=no network=1.1.10.0/24
[admin@R11] > /routing ospf network
add area=area2 disabled=no network=1.1.11.0/24
[admin@R12] > /routing ospf network
add area=area3 disabled=no network=1.1.12.0/24
[admin@R13] > /routing ospf network
add area=area3 disabled=no network=1.1.13.0/24
[admin@R4] > /routing ospf network
add area=area1 disabled=no network=1.1.4.0/30
add area=area2 disabled=no network=1.1.10.0/24
add area=area2 disabled=no network=1.1.11.0/24
add area=area1 disabled=no network=4.4.4.4/32
add area=area1 disabled=no network=2.2.4.0/30
[admin@R5] > /routing ospf network
add area=area1 disabled=no network=1.1.5.0/30
add area=area3 disabled=no network=1.1.12.0/24
add area=area3 disabled=no network=1.1.13.0/24
add area=area1 disabled=no network=5.5.5.5/32
add area=area1 disabled=no network=2.2.4.0/30
[admin@R1] > /routing ospf network
add area=backbone disabled=no network=1.1.1.0/30
add area=area1 disabled=no network=1.1.4.0/30
add area=area1 disabled=no network=1.1.5.0/30
add area=backbone disabled=no network=100.100.100.100/32
[admin@R2] > /routing ospf network
add area=backbone disabled=no network=1.1.1.0/30
add area=backbone disabled=no network=1.1.3.0/30
add area=backbone disabled=no network=2.2.2.2/32
[admin@R3] > /routing ospf network
add area=backbone disabled=no network=1.1.3.0/30
add area=area4 disabled=no network=1.1.6.0/30
add area=area4 disabled=no network=1.1.7.0/30
add area=backbone disabled=no network=3.3.3.3/32
[admin@R6] > /routing ospf network
add area=area4 disabled=no network=1.1.6.0/30
add area=area5 disabled=no network=1.1.14.0/24
add area=area5 disabled=no network=1.1.15.0/24
add area=area4 disabled=no network=6.6.6.6/32
add area=area4 disabled=no network=2.2.6.0/30
[admin@R7] > /routing ospf network
add area=area4 disabled=no network=1.1.7.0/30
add area=area6 disabled=no network=1.1.16.0/24
add area=area6 disabled=no network=1.1.17.0/24
add area=area4 disabled=no network=7.7.7.7/32
add area=area4 disabled=no network=2.2.4.0/30
[admin@R14] > /routing ospf network
add area=area5 disabled=no network=1.1.14.0/24
[admin@R15] > /routing ospf network
add area=area5 disabled=no network=1.1.15.0/24
[admin@R16] > /routing ospf network
add area=area6 disabled=no network=1.1.16.0/24
[admin@R17] > /routing ospf network
add area=area6 disabled=no network=1.1.17.0/24
 Setelah itu tambahkan virtual link untuk menghubungkan daerah daerah yang tidak terhubung langsung dengan backbone area.
[admin@R4] > /routing ospf virtual-link
add authentication=md5 authentication-key=IDN authentication-key-id=1 disabled=no instance-id=0 neighbor-id=0.0.1.1 transit-area=area1 use-bfd=no
[admin@R5] > /routing ospf virtual-link
add authentication=md5 authentication-key=IDN authentication-key-id=1 disabled=no instance-id=0 neighbor-id=0.0.1.1 transit-area=area1 use-bfd=no
[admin@R1] > /routing ospf virtual-link
add authentication=md5 authentication-key=IDN authentication-key-id=1 disabled=no instance-id=0 neighbor-id=0.0.4.4 transit-area=area1 use-bfd=no
add authentication=md5 authentication-key=IDN authentication-key-id=1 disabled=no instance-id=0 neighbor-id=0.0.5.5 transit-area=area1 use-bfd=no
[admin@R3] > /routing ospf virtual-link
add authentication=md5 authentication-key=IDN authentication-key-id=1 disabled=no instance-id=0 neighbor-id=0.0.6.6 transit-area=area4 use-bfd=no
add authentication=md5 authentication-key=IDN authentication-key-id=1 disabled=no instance-id=0 neighbor-id=0.0.7.7 transit-area=area4 use-bfd=no
[admin@R6] > /routing ospf virtual-link
add authentication=md5 authentication-key=IDN authentication-key-id=1 disabled=no instance-id=0 neighbor-id=0.0.3.3 transit-area=area4 use-bfd=no
[admin@R7] > /routing ospf virtual-link
add authentication=md5 authentication-key=IDN authentication-key-id=1 disabled=no instance-id=0 neighbor-id=0.0.3.3 transit-area=area4 use-bfd=no
Lalu pastikan bahwa router yang berada pada area yang terisolir sudah mendapatkan route untuk menuju area backbone. Setelah itu dikarenakan sebelumnya kita mengatur daerah yang terisolir tersebut sebagai stub area dimana stub area tersebut tidak akan mendapatkan advertise dari external route dan menggantikan external route tersebut menjadi default route untuk menuju external route. Kita akan membuat pada router yang berada pada daerah yang terisolir tidak mendapatkan route dari area backbone dan hanya mengandalkan default route yang ada pada dirinya. Tambahkan route filtering pada setiap router yang berada pada daerah yang terisolir.
[admin@R10] > /routing filter
add action=discard chain=ospf-in disabled=no invert-match=no prefix-length=24-32
[admin@R11] > /routing filter
add action=discard chain=ospf-in disabled=no invert-match=no prefix-length=24-32
[admin@R12] > /routing filter
add action=discard chain=ospf-in disabled=no invert-match=no prefix-length=24-32 
[admin@R13] > /routing filter
add action=discard chain=ospf-in disabled=no invert-match=no prefix-length=24-32
[admin@R14] > /routing filter
add action=discard chain=ospf-in disabled=no invert-match=no prefix-length=24-32
[admin@R15] > /routing filter
add action=discard chain=ospf-in disabled=no invert-match=no prefix-length=24-32 
[admin@R16] > /routing filter
add action=discard chain=ospf-in disabled=no invert-match=no prefix-length=24-32
[admin@R17] > /routing filter
add action=discard chain=ospf-in disabled=no invert-match=no prefix-length=24-32
Lalu cek routing tablee yang ada pada salah satu router pada daerah yang terisolir.
[admin@R10] > ip route print       
Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme, B - blackhole, U - unreachable, P - prohibit
 #      DST-ADDRESS        PREF-SRC        GATEWAY            DISTANCE
 0 ADo  0.0.0.0/0                                        1.1.10.1               110
 1 ADC  0.0.10.10/32         10.10.10.10      lo1                       0
 2 ADC  1.1.10.0/24           1.1.10.2            ether1                 0
Maka akan terlihat untuk menuju ke dunia luar, router akan menggunakan default route yang ada pada router. Ini sama halnya ketika kita menerapkan konsep totally stub area pada jaringan OSPF dimana pada routing table yang ada pada router hanya akan ada default route dan juga route directly connected.

Selanjutnya, kita lakukan konfigurasi terhadap RIP. R2 nantinya akan dipasang distribute default agar area rip dapat berkomunikasi dengan dunia luar tanpa harus memiliki seluruh routing table.

Oke langsung saja, konfigurasi routing RIP terlebih dahulu.
[admin@R2] > /routing rip
set default distribute-default=always redistribute-connected=yes
/routing rip interface
add interface=all
[admin@R8] > /routing rip
set redistribute-connected=yes
/routing rip interface
add interface=all
[admin@R9] > /routing rip
set redistribute-connected=yes
/routing rip interface
add interface=all
[admin@R18] > /routing rip
set redistribute-connected=yes
/routing rip interface
add interface=all
[admin@R19] > /routing rip
set redistribute-connected=yes
/routing rip interface
add interface=all
[admin@R20] > /routing rip
set redistribute-connected=yes
/routing rip interface
add interface=all
[admin@R21] > /routing rip
set redistribute-connected=yes
/routing rip interface
add interface=all
Lalu daftarkan neighbors yang terhubung dengan router rip.
[admin@R2] > /routing rip neighbor
add address=1.1.8.2 disabled=no
add address=1.1.9.2 disabled=no
[admin@R2] > /routing rip network
add disabled=no network=1.1.8.0/30
add disabled=no network=1.1.9.0/30
[admin@R8] > /routing rip neighbor
add address=1.1.8.1 disabled=no
add address=1.1.20.2 disabled=no
add address=1.1.21.2 disabled=no
[admin@R8] > /routing rip network
add disabled=no network=1.1.8.0/30
add disabled=no network=1.1.20.0/24
add disabled=no network=1.1.21.0/24
[admin@R9] > /routing rip neighbor
add address=1.1.9.1 disabled=no
add address=1.1.18.2 disabled=no
add address=1.1.19.2 disabled=no
[admin@R9] > /routing rip network
add disabled=no network=1.1.9.0/30
add disabled=no network=1.1.18.0/24
add disabled=no network=1.1.19.0/24
[admin@R18] > /routing rip neighbor
add address=1.1.18.1 disabled=no
[admin@R18] > /routing rip network
add disabled=no network=1.1.18.0/24
[admin@R19] > /routing rip neighbor
add address=1.1.19.1 disabled=no
[admin@R19] > /routing rip network
add disabled=no network=1.1.19.0/24
[admin@R20] > /routing rip neighbor
add address=1.1.20.1 disabled=no
[admin@R20] > /routing rip network
add disabled=no network=1.1.20.0/24
[admin@R21] > /routing rip neighbor
add address=1.1.21.1 disabled=no
[admin@R21] > /routing rip network
add disabled=no network=1.1.21.0/24
Setelah itu, coba ping dari R18 munuju ke jaringan ospf.
[admin@R18] > ping 1.1.14.2
HOST                                     SIZE TTL TIME  STATUS
1.1.14.2                                                timeout 
    sent=1 received=0 packet-loss=100%
Mengapa tidak bisa melakukan ping? Hal ini dikarenakan pada jaringan OSPF, sumber dari router RIP itu tidak ada dikarenakan kita tidak melakukan redistribute rip pada R2. Namun kita kali ini memang tidak redistribute rip, melainkan kali ini kita akan mencoba untuk menggunakan NAT. Penggunaan nat digunakan mentranslasikan address yang ada pada router rip, jadi ketika router RIP mengirimkan paket ke jaringan OSPF, Router OSPF akan mengira yang mengirimkan itu adalah R2, jadi Router OSPF akan mengirimkan balasan kepada Router RIP kembali.

Tambahkan firewall nat pada R2.
[admin@R2] > /ip firewall nat
add chain=srcnat action=masquerade out-interface=ether2
Setelah itu lakukan verifikasi ping dari R18 menuju ke R14.
[admin@R18] > ping 1.1.14.1
HOST                                     SIZE TTL TIME  STATUS
1.1.14.1                                   56  61 6ms 
    sent=1 received=1 packet-loss=0% min-rtt=6ms avg-rtt=6ms max-rtt=6ms
Maka R18 telah dapat melakukan ping kepada R14.
[admin@R4] > /mpls ldp
set enabled=yes lsr-id=4.4.4.4 transport-address=4.4.4.4
/mpls ldp interface
add interface=ether1
[admin@R5] > /mpls ldp
set enabled=yes lsr-id=5.5.5.5 transport-address=5.5.5.5
/mpls ldp interface
add interface=ether1
[admin@R1] > /mpls ldp
set enabled=yes lsr-id=100.100.100.100 transport-address=100.100.100.100
/mpls ldp interface
add interface=ether2
add interface=ether3
add interface=ether1
[admin@R2] > /mpls ldp
set enabled=yes lsr-id=2.2.2.2 transport-address=2.2.2.2
/mpls ldp interface
add interface=ether1
add interface=ether2
[admin@R3] > /mpls ldp
set enabled=yes lsr-id=3.3.3.3 transport-address=3.3.3.3
/mpls ldp interface
add interface=ether2
add interface=ether3
add interface=ether1
[admin@R6] > /mpls ldp
set enabled=yes lsr-id=6.6.6.6 transport-address=6.6.6.6
/mpls ldp interface
add interface=ether1
[admin@R7] > /mpls ldp
set enabled=yes lsr-id=7.7.7.7 transport-address=7.7.7.7
/mpls ldp interface
add interface=ether1 
Maka lakukan verifikasi pada salah satu router yaitu R2.


Maka jika MPLS berhasil, maka status dari mpls neighbor adalah Dynamic Opeational (DO). Lalu coba traceroute dari R10 ke R14.
[admin@R10] > tool traceroute 1.1.14.2
 # ADDRESS                            RT1   RT2   RT3   STATUS
 1 1.1.10.1                                5ms   3ms   32ms
 2 1.1.4.1                                 18ms  17ms  18ms  <MPLS:L=22,E=0>
 3 1.1.1.1                                 14ms  16ms  14ms  <MPLS:L=33,E=0>
 4 1.1.3.2                                 22ms  18ms  16ms  <MPLS:L=27,E=0>
 5 1.1.6.2                                 47ms  13ms  12ms
 6 1.1.14.2                               32ms  23ms  37ms
Maka akan terlihat hasilnya bahwa jalur yang dilewati merupakan jalur MPLS dengan label yang telah diberikan secaa dinamis oleh MPLS itu tersendiri.

Share this