Friday, 27 January 2017

Lab. 17 Superlab Mikrotik

Assalamualaikum,

Pada kali ini saya akan melanjutkan materi routing dimana sebelumnya saya telah memposting materi mengenai Lab. 16 Superlab Mikrotik dan kali ini saya akan melanjutkannya.


Dan materi yang akan di bahas pada kali ini diantara lain sebagai berikut.
  1. BGP Over GRE Tunnel 
  2. Backbone Area Virtual link 
  3. Route Filtering
  4. BGP Default-originate
  5. OSPF Distribute-Default 
  6. Routing Filter 
Konfigurasi

Untuk konfigurasi, pertama tama tentunya lakukan konfigurasi terlebih dahulu terhadap setiap interface yang ada pada router. Namun pada kali ini saya tidak menunjukkan konfigurasi ip address dikarenakan mungkin nanti postingan ini hanya penuh dengan konfigurasi ip address hehehe, Insya allah nanti saya akan update postingan ini dengan tabel ip address. 

Oke jika semua interface telah di tambahkan ip address, lanjut ke konfigurasi routing. Ada beberapa konsep yang nantinya akan dibahas seperti menghubungkan area 0 dengan area 0, peering BGP melalui tunnel, dan lain lainnya. Oke langsung saja menuju ke konfigurasi.

Pertama saya akan melakukan konfigurasi OSPF pada backbone area dan area1. Backbone area ditandai dengan box berwarna merah, dan juga area1 ditandai dengan box berwarna biru. Kalau biasanya backbone area dipakai sebagai penghubung antar area, pada kali ini kita akan mencoba standart area sebagai area penghubung area backbone. Area1 akan digunakan transit area untuk menghubungkan kedua backbone area. Untuk menghubungkan kedua backbone area tersebut, saya akan menggunakan virtual link. 

Pertama konfigurasi terlebih dahulu OSPF instance pada router yang akan menggunakan routing OSPF. 
[admin@R6] > /routing ospf instance
set router-id=6.6.6.6 redistribute-connected=as-type-1
[admin@R4] > /routing ospf instance
set redistribute-connected=as-type-1 router-id=4.4.4.4
[admin@R7] > /routing ospf instance
set redistribute-connected=as-type-1 router-id=7.7.7.7
[admin@R1] > /routing ospf instance
set redistribute-connected=as-type-1 router-id=1.1.1.1
[admin@R2] > /routing ospf instance
set redistribute-connected=as-type-1 router-id=2.2.2.2
[admin@R3] > /routing ospf instance
set redistribute-connected=as-type-1 router-id=3.3.3.3
[admin@R5] > /routing ospf instance
set redistribute-connected=as-type-1 router-id=5.5.5.5
[admin@R8] > /routing ospf instance
set redistribute-connected=as-type-1 router-id=8.8.8.8
[admin@R9] > /routing ospf instance
set redistribute-connected=as-type-1 router-id=9.9.9.9
Setelah itu, buat terlebih dahulu area pada R1,R2, dan R3. R1 dan R3 akan bertindak sebagai ABR.
[admin@R1] > /routing ospf area
add area-id=0.0.0.1 disabled=no instance=default name=area1 type=default
[admin@R2] > /routing ospf area
add area-id=0.0.0.1 disabled=no instance=default name=area1 type=default
[admin@R3] > /routing ospf area
add area-id=0.0.0.1 disabled=no instance=default name=area1 type=default
Jika sudah, advertise network yang ada pada router ospf.
[admin@R6] > /routing ospf network
add area=backbone disabled=no network=1.1.6.0/30
[admin@R4] > /routing ospf network
add area=backbone disabled=no network=1.1.4.0/30
add area=backbone disabled=no network=1.1.7.0/30
add area=backbone disabled=no network=1.1.6.0/30
[admin@R7] > /routing ospf network
add area=backbone disabled=no network=1.1.7.0/30
[admin@R1] > /routing ospf network
add area=backbone disabled=no network=1.1.4.0/30
add area=area1 disabled=no network=1.1.2.0/30
add area=area1 disabled=no network=1.1.3.0/30
[admin@R2] > /routing ospf network
add area=area1 disabled=no network=1.1.2.0/30
add area=area1 disabled=no network=1.1.30.0/30
[admin@R3] > /routing ospf network
add area=backbone disabled=no network=1.1.5.0/30
add area=area1 disabled=no network=1.1.30.0/30
add area=area1 disabled=no network=1.1.3.0/30
[admin@R5] > /routing ospf network
add area=backbone disabled=no network=1.1.5.0/30
add area=backbone disabled=no network=1.1.8.0/30
add area=backbone disabled=no network=1.1.9.0/30
[admin@R8] > /routing ospf network
add area=backbone disabled=no network=1.1.8.0/30
[admin@R9] > /routing ospf network
add area=backbone disabled=no network=1.1.9.0/30
Setelah itu buat virtual link untuk menghubungkan kedua backbone area.
[admin@R1] > /routing ospf virtual-link
add authentication=md5 authentication-key=IDN authentication-key-id=1 disabled=no neighbor-id=3.3.3.3 transit-area=area1
[admin@R3] > /routing ospf virtual-link
add authentication=md5 authentication-key=IDN authentication-key-id=1 disabled=no neighbor-id=1.1.1.1 transit-area=area1
Sedikit penjelasan mengenai konfigurasi di atas, kita menggunakan virtual link yang memiliki autentikasi. Jadi tidak sembarang router yang dapat terhubung dengan virtual link yang kita miliki, dikarenakan untuk terhubung ke virtual link sebuah router yang memiliki keamanan, router lainnya harus tau mengenai autentikasi key yang ada pada router tersebut.

Selanjutnya pada skenario kali ini, R2 akan discard setiap advertise network yang didapatkan dan R2 akan memanfaatkan default route yang diberikan oleh R1 dan R3. Begitu juga dengan R4 dan R5, keduanya akan menggunakan default route yang diberikan oleh R1 dan R3. Konfigurasi R1 dan R3 agar memberikan default route.
[admin@R3] > /routing ospf instance
set distribute-default=always-as-type-1
[admin@R1] > /routing ospf instance
set distribute-default=always-as-type-1
Setelah itu konfigurasi route filter pada R2, R4, dan R5 agar ketiga router tersebut tidak mendapatkan routing ospf selain default route.
[admin@R4] > /routing filter
add action=discard chain=ospf-in disabled=no invert-match=no prefix-length=30-32
[admin@R5] > /routing filter
add action=discard chain=ospf-in disabled=no invert-match=no prefix-length=30-32
[admin@R2] > /routing filter
add action=discard chain=ospf-in disabled=no invert-match=no prefix-length=30-32
Setelah itu cek ip route pada ketiganya.
[admin@R2] > ip route pr
Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme, B - blackhole, U - unreachable, P - prohibit
 #      DST-ADDRESS        PREF-SRC        GATEWAY            DISTANCE
 0 ADo  0.0.0.0/0                                        1.1.2.1                 110
                                                                   1.1.30.2         
 1 ADC  1.1.2.0/30             1.1.2.2              ether1                    0
 2 ADC  1.1.30.0/30           1.1.30.1            ether2                    0
 3 ADC  2.2.2.2/32             2.2.2.2              lo1                          0
 [admin@R4] > ip route print
Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme, B - blackhole, U - unreachable, P - prohibit
 #      DST-ADDRESS        PREF-SRC        GATEWAY            DISTANCE
 0 ADo  0.0.0.0/0                                        1.1.4.1                 110
 1 ADC  1.1.4.0/30             1.1.4.2              ether1                    0
 2 ADC  1.1.6.0/30             1.1.6.1              ether2                    0
 3 ADC  1.1.7.0/30             1.1.7.1              ether3                    0
 4 ADC  4.4.4.4/32             4.4.4.4              lo1                          0
 [admin@R5] > ip route pr
Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme, B - blackhole, U - unreachable, P - prohibit
 #      DST-ADDRESS        PREF-SRC        GATEWAY            DISTANCE
 0 ADo  0.0.0.0/0                                        1.1.5.1                 110
 1 ADC  1.1.5.0/30             1.1.5.2              ether1                    0
 2 ADC  1.1.8.0/30             1.1.8.1              ether2                    0
 3 ADC  1.1.9.0/30             1.1.9.1              ether3                    0
 4 ADC  5.5.5.5/32             5.5.5.5              lo1                          0
Lalu terlihat pada hasil verifikasi tersebut bahwa ketiga router tersebut telah mendapatkan default route. Selanjutnya kita akan melakukan konfigurasi BGP pada router yang berada pada blok kuning. Konfigurasi terlebih dahulu BGP Instance pada setiap router tersebut.
[admin@R10] > /routing bgp instance
set default as=200 client-to-client-reflection=yes cluster-id=10.10.10.10 redistribute-connected=yes router-id=10.10.10.10
[admin@R11] > /routing bgp instance
set default as=200 client-to-client-reflection=yes cluster-id=11.11.11.11 redistribute-connected=yes router-id=11.11.11.11
[admin@R6] > /routing bgp instance
set default as=200 client-to-client-reflection=yes cluster-id=6.6.6.6 router-id=6.6.6.6  
[admin@R9] > /routing bgp instance
set default as=300 client-to-client-reflection=yes cluster-id=9.9.9.9 router-id=9.9.9.9
[admin@R12] > /routing bgp instance
set default as=300 client-to-client-reflection=yes cluster-id=12.12.12.12 redistribute-connected=yes router-id=12.12.12.12
[admin@R13] > /routing bgp instance
set default as=300 client-to-client-reflection=yes cluster-id=13.13.13.13 redistribute-connected=yes router-id=13.13.13.13
Lalu tambahkan BGP Peer pada setiap router.
[admin@R10] > /routing bgp peer
add remote-address=1.1.10.1 remote-as=200
add remote-address=1.1.110.2 remote-as=200
 [admin@R11] > /routing bgp peer
add remote-address=1.1.11.1 remote-as=200
add remote-address=1.1.110.1 remote-as=200
[admin@R6] > /routing bgp peer
add default-originate=always multihop=yes nexthop-choice=force-self remote-address=1.1.10.2 remote-as=200 route-reflect=yes
add default-originate=always multihop=yes nexthop-choice=force-self remote-address=1.1.11.2 remote-as=200 route-reflect=yes
[admin@R13] > /routing bgp peer
add remote-address=1.1.13.1 remote-as=300
add remote-address=1.1.130.1 remote-as=300
[admin@R12] > /routing bgp peer
add remote-address=1.1.12.1 remote-as=300
add remote-address=1.1.130.2 remote-as=300
[admin@R9] > /routing bgp peer
add default-originate=always multihop=yes nexthop-choice=force-self remote-address=1.1.12.2 remote-as=300 route-reflect=yes
add default-originate=always multihop=yes nexthop-choice=force-self remote-address=1.1.13.2 remote-as=300 route-reflect=yes
Lalu pastikan peer sudah established. Selanjutnya, kita buat agar router BGP bagian kanan dapat berkomunikasi dengan router BGP bagian kiri. Pertama tama buat terlebih dahulu gre tunnel untuk menghubungkan kedua blok tersebut, lalu berikan ip address untuk tunnel tersebut.
[admin@R9] > /interface gre
add local-address=1.1.9.2 name=gre remote-address=1.1.6.2
[admin@R9] > /ip address
add address=20.20.20.2/30 disabled=no interface=gre network=20.20.20.0
[admin@R6] > /interface gre
add local-address=1.1.6.2 name=gre remote-address=1.1.9.2
[admin@R6] > /ip address
add address=20.20.20.1/30 disabled=no interface=gre network=20.20.20.0
Lalu lakukan verifikasi bahwa keduanya sudah dapat terhubung satu sama lain. Setelah itu, buat peering antara kedua router tersebut menggunakan address tunnel tersebut.
[admin@R6] > /routing bgp peer
add nexthop-choice=force-self remote-address=20.20.20.2 remote-as=300
[admin@R9] > /routing bgp peer
add nexthop-choice=force-self remote-address=20.20.20.1 remote-as=200 route-reflect=yes
Lalu pastikan keduanya sudah dalam status established.
[admin@R9] > routing bgp peer pr
Flags: X - disabled, E - established
 #   INSTANCE       REMOTE-ADDRESS  REMOTE-AS 
 0 E default             1.1.12.2                      300       
 1 E default             1.1.13.2                      300       
 2 E default             20.20.20.1                  200
 [admin@R6] > routing bgp peer pr
Flags: X - disabled, E - established
 #   INSTANCE   REMOTE-ADDRESS  REMOTE-AS
 0 E default         1.1.10.2                      200      
 1 E default         1.1.11.2                      200      
 2 E default         20.20.20.2                  300  
Setelah itu pastikan kedua blok tersebut saling dapat berkomunikasi. Lalu pastikan bahwa R6 dan R9 telah mendapatkan default route yang diberikan oleh R4 dan R5. Setelah itu, tambahkan filter pada R6 dan R9 agar keduanya tidak mendapatkan route dari OSPF selain default route.
[admin@R6] > /routing filter
add action=discard chain=ospf-in disabled=no prefix-length=30-32
[admin@R9] > /routing filter
add action=discard chain=ospf-in disabled=no prefix-length=30-32
Maka kedua router tersebut akan mendapatkan default route untuk menuju ke jaringan OSPF. Selanjutnya, kita buat agar R10, R11, R12, dan R13 dapat melakukan ping ke jaringan OSPF.
[admin@R6] > /ip firewall nat
add action=masquerade chain=srcnat disabled=no out-interface=ether1
[admin@R9] > /ip firewall nat
add action=masquerade chain=srcnat disabled=no out-interface=ether1
Maka verifikasi apakah R10, R11, R12, dan R13 dapat melakukan ping ke jaringan ospf atau tidak.
[admin@R10] > ping 1.1.30.1
HOST                                     SIZE TTL TIME  STATUS 
1.1.30.1                                   56  61 3ms 
    sent=1 received=1 packet-loss=0% min-rtt=3ms avg-rtt=3ms max-rtt=3ms
[admin@R12] > ping 1.1.30.1
HOST                                     SIZE TTL TIME  STATUS
1.1.30.1                                   56  60 8ms 
    sent=1 received=1 packet-loss=0% min-rtt=8ms avg-rtt=8ms max-rtt=8ms 
Hal ini menandakan bahwa Router local dapat berkomunikasi dengan jaringan OSPF. Lakukan verifikasi ping dari jaringan OSPF menuju Router BGP.
[admin@R1] > ping 1.1.10.2
HOST                                     SIZE TTL TIME  STATUS
                                                no route to host
    sent=1 received=0 packet-loss=100%
Mengapa tidak bisa? Dikarenakan R6 tidak mengadvertise network yang ia miliki agar router OSPF tidak dapat mengetahui jaringan local yang dimiliki Router BGP. 

Share this