Tuesday, 10 January 2017

Lab. 13 Superlab Mikrotik

Assalamualaikum,

Pada kali ini kembali saya akan share mengenai superlab yang saya buat sendiri, dan akan ada beberapa materi yang nantinya akan dibahas di dalam superlab ini yaitu :
  1. Routing OSPF
  2. Routing RIP
  3. Redistribute Routing 
  4. Firewall filter
Dan topologi yang akan kita gunakan adalah sebagai berikut.

Lalu skenario yang akan kita tetapkan pada kali ini adalah sebagai berikut. 
  1. Menghubungkan jaringan local R1 dengan R6. 
  2. Menghubungkan 2 routing yang berbeda 
  3. Melakuan filter terhadap paket yang dikirimkan/diterima
  4. Melimit kecepatan jaringan local
Konfigurasi

Tambahkan ip address terlebih dahulu pada setiap router.
[admin@R1] > /ip address
add address=1.1.1.2/30 disabled=no interface=ether1 network=1.1.1.0
add address=2.2.2.2/30 disabled=no interface=ether2 network=2.2.2.0
add address=20.20.20.1/30 disabled=no interface=ether3 network=20.20.20.0
[admin@R2] > /ip address
add address=2.2.2.1/30 disabled=no interface=ether3 network=2.2.2.0
add address=3.3.3.2/30 disabled=no interface=ether2 network=3.3.3.0
add address=4.4.4.1/30 disabled=no interface=ether1 network=4.4.4.0
[admin@R3] > /ip address
add address=1.1.1.1/30 disabled=no interface=ether1 network=1.1.1.0
add address=3.3.3.1/30 disabled=no interface=ether2 network=3.3.3.0
add address=5.5.5.1/3 disabled=no interface=ether3 network=5.5.5.0
[admin@R4] > /ip address
add address=4.4.4.2/30 disabled=no interface=ether1 network=4.4.4.0
add address=6.6.6.1/30 disabled=no interface=ether3 network=6.6.6.0
add address=7.7.7.1/30 disabled=no interface=ether2 network=7.7.7.0
[admin@R5] > /ip address
add address=5.5.5.2/30 disabled=no interface=ether1 network=5.5.5.0
add address=6.6.6.2/30 disabled=no interface=ether2 network=6.6.6.0
add address=8.8.8.1/30 disabled=no interface=ether3 network=8.8.8.0
[admin@R6] > /ip address
add address=8.8.8.2/30 disabled=no interface=ether1 network=8.8.8.0
add address=7.7.7.2/30 disabled=no interface=ether2 network=7.7.7.0
add address=30.30.30.1/30 disabled=no interface=ether3 network=30.30.30.0
 Setelah itu, tambahkan routing rip terlebih dahulu pada jaringan local R1 dan R2.
[admin@R1] > /routing rip
set redistribute-connected=yes
[admin@R1] > /routing rip network
add disabled=no network=1.1.1.0/30
add disabled=no network=2.2.2.0/30
[admin@R6] > /routing rip
set redistribute-connected=yes
/routing rip network
add disabled=no network=7.7.7.0/30
add disabled=no network=8.8.8.0/30
 Redistribute connected dikonfigurasi agar router yang menggunakan router yang tidak terhubung secara langsung dengan jaringan tersebut tetap dapat mendapatkan rute untuk menuju ke jaringan tersebut. Setelah itu konfigurasi routing OSPF.
[admin@R2] > /routing ospf instance
set redistribute-connected=as-type-1 redistribute-rip=as-type-1
[admin@R2] > /routing ospf network
add area=backbone disabled=no network=3.3.3.0/30
add area=backbone disabled=no network=4.4.4.0/30
[admin@R3] > /routing ospf instance
set redistribute-connected=as-type-1 redistribute-rip=as-type-1
/routing ospf network
add area=backbone disabled=no network=5.5.5.0/30
add area=backbone disabled=no network=3.3.3.0/30
[admin@R4] > /routing ospf instance
set redistribute-connected=as-type-1 redistribute-rip=as-type-1 /routing ospf network
add area=backbone disabled=no network=4.4.4.0/30
add area=backbone disabled=no network=6.6.6.0/30
[admin@R5] >
/routing ospf instance
set redistribute-connected=as-type-1 redistribute-rip=as-type-1
/routing ospf network
add area=backbone disabled=no network=5.5.5.0/30
add area=backbone disabled=no network=6.6.6.0/30
 Lalu lakukan verifikasi route dari jaringan local R1 dan R6.



Setelah itu, lakukan verifikasi ping dari R1 menuju ip client R6 dan sebaliknya. 
[admin@R6] > ping 20.20.20.1
HOST                                     SIZE TTL TIME  STATUS  
20.20.20.1                                 56  61 48ms
20.20.20.1                                 56  61 7ms 
sent=2 received=2 packet-loss=0% min-rtt=7ms avg-rtt=27ms max-rtt=48ms
[admin@R1] > ping 30.30.30.1
HOST                                     SIZE TTL TIME  STATUS
30.30.30.1                                 56  62 21ms
30.30.30.1                                 56  62 4ms 
sent=2 received=2 packet-loss=0% min-rtt=4ms avg-rtt=12ms max-rtt=21ms
 Setelah itu tambahkan rule pada jaringan tersebut, apabila R6 melakukan ping ke jaringan R1, maka packet tersebut akan di reject dan dibalas dengan ICMP PORT UNREACHABLE.
[admin@R1] > ip firewall filter add chain=input dst-address=20.20.20.0/30 action=reject reject-with=icmp-port-unreachable
 Maka hasilnya akan seperti berikut.


Setelah itu, tambahkan rule agar R6 tidak dapat di ping oleh R1 dengan balasan admin prohibited.
 [admin@R6] > ip firewall filter add chain=input dst-address=30.30.30.0/30 action=reject reject-with=icmp-admin-prohibited
Lalu lakukan verifikasi dari R1.
Lalu tambahkan queue agar pada R1, client hanya mendapatkan bandwith yang dikehendaki oleh admin.
[admin@R1] > queue simple add max-limit=5M/10M target-addresses=20.20.20.0/30
Setelah itu lakukan verifikasi.

Maka jaringan tersebut akan terlimit.

Share this