Sunday, 29 January 2017

Lab. 20 Superlab Mikrotik

Assalamualaikum,

Pada kali ini saya akan membahas superlab yang sudah saya buat yang masih berisi mengenai materi routing dimana sebelumnya saya sudah memposting superlab buatan saya dan mengenai materi routing juga yaitu pada postingan Lab. 19 Superlab Mikrotik. Oke langsung saja, berikut topologi yang akan saya gunakan pada superlab kali ini.


Dan materi yang akan dibahas pada superlab kali ini adalah sebagai berikut.
  1. Routing BGP 
  2. BGP Confederation
  3. BGP Multihoming 
  4. Route Filtering 
  5. BGP Max Prefix 
  6. BGP Default Originate
Konfigurasi 

Pertama tama, tentunya lakukan konfigurasi ip address terlebih dahulu kepada setiap interface yang ada pada router. Namun untuk menghemat halaman posting, sekalian aja konfigurasi BGP Instance sama BGP Peer ya hehehe

Konfigurasi R1

[admin@R1] > /ip address
add address=19.19.19.1/16 disabled=no interface=ether1 network=19.19.0.0
add address=10.10.10.1/16 disabled=no interface=ether2 network=10.10.0.0
add address=12.12.12.1/24 disabled=no interface=ether3 network=12.12.12.0
add address=13.13.13.1/24 disabled=no interface=ether4 network=13.13.13.0
add address=1.0.0.1/32 disabled=no interface=lo1 network=1.0.0.1
[admin@R1] > /routing bgp instance
set default as=500 client-to-client-reflection=yes cluster-id=1.0.0.1 redistribute-connected=yes router-id=1.0.0.1
[admin@R1] > /routing bgp peer
add default-originate=always instance=default name=peer1 nexthop-choice=force-self remote-address=12.12.12.2 remote-as=100 route-reflect=yes
add default-originate=always instance=default name=peer2 nexthop-choice=force-self remote-address=13.13.13.3 remote-as=100 route-reflect=yes
[admin@R1] > /routing bgp network
add disabled=no network=12.12.12.0/24 synchronize=yes
add disabled=no network=13.13.13.0/24 synchronize=yes
Konfigurasi R2

[admin@R2] > /ip address
add address=12.12.12.2/24 disabled=no interface=ether1 network=12.12.12.0
add address=25.25.25.2/24 disabled=no interface=ether3 network=25.25.25.0
add address=26.26.26.2/24 disabled=no interface=ether4 network=26.26.26.0
add address=24.24.24.2/24 disabled=no interface=ether2 network=24.24.24.0
add address=1.0.0.2/32 disabled=no interface=lo1 network=1.0.0.2
[admin@R2] > /routing bgp instance
set default as=100 client-to-client-reflection=yes cluster-id=1.0.0.2 redistribute-connected=yes router-id=1.0.0.2
[admin@R2] > /routing bgp peer
add default-originate=always instance=default name=peer1 nexthop-choice=force-self remote-address=25.25.25.5 remote-as=200 route-reflect=yes
add default-originate=always instance=default name=peer2 nexthop-choice=force-self remote-address=26.26.26.6 remote-as=200 route-reflect=yes
add default-originate=always instance=default name=peer3 nexthop-choice=force-self remote-address=24.24.24.4 remote-as=300
add instance=default name=peer4 nexthop-choice=force-self remote-address=12.12.12.1 remote-as=500
[admin@R2] > /routing bgp network
add disabled=no network=25.25.25.0/24 synchronize=yes
add disabled=no network=26.26.26.0/24 synchronize=yes
add disabled=no network=12.12.12.0/24 synchronize=yes
add disabled=no network=24.24.24.0/24 synchronize=yes
Konfigurasi R3
[admin@R3] > /ip address
add address=13.13.13.3/24 disabled=no interface=ether1 network=13.13.13.0
add address=34.34.34.3/24 disabled=no interface=ether2 network=34.34.34.0
add address=37.37.37.3/24 disabled=no interface=ether3 network=37.37.37.0
add address=38.38.38.3/24 disabled=no interface=ether4 network=38.38.38.0
add address=1.0.0.3/32 disabled=no interface=lo1 network=1.0.0.3
[admin@R3] > /routing bgp instance
set default as=100 client-to-client-reflection=yes cluster-id=1.0.0.3 redistribute-connected=yes router-id=1.0.0.3
[admin@R3] > /routing bgp peer
add instance=default name=peer1 nexthop-choice=force-self remote-address=13.13.13.1 remote-as=500
add default-originate=always instance=default name=peer2 nexthop-choice=force-self remote-address=37.37.37.7 remote-as=400 route-reflect=yes
add default-originate=always instance=default name=peer3 nexthop-choice=force-self remote-address=38.38.38.8 remote-as=400 route-reflect=yes
add instance=default name=peer4 nexthop-choice=force-self remote-address=34.34.34.4 remote-as=300
[admin@R3] > /routing bgp network
add disabled=no network=13.13.13.0/24 synchronize=yes
add disabled=no network=34.34.34.0/24 synchronize=yes
add disabled=no network=37.37.37.0/24 synchronize=yes
add disabled=no network=38.38.38.0/24 synchronize=yes
Konfigurasi R4
[admin@R4] > /ip address
add address=24.24.24.4/24 disabled=no interface=ether1 network=24.24.24.0
add address=34.34.34.4/24 disabled=no interface=ether2 network=34.34.34.0
add address=11.0.4.4/24 disabled=no interface=ether3 network=11.0.4.0
add address=1.0.0.4/32 disabled=no interface=lo1 network=1.0.0.4
[admin@R4] > /routing bgp instance
set default as=300 client-to-client-reflection=yes cluster-id=1.0.0.4 redistribute-connected=yes router-id=1.0.0.4
[admin@R4] > /routing bgp peer
add instance=default name=peer1 nexthop-choice=force-self remote-address=24.24.24.2 remote-as=100
add instance=default name=peer2 nexthop-choice=force-self remote-address=34.34.34.3 remote-as=100
add default-originate=always name=peer3 nexthop-choice=force-self remote-address=11.0.4.11 remote-as=300 route-reflect=yes
[admin@R4] > /routing bgp network
add disabled=no network=24.24.24.0/24 synchronize=yes
add disabled=no network=34.34.34.0/24 synchronize=yes
add disabled=no network=11.0.4.0/24 synchronize=yes
Konfigurasi R5

[admin@R5] > /ip address
add address=25.25.25.5/24 disabled=no interface=ether1 network=25.25.25.0
add address=59.59.59.5/24 disabled=no interface=ether3 network=59.59.59.0
add address=56.56.56.5/24 disabled=no interface=ether2 network=56.56.56.0
add address=1.0.0.5/32 disabled=no interface=lo1 network=1.0.0.5
[admin@R5] > /routing bgp instance
set default as=5 client-to-client-reflection=yes cluster-id=1.0.0.5 confederation=200 confederation-peers=6,9 redistribute-connected=yes router-id=1.0.0.5
[admin@R5] > /routing bgp peer
add default-originate=always instance=default name=peer1 nexthop-choice=force-self remote-address=59.59.59.9 remote-as=9 route-reflect=yes
add default-originate=always instance=default name=peer2 remote-address=56.56.56.6 remote-as=6 rroute-reflect=yes
add instance=default name=peer3 remote-address=25.25.25.2 remote-as=100
[admin@R5] > /routing bgp network
add disabled=no network=59.59.59.0/24 synchronize=yes
add disabled=no network=56.56.56.0/24 synchronize=yes
add disabled=no network=25.25.25.0/24 synchronize=yes
Konfigurasi R6

[admin@R6] > /ip address
add address=26.26.26.6/24 disabled=no interface=ether1 network=26.26.26.0
add address=10.0.6.6/24 disabled=no interface=ether3 network=10.0.6.0
add address=56.56.56.6/24 disabled=no interface=ether2 network=56.56.56.0
add address=1.0.0.6/32 disabled=no interface=lo1 network=1.0.0.6
[admin@R6] > /routing bgp instance
set default as=6 client-to-client-reflection=yes cluster-id=1.0.0.6 confederation=200 confederation-peers=5,10 redistribute-connected=yes router-id=1.0.0.6
[admin@R6] > /routing bgp peer
add instance=default name=peer1 nexthop-choice=force-self remote-address=56.56.56.5 remote-as=5 route-reflect=yes
add default-originate=always instance=default multihop=no name=peer2 nexthop-choice=force-self remote-address=10.0.6.10 remote-as=10 route-reflect=yes
add instance=default name=peer3 nexthop-choice=force-self remote-address=26.26.26.2 remote-as=100
[admin@R6] > /routing bgp network
add disabled=no network=10.0.6.0/24 synchronize=yes
add disabled=no network=26.26.26.0/24 synchronize=yes
add disabled=no network=56.56.56.0/24 synchronize=yes
Konfigurasi R7

[admin@R7] > /ip address
add address=37.37.37.7/24 disabled=no interface=ether1 network=37.37.37.0
add address=78.78.78.7/24 disabled=no interface=ether2 network=78.78.78.0
add address=12.0.7.7/24 disabled=no interface=ether3 network=12.0.7.0
add address=1.0.0.7/32 disabled=no interface=lo1 network=1.0.0.7
[admin@R7] > /routing bgp instance
set default as=400 client-to-client-reflection=yes cluster-id=1.0.0.7 redistribute-connected=yes router-id=1.0.0.7
[admin@R7] > /routing bgp peer
add instance=default name=peer1 nexthop-choice=force-self remote-address=37.37.37.3 remote-as=100
add instance=default name=peer2 nexthop-choice=force-self remote-address=78.78.78.8 remote-as=400 route-reflect=yes
add default-originate=always instance=default name=peer3 nexthop-choice=force-self remote-address=12.0.7.12 remote-as=400 route-reflect=yes
[admin@R7] > /routing bgp network
add disabled=no network=37.37.37.0/24 synchronize=yes
add disabled=no network=12.0.7.0/24 synchronize=yes
add disabled=no network=78.78.78.0/24 synchronize=yes
Konfigurasi R8
[admin@R8] > /ip address
add address=38.38.38.8/24 disabled=no interface=ether1 network=38.38.38.0
add address=78.78.78.8/24 disabled=no interface=ether2 network=78.78.78.0
add address=13.0.8.8/24 disabled=no interface=ether3 network=13.0.8.0
add address=1.0.0.8/32 disabled=no interface=lo1 network=1.0.0.8
[admin@R8] > /routing bgp instance
set default as=400 client-to-client-reflection=yes cluster-id=1.0.0.8 redistribute-connected=yes router-id=1.0.0.8
[admin@R8] > /routing bgp peer
add instance=default name=peer1 nexthop-choice=force-self remote-address=38.38.38.3 remote-as=100
add instance=default name=peer2 remote-address=78.78.78.7 remote-as=400 route-reflect=yes
add default-originate=always instance=default name=peer3 nexthop-choice=force-self remote-address=13.0.8.13 remote-as=400 route-reflect=yes
[admin@R8] > /routing bgp network
add disabled=no network=78.78.78.0/24 synchronize=yes
add disabled=no network=13.0.8.0/24 synchronize=yes
add disabled=no network=38.38.38.0/24 synchronize=yes
Konfigurasi R9
[admin@R9] > /ip address
add address=59.59.59.9/24 disabled=no interface=ether1 network=59.59.59.0
[admin@R9] > /routing bgp instance
set default as=9 client-to-client-reflection=yes cluster-id=1.0.0.9 confederation=200 confederation-peers=5 redistribute-connected=yes router-id=1.0.0.9
[admin@R9] > /routing bgp peer
add instance=default name=peer1 remote-address=59.59.59.5 remote-as=5
[admin@R9] > /routing bgp network
add disabled=no network=59.59.59.0/24 synchronize=yes
Konfigurasi R10
[admin@R10] > /ip address
add address=10.0.6.10/24 disabled=no interface=ether1 network=10.0.6.0
[admin@R10] > /routing bgp instance
set default as=10 client-to-client-reflection=yes cluster-id=1.0.0.10 confederation=200 confederation-peers=6 redistribute-connected=yes router-id=1.0.0.10
[admin@R10] > /routing bgp peer
add instance=default multihop=no name=peer1 remote-address=10.0.6.6 remote-as=6
[admin@R10] > /routing bgp network
add disabled=no network=10.0.6.0/24 synchronize=yes
Konfigurasi R11
[admin@R11] > /ip address
add address=11.0.4.11/24 disabled=no interface=ether1 network=11.0.4.0
[admin@R11] > /routing bgp instance
set default as=300 client-to-client-reflection=yes cluster-id=1.0.0.11 redistribute-connected=yes router-id=1.0.0.11
[admin@R11] > /routing bgp peer
add instance=default name=peer1 remote-address=11.0.4.4 remote-as=300
[admin@R11] > /routing bgp network
add disabled=no network=11.0.4.0/24 synchronize=yes
Konfigurasi R12

[admin@R12] > /ip address
add address=12.0.7.12/24 disabled=no interface=ether1 network=12.0.7.0
[admin@R12] > /routing bgp instance
set default as=400 client-to-client-reflection=yes cluster-id=1.0.0.12 redistribute-connected=yes router-id=1.0.0.12
[admin@R12] > /routing bgp peer
add instance=default name=peer1 remote-address=12.0.7.7 remote-as=400
[admin@R12] > /routing bgp network
add disabled=no network=12.0.7.0/24 synchronize=yes
Konfigurasi R13

[admin@R13] > /ip address
add address=13.0.8.13/24 disabled=no interface=ether1 network=13.0.8.0
[admin@R13] > /routing bgp instance
set default as=400 client-to-client-reflection=yes cluster-id=1.0.0.13 redistribute-connected=yes router-id=1.0.0.13
[admin@R13] > /routing bgp peer
add instance=default  name=peer1 remote-address=13.0.8.8 remote-as=400
[admin@R13] > /routing bgp network
add disabled=no network=13.0.8.0/24 synchronize=yes
Oke setelah melakukan konfigurasi routing BGP yang cukup panjang dan melelahkan wkwk selanjutnya adalah melakukan konfigurasi route filtering pada R2, R3, dan R4 agar router local tidak mendapatkan routing yang menumpuk melainkan menggunakan default route yang sudah diberikan oleh R2, R3, dan R4 ketika konfigurasi BGP Peer tadi.
[admin@RX] > /routing filter
add action=discard chain=bgp-out disabled=no invert-match=no prefix-length=16-32 
Setelah itu konfigurasi peer pada setiap router agar menerapkan route filter yang sudah kita buat tadi.
[admin@R2] > /routing bgp peer
set peer1 out-filter=bgp-out
set peer2 out-filter=bgp-out
[admin@R3] > /routing bgp peer
set peer1 out-filter=bgp-out
[admin@R4] > /routing bgp peer
set peer1 out-filter=bgp-out
set peer2 out-filter=bgp-out
Lalu lakukan verifikasi pada salah satu router bahwa route sudah berkurang.
[admin@R9] > ip route print 
Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme, B - blackhole, U - unreachable, P - prohibit
 #      DST-ADDRESS        PREF-SRC        GATEWAY            DISTANCE
 0 ADb  0.0.0.0/0                                        59.59.59.5               20
 1 ADb  1.0.0.5/32                                      59.59.59.5               20
 2 ADb  1.0.0.6/32                                      59.59.59.5               20
 3 ADb  10.0.6.0/24                                    59.59.59.5               20
 4 ADb  25.25.25.0/24                                59.59.59
27 ADb  dst-address=59.59.59.0/24 gateway=25.25.25.5 gateway-status=25.25.25.5 reachable via  ether3 distance=20 scope=40 target-scope=10 bgp-as-path="200"
        bgp-origin=igp received-from=peer1

28  Db  dst-address=59.59.59.0/24 gateway=26.26.26.6 gateway-status=26.26.26.6 reachable via  ether4 distance=20 scope=40 target-scope=10 bgp-as-path="200"
        bgp-origin=igp received-from=peer2
Terlihat bahwa routing table yang tadinya ada banyak kini telah berkurang. Selanjutnya kita akan memanipulasi jalur. Coba lakukan traceroute terlebih dahulu dari R11 menuju R2.
[admin@R11] > tool traceroute 12.12.12.2
 # ADDRESS                                 RT1   RT2   RT3   STATUS
 1 11.0.4.4                                1ms   1ms   1ms
 2 12.12.12.2                              2ms   3ms   1ms
Terlihat bahwa nexthop yang dilewati hanya ada 2. Lalu coba kita pindah jalurnya melewati jalur yang lainnya.
[admin@R4] > /routing filter
add action=accept chain=bgp-prep disabled=yes invert-match=no prefix=12.12.12.0/24 set-bgp-prepend=1 set-bgp-prepend-path=10,20
Setelah itu definisikan in filter pada bgp peer dengan in-filter menggunakan chain yang sudah kita buat tadi.
[admin@R4] > /routing bgp peer
set peer1 in-filter=bgp-prep
Lalu lakukan verifikasi traceroute kembali.
[admin@R11] > tool traceroute 12.12.12.2
 # ADDRESS                                 RT1   RT2   RT3   STATUS
 1 11.0.4.4                                1ms   1ms   1ms
 2 34.34.34.3                              1ms   1ms   1ms
 3 13.13.13.1                              2ms   2ms   3ms
 4 12.12.12.2                              3ms   2ms   2ms
Setelah itu maka akan terlihat bahwa jalur yang digunakan telah berbeda. Selanjutnya kita membatasi prefix yang dapat diperbolehkan masuk ke dalam sebuah router. Sebelumnya lakukan verifikasi terlebih dahulu.
 [admin@R4] > routing bgp peer print status
Flags: X - disabled, E - established
 0 E name="peer1" instance=default remote-address=24.24.24.2 remote-as=100 tcp-md5-key="" nexthop-choice=force-self multihop=no route-reflect=no hold-time=3m ttl=255
      in-filter=bgp-prep out-filter=yes address-families=ip default-originate=never remove-private-as=no as-override=no passive=no
     use-bfd=no remote-id=1.0.0.2 local-address=24.24.24.4 uptime=5h2m53s prefix-count=15 updates-sent=72 updates-received=130 withdrawn-sent=3 withdrawn-received=0
     remote-hold-time=3m used-hold-time=3m used-keepalive-time=1m refresh-capability=yes as4-capability=yes state=established

 1 E name="peer2" instance=default remote-address=34.34.34.3 remote-as=100 tcp-md5-key="" nexthop-choice=force-self multihop=no route-reflect=no hold-time=3m ttl=255
      in-filter=yes out-filter="" address-families=ip default-originate=never remove-private-as=no as-override=no passive=no use-bfd=no
     remote-id=1.0.0.3 local-address=34.34.34.4 uptime=5h2m52s prefix-count=14 updates-sent=44 updates-received=113 withdrawn-sent=4 withdrawn-received=0
     remote-hold-time=3m used-hold-time=3m used-keepalive-time=1m refresh-capability=yes as4-capability=yes state=established

 2 E name="peer3" instance=default remote-address=11.0.4.11 remote-as=300 tcp-md5-key="" nexthop-choice=force-self multihop=no route-reflect=yes hold-time=3m ttl=255
     in-filter="" out-filter="" address-families=ip default-originate=always remove-private-as=no as-override=no passive=no use-bfd=no remote-id=1.0.0.11
     local-address=11.0.4.4 uptime=6h35m50s prefix-count=1 updates-sent=102 updates-received=9 withdrawn-sent=20 withdrawn-received=0 remote-hold-time=3m
     used-hold-time=3m used-keepalive-time=1m refresh-capability=yes as4-capability=yes state=established
Terlihat diatas bahwa pada peer1 terdapat 15 prefix yang masuk ke dia, kemudian pada peer2 terdapat 14 prefix yang masuk ke dia, dan pada peer 3 terdapat 1 prefix yang masuk. Lalu kali ini kita akan mengkonfigurasi maximum prefix yang dapat masuk ke dia. Lalu apa yang terjadi jika prefix yang masuk melebihi limit tersebut? Mari kita lihat. Konfigurasi max-prefix-limit pada salah satu peer. Saya akan memilih peer1 dengan max-prefix-limit 10.
[admin@R4] > routing bgp peer print status
Flags: X - disabled, E - established
 0 E name="peer1" instance=default remote-address=24.24.24.2 remote-as=100 tcp-md5-key="" nexthop-choice=force-self multihop=no route-reflect=no hold-time=3m ttl=255
     in-filter=bgp-prep out-filter=yes address-families=ip default-originate=never remove-private-as=no as-override=no passive=no
     use-bfd=no remote-id=1.0.0.2 local-address=24.24.24.4 uptime=5h2m53s prefix-count=15 updates-sent=72 updates-received=130 withdrawn-sent=3 withdrawn-received=0
     remote-hold-time=3m used-hold-time=3m used-keepalive-time=1m refresh-capability=yes as4-capability=yes state=established

 1 E name="peer2" instance=default remote-address=34.34.34.3 remote-as=100 tcp-md5-key="" nexthop-choice=force-self multihop=no route-reflect=no hold-time=3m ttl=255
     in-filter=yes out-filter="" address-families=ip default-originate=never remove-private-as=no as-override=no passive=no use-bfd=no
     remote-id=1.0.0.3 local-address=34.34.34.4 uptime=5h2m52s prefix-count=14 updates-sent=44 updates-received=113 withdrawn-sent=4 withdrawn-received=0
     remote-hold-time=3m used-hold-time=3m used-keepalive-time=1m refresh-capability=yes as4-capability=yes state=established

 2 E name="peer3" instance=default remote-address=11.0.4.11 remote-as=300 tcp-md5-key="" nexthop-choice=force-self multihop=no route-reflect=yes hold-time=3m ttl=255
     in-filter="" out-filter="" address-families=ip default-originate=always remove-private-as=no as-override=no passive=no use-bfd=no remote-id=1.0.0.11
     local-address=11.0.4.4 uptime=6h35m50s prefix-count=1 updates-sent=102 updates-received=9 withdrawn-sent=20 withdrawn-received=0 remote-hold-time=3m
     used-hold-time=3m used-keepalive-time=1m refresh-capability=yes as4-capability=yes state=established
[admin@R4] > routing bgp peer set numbers=0 max-prefix-limit=10
[admin@R4] > routing bgp peer print
Flags: X - disabled, E - established
 #   INSTANCE      REMOTE-ADDRESS REMOTE-AS 
 0   default              24.24.24.2                100       
 1 E default             34.34.34.3                100       
 2 E default             11.0.4.11                  300  
Maka akan terlihat bahwa status established yang ada pada peer1 akan hilang dikarenakan sudah melebihi prefix yang telah di tentukan oleh R4. Selanjutnya kita akan membuat seluruh perangkat terhubung ke internet. Kali ini saya akan menggunakan 2 ISP dimana 1 ISP sebagai cadangan, dan 1 lagi menjadi jalur utama. Saya akan menggunakan konsep fail over menggunakan static route.
[admin@R1] > /ip route
add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=19.19.19.4
add disabled=no distance=1 dst-address=1.0.0.5/32 gateway=12.12.12.2
Lalu lakukan verifikasi tabel routing.
[admin@R1] > ip route print detail where dst-address=0.0.0.0/0
Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme, B - blackhole, U - unreachable, P - prohibit
 0 A S  dst-address=0.0.0.0/0 gateway=19.19.19.4 gateway-status=19.19.19.4 reachable via  ether1 check-gateway=ping distance=1 scope=30 target-scope=10

 1   S  dst-address=0.0.0.0/0 gateway=10.10.10.4 gateway-status=10.10.10.4 reachable via  ether2 distance=2 scope=30 target-scope=10
Maka akan terlihat salah satu link yang aktif dan satu lagi tidak aktif. Untuk menjadikan seluruh router dapat terkoneksi ke internet, tambahkan firewall dan dns.
[admin@RX] > /ip firewall nat
add action=masquerade chain=srcnat disabled=no out-interface=(interface internet)
[admin@RX] > /ip dns
set allow-remote-requests=yes servers=8.8.8.8,8.8.4.4
 Lalu lakukan verifikasi pada router local bahwa sudah terhubung ke internet.
[admin@R12] > ping google.com
HOST                                     SIZE TTL TIME  STATUS
74.125.200.100                             56  38 45ms
74.125.200.100                             56  38 46ms
74.125.200.100                             56  38 44ms
    sent=3 received=3 packet-loss=0% min-rtt=44ms avg-rtt=45ms max-rtt=46ms
Dan selesai.

Terimakasih, Wassalamualaikum. 

Saturday, 28 January 2017

Lab. 19 Superlab Mikrotik

Assalamualaikum,

Pada kali ini saya akan melanjutkan materi routing yang sebelumnya saya telah memposting materi mengenai routing juga yaitu pada Lab. 18 Superlab Mikrotik. Oke langsung saja, berikut topologi yang akan saya gunakan.
Dalam materi ini saya akan membahas beberapa materi yaitu sebagai berikut.
  1. OSPF Multi Area
  2. OSPF Distribute Default 
  3. Routing Filter 
  4. RIP 
  5. MPLS LDP
  6. Redistribute 
  7. Virtual Link
Konfigurasi

Lakukan konfigurasi ip address terlebih dahulu pada setiap interface yang ada pada router. Untuk konfigurasi ip address, saya tidak akan menuliskan satu persatu padapostingan ini dan insya allah nanti akan saya update lagi dengan tabel ip address. Langsung saja konfigurasi instance pada setiap router.
[admin@R10] > /routing ospf instance
set default redistribute-connected=as-type-1 router-id=0.0.10.10
[admin@R11] > /routing ospf instance
set default redistribute-connected=as-type-1 router-id=0.0.11.11
[admin@R12] > /routing ospf instance
set default redistribute-connected=as-type-1 router-id=0.0.12.12
[admin@R13] > /routing ospf instance
set default redistribute-connected=as-type-1 router-id=0.0.13.13
[admin@R4] > /routing ospf instance
set default redistribute-connected=as-type-1 router-id=0.0.4.4
[admin@R5] > /routing ospf instance
set default redistribute-connected=as-type-1 router-id=0.0.5.5
[admin@R1] > /routing ospf instance
set default redistribute-connected=as-type-1 router-id=0.0.1.1
[admin@R2] > /routing ospf instance
set default redistribute-connected=as-type-1 router-id=0.0.2.2
[admin@R3] > /routing ospf instance
set default redistribute-connected=as-type-1 router-id=0.0.3.3
[admin@R6] > /routing ospf instance
set default redistribute-connected=as-type-1 router-id=0.0.6.6
[admin@R7] > /routing ospf instance
set default redistribute-connected=as-type-1 router-id=0.0.7.7
[admin@R14] > /routing ospf instance
set default redistribute-connected=as-type-1 router-id=0.0.14.14
[admin@R15] > /routing ospf instance
set default redistribute-connected=as-type-1 router-id=0.0.15.15
[admin@R16] > /routing ospf instance
set default redistribute-connected=as-type-1 router-id=0.0.16.16
[admin@R17] > /routing ospf instance
set default redistribute-connected=as-type-1 router-id=0.0.17.17
Oke jika sudah menambahkan mengatur instance pada router OSPF, selanjutnya konfigurasi area dikarenakan pada lab ini akan ada banyak area yang akan digunakan.
[admin@R10] > /routing ospf area
add area-id=0.0.0.2 default-cost=1 disabled=no inject-summary-lsas=yes instance=default name=area2 type=stub
[admin@R11] > /routing ospf area
add area-id=0.0.0.2 disabled=no instance=default name=area2 type=default
[admin@R12] > /routing ospf area
add area-id=0.0.0.3 default-cost=1 disabled=no inject-summary-lsas=yes instance=default name=area3 type=stub
[admin@R13] > /routing ospf area
add area-id=0.0.0.3 default-cost=1 disabled=no inject-summary-lsas=yes instance=default name=area3 type=stub
[admin@R4] > /routing ospf area
add area-id=0.0.0.1 disabled=no instance=default name=area1 type=default
add area-id=0.0.0.2 default-cost=1 disabled=no inject-summary-lsas=yes instance=default name=area2 type=stub
[admin@R5] > /routing ospf area
add area-id=0.0.0.1 disabled=no instance=default name=area1 type=default
add area-id=0.0.0.3 default-cost=1 disabled=no inject-summary-lsas=yes instance=default name=area3 type=stub
[admin@R6] > /routing ospf area
add area-id=0.0.0.4 disabled=no instance=default name=area4 type=default
add area-id=0.0.0.5 disabled=no instance=default name=area5 type=default
[admin@R7] > /routing ospf area
add area-id=0.0.0.4 disabled=no instance=default name=area4 type=default
add area-id=0.0.0.6 disabled=no instance=default name=area6 type=default
[admin@R14] > /routing ospf area
add area-id=0.0.0.5 disabled=no instance=default name=area5 type=default
[admin@R15] > /routing ospf area
add area-id=0.0.0.5 disabled=no instance=default name=area5 type=default
[admin@R16] > /routing ospf area
add area-id=0.0.0.6 disabled=no instance=default name=area6 type=default
[admin@R17] > /routing ospf area
add area-id=0.0.0.6 disabled=no instance=default name=area6 type=default
Setelah itu, tambahkan network yang terhubung dengan router OSPF.
[admin@R10] > /routing ospf network
add area=area2 disabled=no network=1.1.10.0/24
[admin@R11] > /routing ospf network
add area=area2 disabled=no network=1.1.11.0/24
[admin@R12] > /routing ospf network
add area=area3 disabled=no network=1.1.12.0/24
[admin@R13] > /routing ospf network
add area=area3 disabled=no network=1.1.13.0/24
[admin@R4] > /routing ospf network
add area=area1 disabled=no network=1.1.4.0/30
add area=area2 disabled=no network=1.1.10.0/24
add area=area2 disabled=no network=1.1.11.0/24
add area=area1 disabled=no network=4.4.4.4/32
add area=area1 disabled=no network=2.2.4.0/30
[admin@R5] > /routing ospf network
add area=area1 disabled=no network=1.1.5.0/30
add area=area3 disabled=no network=1.1.12.0/24
add area=area3 disabled=no network=1.1.13.0/24
add area=area1 disabled=no network=5.5.5.5/32
add area=area1 disabled=no network=2.2.4.0/30
[admin@R1] > /routing ospf network
add area=backbone disabled=no network=1.1.1.0/30
add area=area1 disabled=no network=1.1.4.0/30
add area=area1 disabled=no network=1.1.5.0/30
add area=backbone disabled=no network=100.100.100.100/32
[admin@R2] > /routing ospf network
add area=backbone disabled=no network=1.1.1.0/30
add area=backbone disabled=no network=1.1.3.0/30
add area=backbone disabled=no network=2.2.2.2/32
[admin@R3] > /routing ospf network
add area=backbone disabled=no network=1.1.3.0/30
add area=area4 disabled=no network=1.1.6.0/30
add area=area4 disabled=no network=1.1.7.0/30
add area=backbone disabled=no network=3.3.3.3/32
[admin@R6] > /routing ospf network
add area=area4 disabled=no network=1.1.6.0/30
add area=area5 disabled=no network=1.1.14.0/24
add area=area5 disabled=no network=1.1.15.0/24
add area=area4 disabled=no network=6.6.6.6/32
add area=area4 disabled=no network=2.2.6.0/30
[admin@R7] > /routing ospf network
add area=area4 disabled=no network=1.1.7.0/30
add area=area6 disabled=no network=1.1.16.0/24
add area=area6 disabled=no network=1.1.17.0/24
add area=area4 disabled=no network=7.7.7.7/32
add area=area4 disabled=no network=2.2.4.0/30
[admin@R14] > /routing ospf network
add area=area5 disabled=no network=1.1.14.0/24
[admin@R15] > /routing ospf network
add area=area5 disabled=no network=1.1.15.0/24
[admin@R16] > /routing ospf network
add area=area6 disabled=no network=1.1.16.0/24
[admin@R17] > /routing ospf network
add area=area6 disabled=no network=1.1.17.0/24
 Setelah itu tambahkan virtual link untuk menghubungkan daerah daerah yang tidak terhubung langsung dengan backbone area.
[admin@R4] > /routing ospf virtual-link
add authentication=md5 authentication-key=IDN authentication-key-id=1 disabled=no instance-id=0 neighbor-id=0.0.1.1 transit-area=area1 use-bfd=no
[admin@R5] > /routing ospf virtual-link
add authentication=md5 authentication-key=IDN authentication-key-id=1 disabled=no instance-id=0 neighbor-id=0.0.1.1 transit-area=area1 use-bfd=no
[admin@R1] > /routing ospf virtual-link
add authentication=md5 authentication-key=IDN authentication-key-id=1 disabled=no instance-id=0 neighbor-id=0.0.4.4 transit-area=area1 use-bfd=no
add authentication=md5 authentication-key=IDN authentication-key-id=1 disabled=no instance-id=0 neighbor-id=0.0.5.5 transit-area=area1 use-bfd=no
[admin@R3] > /routing ospf virtual-link
add authentication=md5 authentication-key=IDN authentication-key-id=1 disabled=no instance-id=0 neighbor-id=0.0.6.6 transit-area=area4 use-bfd=no
add authentication=md5 authentication-key=IDN authentication-key-id=1 disabled=no instance-id=0 neighbor-id=0.0.7.7 transit-area=area4 use-bfd=no
[admin@R6] > /routing ospf virtual-link
add authentication=md5 authentication-key=IDN authentication-key-id=1 disabled=no instance-id=0 neighbor-id=0.0.3.3 transit-area=area4 use-bfd=no
[admin@R7] > /routing ospf virtual-link
add authentication=md5 authentication-key=IDN authentication-key-id=1 disabled=no instance-id=0 neighbor-id=0.0.3.3 transit-area=area4 use-bfd=no
Lalu pastikan bahwa router yang berada pada area yang terisolir sudah mendapatkan route untuk menuju area backbone. Setelah itu dikarenakan sebelumnya kita mengatur daerah yang terisolir tersebut sebagai stub area dimana stub area tersebut tidak akan mendapatkan advertise dari external route dan menggantikan external route tersebut menjadi default route untuk menuju external route. Kita akan membuat pada router yang berada pada daerah yang terisolir tidak mendapatkan route dari area backbone dan hanya mengandalkan default route yang ada pada dirinya. Tambahkan route filtering pada setiap router yang berada pada daerah yang terisolir.
[admin@R10] > /routing filter
add action=discard chain=ospf-in disabled=no invert-match=no prefix-length=24-32
[admin@R11] > /routing filter
add action=discard chain=ospf-in disabled=no invert-match=no prefix-length=24-32
[admin@R12] > /routing filter
add action=discard chain=ospf-in disabled=no invert-match=no prefix-length=24-32 
[admin@R13] > /routing filter
add action=discard chain=ospf-in disabled=no invert-match=no prefix-length=24-32
[admin@R14] > /routing filter
add action=discard chain=ospf-in disabled=no invert-match=no prefix-length=24-32
[admin@R15] > /routing filter
add action=discard chain=ospf-in disabled=no invert-match=no prefix-length=24-32 
[admin@R16] > /routing filter
add action=discard chain=ospf-in disabled=no invert-match=no prefix-length=24-32
[admin@R17] > /routing filter
add action=discard chain=ospf-in disabled=no invert-match=no prefix-length=24-32
Lalu cek routing tablee yang ada pada salah satu router pada daerah yang terisolir.
[admin@R10] > ip route print       
Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme, B - blackhole, U - unreachable, P - prohibit
 #      DST-ADDRESS        PREF-SRC        GATEWAY            DISTANCE
 0 ADo  0.0.0.0/0                                        1.1.10.1               110
 1 ADC  0.0.10.10/32         10.10.10.10      lo1                       0
 2 ADC  1.1.10.0/24           1.1.10.2            ether1                 0
Maka akan terlihat untuk menuju ke dunia luar, router akan menggunakan default route yang ada pada router. Ini sama halnya ketika kita menerapkan konsep totally stub area pada jaringan OSPF dimana pada routing table yang ada pada router hanya akan ada default route dan juga route directly connected.

Selanjutnya, kita lakukan konfigurasi terhadap RIP. R2 nantinya akan dipasang distribute default agar area rip dapat berkomunikasi dengan dunia luar tanpa harus memiliki seluruh routing table.

Oke langsung saja, konfigurasi routing RIP terlebih dahulu.
[admin@R2] > /routing rip
set default distribute-default=always redistribute-connected=yes
/routing rip interface
add interface=all
[admin@R8] > /routing rip
set redistribute-connected=yes
/routing rip interface
add interface=all
[admin@R9] > /routing rip
set redistribute-connected=yes
/routing rip interface
add interface=all
[admin@R18] > /routing rip
set redistribute-connected=yes
/routing rip interface
add interface=all
[admin@R19] > /routing rip
set redistribute-connected=yes
/routing rip interface
add interface=all
[admin@R20] > /routing rip
set redistribute-connected=yes
/routing rip interface
add interface=all
[admin@R21] > /routing rip
set redistribute-connected=yes
/routing rip interface
add interface=all
Lalu daftarkan neighbors yang terhubung dengan router rip.
[admin@R2] > /routing rip neighbor
add address=1.1.8.2 disabled=no
add address=1.1.9.2 disabled=no
[admin@R2] > /routing rip network
add disabled=no network=1.1.8.0/30
add disabled=no network=1.1.9.0/30
[admin@R8] > /routing rip neighbor
add address=1.1.8.1 disabled=no
add address=1.1.20.2 disabled=no
add address=1.1.21.2 disabled=no
[admin@R8] > /routing rip network
add disabled=no network=1.1.8.0/30
add disabled=no network=1.1.20.0/24
add disabled=no network=1.1.21.0/24
[admin@R9] > /routing rip neighbor
add address=1.1.9.1 disabled=no
add address=1.1.18.2 disabled=no
add address=1.1.19.2 disabled=no
[admin@R9] > /routing rip network
add disabled=no network=1.1.9.0/30
add disabled=no network=1.1.18.0/24
add disabled=no network=1.1.19.0/24
[admin@R18] > /routing rip neighbor
add address=1.1.18.1 disabled=no
[admin@R18] > /routing rip network
add disabled=no network=1.1.18.0/24
[admin@R19] > /routing rip neighbor
add address=1.1.19.1 disabled=no
[admin@R19] > /routing rip network
add disabled=no network=1.1.19.0/24
[admin@R20] > /routing rip neighbor
add address=1.1.20.1 disabled=no
[admin@R20] > /routing rip network
add disabled=no network=1.1.20.0/24
[admin@R21] > /routing rip neighbor
add address=1.1.21.1 disabled=no
[admin@R21] > /routing rip network
add disabled=no network=1.1.21.0/24
Setelah itu, coba ping dari R18 munuju ke jaringan ospf.
[admin@R18] > ping 1.1.14.2
HOST                                     SIZE TTL TIME  STATUS
1.1.14.2                                                timeout 
    sent=1 received=0 packet-loss=100%
Mengapa tidak bisa melakukan ping? Hal ini dikarenakan pada jaringan OSPF, sumber dari router RIP itu tidak ada dikarenakan kita tidak melakukan redistribute rip pada R2. Namun kita kali ini memang tidak redistribute rip, melainkan kali ini kita akan mencoba untuk menggunakan NAT. Penggunaan nat digunakan mentranslasikan address yang ada pada router rip, jadi ketika router RIP mengirimkan paket ke jaringan OSPF, Router OSPF akan mengira yang mengirimkan itu adalah R2, jadi Router OSPF akan mengirimkan balasan kepada Router RIP kembali.

Tambahkan firewall nat pada R2.
[admin@R2] > /ip firewall nat
add chain=srcnat action=masquerade out-interface=ether2
Setelah itu lakukan verifikasi ping dari R18 menuju ke R14.
[admin@R18] > ping 1.1.14.1
HOST                                     SIZE TTL TIME  STATUS
1.1.14.1                                   56  61 6ms 
    sent=1 received=1 packet-loss=0% min-rtt=6ms avg-rtt=6ms max-rtt=6ms
Maka R18 telah dapat melakukan ping kepada R14.
[admin@R4] > /mpls ldp
set enabled=yes lsr-id=4.4.4.4 transport-address=4.4.4.4
/mpls ldp interface
add interface=ether1
[admin@R5] > /mpls ldp
set enabled=yes lsr-id=5.5.5.5 transport-address=5.5.5.5
/mpls ldp interface
add interface=ether1
[admin@R1] > /mpls ldp
set enabled=yes lsr-id=100.100.100.100 transport-address=100.100.100.100
/mpls ldp interface
add interface=ether2
add interface=ether3
add interface=ether1
[admin@R2] > /mpls ldp
set enabled=yes lsr-id=2.2.2.2 transport-address=2.2.2.2
/mpls ldp interface
add interface=ether1
add interface=ether2
[admin@R3] > /mpls ldp
set enabled=yes lsr-id=3.3.3.3 transport-address=3.3.3.3
/mpls ldp interface
add interface=ether2
add interface=ether3
add interface=ether1
[admin@R6] > /mpls ldp
set enabled=yes lsr-id=6.6.6.6 transport-address=6.6.6.6
/mpls ldp interface
add interface=ether1
[admin@R7] > /mpls ldp
set enabled=yes lsr-id=7.7.7.7 transport-address=7.7.7.7
/mpls ldp interface
add interface=ether1 
Maka lakukan verifikasi pada salah satu router yaitu R2.


Maka jika MPLS berhasil, maka status dari mpls neighbor adalah Dynamic Opeational (DO). Lalu coba traceroute dari R10 ke R14.
[admin@R10] > tool traceroute 1.1.14.2
 # ADDRESS                            RT1   RT2   RT3   STATUS
 1 1.1.10.1                                5ms   3ms   32ms
 2 1.1.4.1                                 18ms  17ms  18ms  <MPLS:L=22,E=0>
 3 1.1.1.1                                 14ms  16ms  14ms  <MPLS:L=33,E=0>
 4 1.1.3.2                                 22ms  18ms  16ms  <MPLS:L=27,E=0>
 5 1.1.6.2                                 47ms  13ms  12ms
 6 1.1.14.2                               32ms  23ms  37ms
Maka akan terlihat hasilnya bahwa jalur yang dilewati merupakan jalur MPLS dengan label yang telah diberikan secaa dinamis oleh MPLS itu tersendiri.

Friday, 27 January 2017

Lab. 18 Superlab Mikrotik

Assalamualaikum,

Pada kali ini saya akan melanjutkan materi routing yang sebelumnya saya telah memposting materi mengenai routing juga yaitu pada Lab. 17 Superlab Mikrotik. Oke langsung saja, berikut topologi yang akan saya gunakan.


Dan materi yang akan dibahas pada lab ini adalah sebagai berikut.
  1. BGP Confederation 
  2. BGP Nexthop Self
  3. BGP Multihop 
  4. BGP Multihoming
  5. BGP Path Selection ( Weight, Prepend, Local Preference )
Konfigurasi

Pertama tama, tambahkan ip address pada setiap interface yang ada pada router. 
[admin@R5] > /ip address
add address=1.1.5.2/30 disabled=no interface=ether1 network=1.1.5.0
[admin@R6] > /ip address
add address=1.1.6.2/30 disabled=no interface=ether1 network=1.1.6.0
[admin@R7] > /ip address
add address=1.1.5.1/30 disabled=no interface=ether4 network=1.1.5.0
add address=1.1.6.1/30 disabled=no interface=ether3 network=1.1.6.0
add address=1.1.7.2/30 disabled=no interface=ether1 network=1.1.7.0
add address=2.2.7.2/30 disabled=no interface=ether2 network=2.2.7.0
[admin@R9] > /ip address
add address=1.1.9.2/30 disabled=no interface=ether1 network=1.1.9.0
[admin@R10] > /ip address
add address=1.1.10.2/30 disabled=no interface=ether1 network=1.1.10.0
[admin@R8] > /ip address
add address=1.1.8.2/30 disabled=no interface=ether1 network=1.1.8.0
add address=2.2.8.2/30 disabled=no interface=ether2 network=2.2.8.0
add address=1.1.9.1/30 disabled=no interface=ether3 network=1.1.9.0
add address=1.1.10.1/30 disabled=no interface=ether4 network=1.1.10.0
[admin@R1] > /ip address
add address=1.1.7.1/30 disabled=no interface=ether1 network=1.1.7.0
add address=1.1.2.1/30 disabled=no interface=ether2 network=1.1.2.0
[admin@R2] > /ip address
add address=1.1.2.2/30 disabled=no interface=ether1 network=1.1.2.0
add address=1.1.8.1/30 disabled=no interface=ether2 network=1.1.8.0
[admin@R3] > /ip address
add address=2.2.7.1/30 disabled=no interface=ether1 network=2.2.7.0
add address=2.2.4.1/30 disabled=no interface=ether2 network=2.2.4.0
[admin@R4] > /ip address
add address=2.2.4.2/30 disabled=no interface=ether1 network=2.2.4.0
add address=2.2.8.1/30 disabled=no interface=ether2 network=2.2.8.0
Setelah itu, konfigurasi BGP Instance pada router yang berada pada AS100 dan AS200.
[admin@R1] > /routing bgp instance
set default as=100 client-to-client-reflection=yes router-id=0.0.0.1
[admin@R2] > /routing bgp instance
set default as=100 client-to-client-reflection=yes router-id=0.0.0.2
[admin@R3] > /routing bgp instance
set default as=200 client-to-client-reflection=yes router-id=0.0.0.3 
[admin@R4] > /routing bgp instance
set default as=200 client-to-client-reflection=yes router-id=0.0.0.4
Selanjutnya baru lakukan konfigurasi pada router yang berada pada blok sebelah kanan dan kiri.
[admin@R5] > /routing bgp instance
set default as=5 client-to-client-reflection=yes confederation=7 confederation-peers=7 router-id=0.0.0.5
[admin@R6] > /routing bgp instance
set default as=6 client-to-client-reflection=yes confederation=7 confederation-peers=7 router-id=0.0.0.6
[admin@R7] > /routing bgp instance
set default as=7 client-to-client-reflection=yes confederation=7 confederation-peers=5-6 router-id=0.0.0.7
[admin@R9] > /routing bgp instance
set default as=9 client-to-client-reflection=yes confederation=8 confederation-peers=8 router-id=0.0.0.9
[admin@R10] > /routing bgp instance
set default as=10 client-to-client-reflection=yes confederation=8 confederation-peers=8 router-id=0.0.0.10
[admin@R8] > /routing bgp instance
set default as=8 client-to-client-reflection=yes confederation=8 confederation-peers=9-10 router-id=0.0.0.8
Ada beberapa yang berbeda pada saat konfigurasi AS100, AS200 dan Router blok kanan dan kiri. Pada saat konfigurasi router blok kanan dan kiri, ada konfigurasi confederation. BGP Confederation merupakan sebuah skema scalability routing dimana beberapa router yang semulanya berada dalam beberapa AS, dibagi bagi seolah olah menjadi beberapa AS namun semuanya itu tetap berada pada AS yang sama. Pada bagian blok kiri, router akan menggunakan confederation 7 dan pada bagian blok kanan, router akan menggunakan confederation 8.

Selanjutnya, konfigurasi peering antar router.
[admin@R5] > /routing bgp peer
add multihop=yes name=peer1 nexthop-choice=remote-address=1.1.5.1 remote-as=7
[admin@R6] > /routing bgp peer
add name=peer1 remote-address=1.1.6.1 remote-as=7
[admin@R7] > /routing bgp peer
add multihop=yes name=peer1 nexthop-choice=force-self remote-address=1.1.7.1 remote-as=100
add multihop=yes name=peer2 nexthop-choice=force-self remote-address=2.2.7.1 remote-as=200
add multihop=yes name=peer3 nexthop-choice=force-self remote-address=1.1.5.2 remote-as=5 route-reflect=yes
add multihop=yes name=peer4 nexthop-choice=force-self remote-address=1.1.6.2 remote-as=6 route-reflect=yes
[admin@R9] > /routing bgp peer
add multihop=yes name=peer1 nexthop-choice=force-self remote-address=1.1.9.1 remote-as=8
[admin@R10] > /routing bgp peer
add multihop=yes name=peer1 nexthop-choice=force-self remote-address=1.1.10.1 remote-as=8
[admin@R8] > /routing bgp peer
add multihop=yes name=peer1 nexthop-choice=force-self remote-address=1.1.8.1 remote-as=100
add multihop=yes name=peer2 nexthop-choice=force-self remote-address=2.2.8.1 remote-as=200
add multihop=yes name=peer3 nexthop-choice=force-self remote-address=1.1.9.2 remote-as=9
add multihop=yes name=peer4 nexthop-choice=force-self remote-address=1.1.10.2 remote-as=10
[admin@R1] > /routing bgp peer
add  name=peer1 nexthop-choice=force-self remote-address=1.1.2.2 remote-as=100
add multihop=yes name=peer2 nexthop-choice=force-self remote-address=1.1.7.2 remote-as=7
[admin@R2] > /routing bgp peer
add multihop=yes name=peer1 nexthop-choice=force-self remote-address=1.1.2.1 remote-as=100
add multihop=yes name=peer2 nexthop-choice=force-self remote-address=1.1.8.2 remote-as=8
[admin@R3] > /routing bgp peer
add multihop=yes name=peer1 nexthop-choice=force-self remote-address=2.2.7.2 remote-as=7
add multihop=yes name=peer2 nexthop-choice=force-self remote-address=2.2.4.2 remote-as=200
[admin@R4] > /routing bgp peer
add multihop=yes name=peer1 nexthop-choice=force-self remote-address=2.2.4.1 remote-as=200
add multihop=yes name=peer2 nexthop-choice=force-self remote-address=2.2.8.2 remote-as=8
Jika sudah melakukan konfigurasi, pastikan semuanya saling dapat berkomunikasi. Lalu lakukan verifikasi bahwa confederation sudah berhasil. Setelah itu, lakukan traceroute dari R6 ke R9 dan lihat jalur mana saja yang digunakan.
[admin@R6] > tool traceroute 1.1.9.2
 # ADDRESS                                 RT1   RT2   RT3   STATUS
 1 1.1.6.1                                       1ms   1ms   1ms
 2 1.1.7.1                                       7ms   1ms   1ms
 3 1.1.2.2                                       1ms   1ms   2ms
 4 1.1.8.2                                       2ms   2ms   1ms
 5 1.1.9.2                                       2ms   2ms   2ms
Terlihat pada hasil traceroute diatas, bahwa untuk mengirim packet menuju R9 maka jalan yang dilewati adalah AS100. Kali ini kita akan merubah jalur yang semulanya melewati AS100, kali ini akan melewati AS200. Kita akan mindah jalur menggunakan attribute AS_PATH.
[admin@R7] > /routing filter
add action=accept chain=bgp-out disabled=no invert-match=no set-bgp-prepend=1 set-bgp-prepend-path=10,20,30
[admin@R7] > /routing bgp peer
set peer1 in-filter=bgp-in
Terlihat pada konfigurasi diatas, BGP Prepend akan menentukan berapa kali AS yang dilewati akan diulang. Misalkan kita harus melewati AS100 untuk menuju R9, maka ketika BGP Prepend di set dengan value 1, maka AS100 hanya akan muncul 1 kali pada routing table, dan jika BGP Prepend di set dengan value 2, maka akan terlihat AS100 yang akan dilewati menjadi 2. Sedangkan BGP Prepend path, itu ibarat AS palsu yang dibuat oleh router, dan nantinya ketika akan menuju R9, maka AS palsu tersebut akan muncul pada bgp as path, namun dalam kenyataannya, AS tersebut tidak ada. Lakukan verifikasi routing table.
[admin@R7] > ip route print detail where dst-address=1.1.7.0/30
Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme, B - blackhole, U - unreachable, P - prohibit
 6 ADC  dst-address=1.1.7.0/30 pref-src=1.1.7.2 gateway=ether1 gateway-status=ether1 reachable distance=0 scope=10

 7  Db  dst-address=1.1.7.0/30 gateway=1.1.7.1 gateway-status=1.1.7.1 reachable via  ether1 distance=20 scope=40 target-scope=30 bgp-as-path="7,10,20,30,100" bgp-origin=igp received-from=peer1
Maka akan terlihat AS AS palsu yang sebelumya sudah kita buat. Oh iya, coba lihat pada status dari routing table yang sudah kita verifikasi tadi. Terlihat BGP Routing dengan AS100 tidak aktif. Coba lakukan verifikasi traceroute.
[admin@R6] > tool traceroute 1.1.9.2
 # ADDRESS                                 RT1   RT2   RT3   STATUS
 1 1.1.6.1                                       2ms   1ms   1ms
 2 2.2.7.1                                      5ms   2ms   2ms
 3 2.2.4.2                                     2ms   2ms   2ms
 4 1.1.8.2                                       4ms   6ms   0ms
 5 1.1.9.2                                       3ms   5ms   3ms 
Dan terlihat pada hasil verifikasi diatas bahwa jalur yang digunakan telah dirubah dan melewati AS200. Selanjutnya kita akan merubah distance pada AS200.
[admin@R7] > /routing filter
add action=accept chain=bgp-inAS200 disabled=no invert-match=no set-distance=200
[admin@R7] > /routing bgp peer
set peer2 in-filter=bgp-inAS200
Lalu lakukan verifikasi routing table.
[admin@R7] > ip route print detail where dst-address=2.2.7.0/30
Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme, B - blackhole, U - unreachable, P - prohibit
16 ADC  dst-address=2.2.7.0/30 pref-src=2.2.7.2 gateway=ether2 gateway-status=ether2 reachable distance=0 scope=10

17  Db  dst-address=2.2.7.0/30 gateway=2.2.7.1 gateway-status=2.2.7.1 reachable via  ether2 distance=200 scope=40 target-scope=30 bgp-as-path="200" bgp-origin=igp
        received-from=peer2
Coba lakukan traceroute dari R6 ke R9.
[admin@R6] > tool traceroute 1.1.9.2
 # ADDRESS                                 RT1   RT2   RT3   STATUS
 1 1.1.6.1                                 1ms   1ms   0ms
 2 2.2.7.1                                 2ms   2ms   2ms
 3 2.2.4.2                                 3ms   2ms   3ms 
 4 1.1.8.2                                 3ms   3ms   5ms
 5 1.1.9.2                                 4ms   3ms   7ms 
Ternyata walaupun distance di rubah dan AS200 merupakan jalur utama yang digunakan. Selanjutnya coba konfigurasi rubah weight.
[admin@R7] > /routing filter
add action=accept chain=bgp-in disabled=no invert-match=no  set-bgp-weight=100
Lalu lakukan verifikasi routing table.
[admin@R7] > ip route print detail where dst-address=1.1.7.0/30
Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme, B - blackhole, U - unreachable, P - prohibit
 6 ADC  dst-address=1.1.7.0/30 pref-src=1.1.7.2 gateway=ether1 gateway-status=ether1 reachable distance=0 scope=10

 7  Db  dst-address=1.1.7.0/30 gateway=1.1.7.1 gateway-status=1.1.7.1 reachable via  ether1 distance=20 scope=40 target-scope=30 bgp-as-path="7,10,20,30,100"
        bgp-origin=igp received-from=peer1
Namun ternyata jalur AS100 tetap juga tidak aktif juga. Mengapa begitu? Dikarenakan BGP merupakan routing yang memilih jalur berdasarkan AS yang dilewatinya. Jadi apabila ada banyak AS yang harus dilewati, maka jalur tersebut tidak akan dipilih.

Lab. 17 Superlab Mikrotik

Assalamualaikum,

Pada kali ini saya akan melanjutkan materi routing dimana sebelumnya saya telah memposting materi mengenai Lab. 16 Superlab Mikrotik dan kali ini saya akan melanjutkannya.


Dan materi yang akan di bahas pada kali ini diantara lain sebagai berikut.
  1. BGP Over GRE Tunnel 
  2. Backbone Area Virtual link 
  3. Route Filtering
  4. BGP Default-originate
  5. OSPF Distribute-Default 
  6. Routing Filter 
Konfigurasi

Untuk konfigurasi, pertama tama tentunya lakukan konfigurasi terlebih dahulu terhadap setiap interface yang ada pada router. Namun pada kali ini saya tidak menunjukkan konfigurasi ip address dikarenakan mungkin nanti postingan ini hanya penuh dengan konfigurasi ip address hehehe, Insya allah nanti saya akan update postingan ini dengan tabel ip address. 

Oke jika semua interface telah di tambahkan ip address, lanjut ke konfigurasi routing. Ada beberapa konsep yang nantinya akan dibahas seperti menghubungkan area 0 dengan area 0, peering BGP melalui tunnel, dan lain lainnya. Oke langsung saja menuju ke konfigurasi.

Pertama saya akan melakukan konfigurasi OSPF pada backbone area dan area1. Backbone area ditandai dengan box berwarna merah, dan juga area1 ditandai dengan box berwarna biru. Kalau biasanya backbone area dipakai sebagai penghubung antar area, pada kali ini kita akan mencoba standart area sebagai area penghubung area backbone. Area1 akan digunakan transit area untuk menghubungkan kedua backbone area. Untuk menghubungkan kedua backbone area tersebut, saya akan menggunakan virtual link. 

Pertama konfigurasi terlebih dahulu OSPF instance pada router yang akan menggunakan routing OSPF. 
[admin@R6] > /routing ospf instance
set router-id=6.6.6.6 redistribute-connected=as-type-1
[admin@R4] > /routing ospf instance
set redistribute-connected=as-type-1 router-id=4.4.4.4
[admin@R7] > /routing ospf instance
set redistribute-connected=as-type-1 router-id=7.7.7.7
[admin@R1] > /routing ospf instance
set redistribute-connected=as-type-1 router-id=1.1.1.1
[admin@R2] > /routing ospf instance
set redistribute-connected=as-type-1 router-id=2.2.2.2
[admin@R3] > /routing ospf instance
set redistribute-connected=as-type-1 router-id=3.3.3.3
[admin@R5] > /routing ospf instance
set redistribute-connected=as-type-1 router-id=5.5.5.5
[admin@R8] > /routing ospf instance
set redistribute-connected=as-type-1 router-id=8.8.8.8
[admin@R9] > /routing ospf instance
set redistribute-connected=as-type-1 router-id=9.9.9.9
Setelah itu, buat terlebih dahulu area pada R1,R2, dan R3. R1 dan R3 akan bertindak sebagai ABR.
[admin@R1] > /routing ospf area
add area-id=0.0.0.1 disabled=no instance=default name=area1 type=default
[admin@R2] > /routing ospf area
add area-id=0.0.0.1 disabled=no instance=default name=area1 type=default
[admin@R3] > /routing ospf area
add area-id=0.0.0.1 disabled=no instance=default name=area1 type=default
Jika sudah, advertise network yang ada pada router ospf.
[admin@R6] > /routing ospf network
add area=backbone disabled=no network=1.1.6.0/30
[admin@R4] > /routing ospf network
add area=backbone disabled=no network=1.1.4.0/30
add area=backbone disabled=no network=1.1.7.0/30
add area=backbone disabled=no network=1.1.6.0/30
[admin@R7] > /routing ospf network
add area=backbone disabled=no network=1.1.7.0/30
[admin@R1] > /routing ospf network
add area=backbone disabled=no network=1.1.4.0/30
add area=area1 disabled=no network=1.1.2.0/30
add area=area1 disabled=no network=1.1.3.0/30
[admin@R2] > /routing ospf network
add area=area1 disabled=no network=1.1.2.0/30
add area=area1 disabled=no network=1.1.30.0/30
[admin@R3] > /routing ospf network
add area=backbone disabled=no network=1.1.5.0/30
add area=area1 disabled=no network=1.1.30.0/30
add area=area1 disabled=no network=1.1.3.0/30
[admin@R5] > /routing ospf network
add area=backbone disabled=no network=1.1.5.0/30
add area=backbone disabled=no network=1.1.8.0/30
add area=backbone disabled=no network=1.1.9.0/30
[admin@R8] > /routing ospf network
add area=backbone disabled=no network=1.1.8.0/30
[admin@R9] > /routing ospf network
add area=backbone disabled=no network=1.1.9.0/30
Setelah itu buat virtual link untuk menghubungkan kedua backbone area.
[admin@R1] > /routing ospf virtual-link
add authentication=md5 authentication-key=IDN authentication-key-id=1 disabled=no neighbor-id=3.3.3.3 transit-area=area1
[admin@R3] > /routing ospf virtual-link
add authentication=md5 authentication-key=IDN authentication-key-id=1 disabled=no neighbor-id=1.1.1.1 transit-area=area1
Sedikit penjelasan mengenai konfigurasi di atas, kita menggunakan virtual link yang memiliki autentikasi. Jadi tidak sembarang router yang dapat terhubung dengan virtual link yang kita miliki, dikarenakan untuk terhubung ke virtual link sebuah router yang memiliki keamanan, router lainnya harus tau mengenai autentikasi key yang ada pada router tersebut.

Selanjutnya pada skenario kali ini, R2 akan discard setiap advertise network yang didapatkan dan R2 akan memanfaatkan default route yang diberikan oleh R1 dan R3. Begitu juga dengan R4 dan R5, keduanya akan menggunakan default route yang diberikan oleh R1 dan R3. Konfigurasi R1 dan R3 agar memberikan default route.
[admin@R3] > /routing ospf instance
set distribute-default=always-as-type-1
[admin@R1] > /routing ospf instance
set distribute-default=always-as-type-1
Setelah itu konfigurasi route filter pada R2, R4, dan R5 agar ketiga router tersebut tidak mendapatkan routing ospf selain default route.
[admin@R4] > /routing filter
add action=discard chain=ospf-in disabled=no invert-match=no prefix-length=30-32
[admin@R5] > /routing filter
add action=discard chain=ospf-in disabled=no invert-match=no prefix-length=30-32
[admin@R2] > /routing filter
add action=discard chain=ospf-in disabled=no invert-match=no prefix-length=30-32
Setelah itu cek ip route pada ketiganya.
[admin@R2] > ip route pr
Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme, B - blackhole, U - unreachable, P - prohibit
 #      DST-ADDRESS        PREF-SRC        GATEWAY            DISTANCE
 0 ADo  0.0.0.0/0                                        1.1.2.1                 110
                                                                   1.1.30.2         
 1 ADC  1.1.2.0/30             1.1.2.2              ether1                    0
 2 ADC  1.1.30.0/30           1.1.30.1            ether2                    0
 3 ADC  2.2.2.2/32             2.2.2.2              lo1                          0
 [admin@R4] > ip route print
Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme, B - blackhole, U - unreachable, P - prohibit
 #      DST-ADDRESS        PREF-SRC        GATEWAY            DISTANCE
 0 ADo  0.0.0.0/0                                        1.1.4.1                 110
 1 ADC  1.1.4.0/30             1.1.4.2              ether1                    0
 2 ADC  1.1.6.0/30             1.1.6.1              ether2                    0
 3 ADC  1.1.7.0/30             1.1.7.1              ether3                    0
 4 ADC  4.4.4.4/32             4.4.4.4              lo1                          0
 [admin@R5] > ip route pr
Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme, B - blackhole, U - unreachable, P - prohibit
 #      DST-ADDRESS        PREF-SRC        GATEWAY            DISTANCE
 0 ADo  0.0.0.0/0                                        1.1.5.1                 110
 1 ADC  1.1.5.0/30             1.1.5.2              ether1                    0
 2 ADC  1.1.8.0/30             1.1.8.1              ether2                    0
 3 ADC  1.1.9.0/30             1.1.9.1              ether3                    0
 4 ADC  5.5.5.5/32             5.5.5.5              lo1                          0
Lalu terlihat pada hasil verifikasi tersebut bahwa ketiga router tersebut telah mendapatkan default route. Selanjutnya kita akan melakukan konfigurasi BGP pada router yang berada pada blok kuning. Konfigurasi terlebih dahulu BGP Instance pada setiap router tersebut.
[admin@R10] > /routing bgp instance
set default as=200 client-to-client-reflection=yes cluster-id=10.10.10.10 redistribute-connected=yes router-id=10.10.10.10
[admin@R11] > /routing bgp instance
set default as=200 client-to-client-reflection=yes cluster-id=11.11.11.11 redistribute-connected=yes router-id=11.11.11.11
[admin@R6] > /routing bgp instance
set default as=200 client-to-client-reflection=yes cluster-id=6.6.6.6 router-id=6.6.6.6  
[admin@R9] > /routing bgp instance
set default as=300 client-to-client-reflection=yes cluster-id=9.9.9.9 router-id=9.9.9.9
[admin@R12] > /routing bgp instance
set default as=300 client-to-client-reflection=yes cluster-id=12.12.12.12 redistribute-connected=yes router-id=12.12.12.12
[admin@R13] > /routing bgp instance
set default as=300 client-to-client-reflection=yes cluster-id=13.13.13.13 redistribute-connected=yes router-id=13.13.13.13
Lalu tambahkan BGP Peer pada setiap router.
[admin@R10] > /routing bgp peer
add remote-address=1.1.10.1 remote-as=200
add remote-address=1.1.110.2 remote-as=200
 [admin@R11] > /routing bgp peer
add remote-address=1.1.11.1 remote-as=200
add remote-address=1.1.110.1 remote-as=200
[admin@R6] > /routing bgp peer
add default-originate=always multihop=yes nexthop-choice=force-self remote-address=1.1.10.2 remote-as=200 route-reflect=yes
add default-originate=always multihop=yes nexthop-choice=force-self remote-address=1.1.11.2 remote-as=200 route-reflect=yes
[admin@R13] > /routing bgp peer
add remote-address=1.1.13.1 remote-as=300
add remote-address=1.1.130.1 remote-as=300
[admin@R12] > /routing bgp peer
add remote-address=1.1.12.1 remote-as=300
add remote-address=1.1.130.2 remote-as=300
[admin@R9] > /routing bgp peer
add default-originate=always multihop=yes nexthop-choice=force-self remote-address=1.1.12.2 remote-as=300 route-reflect=yes
add default-originate=always multihop=yes nexthop-choice=force-self remote-address=1.1.13.2 remote-as=300 route-reflect=yes
Lalu pastikan peer sudah established. Selanjutnya, kita buat agar router BGP bagian kanan dapat berkomunikasi dengan router BGP bagian kiri. Pertama tama buat terlebih dahulu gre tunnel untuk menghubungkan kedua blok tersebut, lalu berikan ip address untuk tunnel tersebut.
[admin@R9] > /interface gre
add local-address=1.1.9.2 name=gre remote-address=1.1.6.2
[admin@R9] > /ip address
add address=20.20.20.2/30 disabled=no interface=gre network=20.20.20.0
[admin@R6] > /interface gre
add local-address=1.1.6.2 name=gre remote-address=1.1.9.2
[admin@R6] > /ip address
add address=20.20.20.1/30 disabled=no interface=gre network=20.20.20.0
Lalu lakukan verifikasi bahwa keduanya sudah dapat terhubung satu sama lain. Setelah itu, buat peering antara kedua router tersebut menggunakan address tunnel tersebut.
[admin@R6] > /routing bgp peer
add nexthop-choice=force-self remote-address=20.20.20.2 remote-as=300
[admin@R9] > /routing bgp peer
add nexthop-choice=force-self remote-address=20.20.20.1 remote-as=200 route-reflect=yes
Lalu pastikan keduanya sudah dalam status established.
[admin@R9] > routing bgp peer pr
Flags: X - disabled, E - established
 #   INSTANCE       REMOTE-ADDRESS  REMOTE-AS 
 0 E default             1.1.12.2                      300       
 1 E default             1.1.13.2                      300       
 2 E default             20.20.20.1                  200
 [admin@R6] > routing bgp peer pr
Flags: X - disabled, E - established
 #   INSTANCE   REMOTE-ADDRESS  REMOTE-AS
 0 E default         1.1.10.2                      200      
 1 E default         1.1.11.2                      200      
 2 E default         20.20.20.2                  300  
Setelah itu pastikan kedua blok tersebut saling dapat berkomunikasi. Lalu pastikan bahwa R6 dan R9 telah mendapatkan default route yang diberikan oleh R4 dan R5. Setelah itu, tambahkan filter pada R6 dan R9 agar keduanya tidak mendapatkan route dari OSPF selain default route.
[admin@R6] > /routing filter
add action=discard chain=ospf-in disabled=no prefix-length=30-32
[admin@R9] > /routing filter
add action=discard chain=ospf-in disabled=no prefix-length=30-32
Maka kedua router tersebut akan mendapatkan default route untuk menuju ke jaringan OSPF. Selanjutnya, kita buat agar R10, R11, R12, dan R13 dapat melakukan ping ke jaringan OSPF.
[admin@R6] > /ip firewall nat
add action=masquerade chain=srcnat disabled=no out-interface=ether1
[admin@R9] > /ip firewall nat
add action=masquerade chain=srcnat disabled=no out-interface=ether1
Maka verifikasi apakah R10, R11, R12, dan R13 dapat melakukan ping ke jaringan ospf atau tidak.
[admin@R10] > ping 1.1.30.1
HOST                                     SIZE TTL TIME  STATUS 
1.1.30.1                                   56  61 3ms 
    sent=1 received=1 packet-loss=0% min-rtt=3ms avg-rtt=3ms max-rtt=3ms
[admin@R12] > ping 1.1.30.1
HOST                                     SIZE TTL TIME  STATUS
1.1.30.1                                   56  60 8ms 
    sent=1 received=1 packet-loss=0% min-rtt=8ms avg-rtt=8ms max-rtt=8ms 
Hal ini menandakan bahwa Router local dapat berkomunikasi dengan jaringan OSPF. Lakukan verifikasi ping dari jaringan OSPF menuju Router BGP.
[admin@R1] > ping 1.1.10.2
HOST                                     SIZE TTL TIME  STATUS
                                                no route to host
    sent=1 received=0 packet-loss=100%
Mengapa tidak bisa? Dikarenakan R6 tidak mengadvertise network yang ia miliki agar router OSPF tidak dapat mengetahui jaringan local yang dimiliki Router BGP.