Sunday, 5 November 2017

VLAN Mikrotik

Assalamualaikum, 

Oke setelah lama ga ngepost, kali ini saya bangkit kembali dengan semangat 45 yang mulai berkobar hehehe. Oke fokus. Fokus. Fokus. 

Pada kali ini, saya akan membahas sebuah materiyaitu materi mengenai VLAN. Seperti yang kita ketahui sebelumnya, bahwa VLAN ini tentunya sangat berguna apabila diterapkan di dalam sebuah jaringan. Mengapa berguna? Dikarenakan seperti yang kita tahu, bahwa VLAN ini merupakan protocol yang membuat jaringan tersebut scalabilitynya lebih baik, dan juga tentunya agar memudahkan dalam management jaringan yang baik. 

Oke langsung saja, berikut topologi yang akan kita gunakan pada lab kali ini. 

Topologi
Konfigurasi 

Sesuai dengan topologi diatas, kita akan menggunakan 3 router dimana ketiga router tersebut nantinya akan saling terhubung dengan menggunakan VLAN. Jadi kita tidak menggunakan interface fisik sebagai penghubung antar router tersebut, akan tetapi kita akan menggunakan  interface VLAN sebagai perantara terhubungnya sebuah router dengan router lainnya. 

Lalu apa yang harus pertama kali dikonfigurasikan? 

Yang pertama kali harus dikonfigurasikan tentunya adalah VLAN pada setiap router. Mengapa bukan ip address? Hal ini dikarenakan dalam penggunaan VLAN, dia akan menggunakan layer 2 sebagai media penghubung dari sebuah router dengan router lainnya. Seperti yang kita tahu, layer 2 bekerja dengan menggunakan mac-address. Jadi apabila sebuah router sudah terhubung secara fisik dengan router lainnya, maka sudah dapat dipastikan juga bahwa keduanya sudah dapat terhubung satu sama lain. Jadi tidak perlu adanya ip address yang dimasukkan ke dalam interface fisik. 

Oke langsung saja, berikut konfigurasi VLAN untuk setiap router. 

Router1
[admin@R1] > interface vlan add vlan-id=10 name=VLAN10 interface=ether1
Router2
[admin@R2] > interface vlan add vlan-id=10 name=VLAN10 interface=ether1
[admin@R2] > interface vlan add vlan-id=10 name=VLAN10-R3 interface=ether2
Router3
[admin@R3] > interface vlan add vlan-id=10 name=VLAN10 interface=ether1
Oke berdasarkan konfigurasi diatas, kita melakukan pendaftaran VLAN pada interface yang akan digunakan. Apabila ada pertanyaan, mengapa di router 2 kita harus menggunakan 2 VLAN? Hal ini bertujuan agar Router1 dapat berkomunikasi dengan Router3 dengan menggunakan VLAN yang sama. Jadi kita harus mengkonfigurasikan bridge juga pada kedua VLAN tersebut, agar kedua VLAN tersebut terhubung satu sama lainnya.Oke langsung saja kita konfigurasikan. 

Router2
[admin@R2] > interface bridge add name=Gabungan
[admin@R2] > interface bridge port add interface=VLAN10 bridge=Gabungan
[admin@R2] > interface bridge port add interface=VLAN10-R3 bridge=Gabungan
Jika sudah dikonfigurasikan, langkah selanjutnya adalah kita akan menambahkan ip address pada setiap VLAN. Kenapa? Hal ini agar nantinya, setiap router dapat saling berkomunikasi satu sama lainnya. 

Router1
[admin@R1] > ip address add address=10.10.10.1/24 interface=VLAN10
Router2
[admin@R2] > ip address add address=10.10.10.2/24 interface=VLAN10
Router3
[admin@R3] > ip address add address=10.10.10.3/24 interface=VLAN10

Oke jika sudah seperti itu, sekarang lakukan verifikasi bahwa setiap  router dapat berkomunikasi satu sama lain.

Wednesday, 4 October 2017

Routing mark 2 ISP Berbeda

Assalamualaikum,

Pada kali ini, saya akan menunjukkan sebuah cara yang digunakan untuk memanipuasi jalur untuk keluar. Dalam hal ini, nantinya kita akan mengalihkan sebuah traffic untuk network sekian, dan juga sebuah traffic untuk network lainnya. Hal ini biasanya digunakan untuk meoptimalkan beban traffic yang ada pada jaringan tersebut. Sehingga tentunya, traffic akan terasa cukup lega dan terlihat adil.

Oke langsung saja, berikut topologi yang akan kita gunakan.

Topologi
Konfigurasi

Oke berdasarkan topologi diatas, terlihat bahwa sebuah jaringan memiliki 2 ISP yang sama sama digunakan untuk terhubung ke internet tentunya, dan juga ada 2 network yang ada pada sisi client. Sehingga nantinya sebuah network akan melewati jalur ISP A dan network lainnya akan melewati jalur ISP B.

Kita akan membuat agar network dari VLAN 10 melewati ISP A, dan VLAN 20 melewati ISP B.

Router1

[admin@R1]> ip firewall mangle add chain=prerouting src-address=172.4.110.0/24 action=mark-routing new-routing-mark=TrafficVLAN10
[admin@R1] > ip firewall mangle add chain=prerouting src-address=172.4.120.0/24 action=mark-routing new-routing-mark=TrafficVLAN20
Berdasarkan konfigurasi tersebut, menandakan bahwa setiap packet yang berasal ari VLAN10, maka tandai routing tersebut dengan nama TrafficVLAN10. Sedangkan untuk traffic yang berasal dari VLAN20, maka tandai routing tersebut dengan TrafficVLAN20.

Jika sudah seperti itu, kita harus mendefinisikan nantinya traffic yang dibuat tadi akan melewati jalur yang mana. Oleh karena itu, kita harus membuat route untuk masing masing traffic.

Router1
[admin@R1]> ip route add gateway=172.4.2.1/30 routing-mark=TrafficVLAN10
[admin@R1]> ip route add gateway=172.4.2.5/30 routing-mark=TrafficVLAN20
Jika sudah seperti itu, maka lakukan pengecekan dengan menggunakan traceroute. Maka hasilnya itu, apabila VLAN10 melakukan traceroute, maka yang akan dilewati adalah jalur ISP A, dan sedangkan apabila VLAN20 melakukan traceroute, maka yang akan dilewati adalah jalur ISP B.

Friday, 15 September 2017

Firewall address list

Assalamualaikum,

Pada kali ini saya akan membahas kembali materi tentang firewall, dan materi yang akan dibahas pada kali ini adalah dengan penggunaan address-list.


Address list sendiri, merupakan sekumpulan address yang dapat dikelompokkan menjadi satu group. Untuk penggunaannya sendiri, biasanya address list tersebut digunakan untuk melakukan filter terhadap sekumpulan address yang dikehendaki untuk difilter. Oke langsung saja, berikut topologi yang akan kita gunakan.

Topologi

Konfigurasi

Untuk konfigurasinya, buat agar setiap setiap router tersebut dapat tehubung ke internet terlebih dahulu. Pada firewall yang akan kita konfigurasi pada kali ini, nantinya kita akan membuat rule, "Apabila ada yang melakukan ping ke router, maka koneksi dirinya menuju internet akan di blokir selama 5 menit. Setelah 5 menit itu, baru nanti ia bisa melakukan akses ke internet kembali". Oke langsung saja konfigurasikan firewall yang sesuai untuk rule tersebut. 

R-Gateway
/ip firewall filter
add action=add-src-to-address-list address-list=PingKeRouter address-list-timeout=5m chain=input protocol=icmp
add action=drop chain=input src-address-list=PingKeRouter
add action=drop chain=forward src-address-list=PingKeRouter
Berdasarkan konfigurasi diatas, kita dapat definisikan dalam bahasa manusianya untuk memerintahkan R-Gateway sebagai berikut. 
Setiap packet yang menuju ke router dengan protocol ICMP, izinkan, dan daftarkan ke dalam address-list, dan berikan waktu expired pada address list tersebut selama 5 menit.
Selanjutnya kita mendefinisikan kembali pada firewall yang ke 2 dan ke 3 sebagai berikut. 
Setiap packet yang berasal dari address-list PingKeRouter, yang ingin menuju ke router ataupun melewati router, maka drop packet tersebut.
Jadi seperti itulah bagaimana kita memerintahkannya dalam bahasa manusia. Apabila sudah seperti itu, maka selama ada addresslist yang ditambahkan ke dalam grup PingKeRouter, maka setiap packet yang akan dikirimkan ke router ataupun melewati router akan di drop.

Thursday, 14 September 2017

DHCP Client

Assalamualaikum, 

Pada kali ini saya akan membahas kembali dan masih mengenai mikrotik, materi yang akan saya bahas pada kali ini adalah materi mengenai DHCP Client pada mikrotik. 
 

Pada DHCP Client yang ada di mikrotik sendiri, tentunya berguna untuk melakukan request address kepada DHCP Server. Jadi kita mengkonfigurasikan mikrotik agar mendapatkan address dari DHCP server. 

Dalam mikrotik sendiri, ada beberapa konfigurasi yang dapat kita konfigurasikan pada bagian DHCP Client, dan diantaranya sebagai berikut. 

1.Interface
Interface merupakan salah satu konfigurasi yang wajib dikonfigurasikan pada client. Dalam hal ini, kita mengkonfigurasikan untuk menentukan interface mana yang nantinya akan mendapatkan address DHCP dan mana address yang akan melakukan request untuk mendapatkan address. 

2. Hostname
Hostname sendiri, merupakan konfigurasi yang tidak begitu wajib. Fungsinya sendiri agar nantinya router kita dikenali oleh DHCP Server dengan hostname yang telah didefinisikan. 

3. Client-id
Client id juga merupakan konfigurasi yang tidak begitu wajib juga. Untuk fungsinya sendiri, berfungsi untuk mendefinisikan mac address pada interface yang kita gunakan. 

4. Add default route
Dalam parameter ini, kita dapat menentukan apakah kita ingin menambahkan default route pada router tersebut. Untuk default route itu sendiri, nantinya akan menggunakan DHCP Server sebagai gateway kemana dia akan keluar. 

5.Use peer dns
Dalam parameter tersebut, kita bisa mendefinisikan apakah ingin menambahkan dns sesuai yang diberikan oleh DHCP server. 

6. Use peer ntp
Dalam parameter tersebut, kita dapat mendefinisikan apakah kita ingin mensinkronkan waktu yang ada pada router kita dengan DHCP server. 

7. Default route distance
Dan parameter ini adalah yang terakhir, dimana apabila kita memiliki 2 dhcp server, kita dapat menentukan mana prioritas gateway yang akan kita gunakan. 

Oke parameter diatas adalah beberapa parameter yang dapat kita konfigurasikan apabila kita ingin menggunakan address dari DHCP server. Untuk konfigurasinya sendiri, agar kita dapat terhubung ke internet, yang intinya adalah sebagai berikut. 
/ip dhcp-client
add interface=ether1 disabled=no add-default-route=yes use-peer-dns=yes use-peer-ntp=yes
Konfigurasi tersebut adalah konfigurasi familiar yang ditambahkan apabila kita ingin menggunakan DHCP server sebagai gateway untuk menuju ke internet. 

Port Forwarding Mikrotik

Assalamualaikum, 

Pada kali ini saya akan membahas sebuah materi yang mungkin bisa dibilang simple, akan tetapi tentunya sangat dibutuhkan. Materi tersebut adalah port forwarding. 


Materi port forwarding sendiri bisa dibilang simple, dikarenakan kita hanya perlu melakukan konfigurasi pada firewall nat. Dan bisa dibilang penting apabila kita ingin melakukan sesuatu pada jaringan local yang kita miliki, agar dapat digunakan oleh jaringan publik. 

Oke inti dari port forwarding sendiri, adalah agar apabila ada sebuah pengiriman yang menuju ke sebuah address dengan menggunakan port sekian, maka paket tersebut akan diteruskan kembali kepada address dan port yang telah ditentukan.

Oke langsung saja, berikut topologi yang akan kita gunakan. 

Topologi
 
Konfigurasi
Untuk konfigurasinya, tentunya konfigurasikan terlebih dahulu ip address pada setiap router agar kedua router tersebut saling mengakses internet. Dalam hal ini, apabila terjadi dilapangan, maka R-Client merupakan router yang memiliki address local yang ingin agar bisa diakses melalui internet, sedangkan R-Forwarding adalah router yang memiliki ip publik yang membuat agar R-Client dapat diakses oleh internet. 

Oke lansung saja, konfigurasikan port forwarding pada R-Forwarding.
/ip firewall nat
add action=dst-nat chain=dstnat dst-address=192.168.122.125 dst-port=1122 protocol=tcp to-addresses=12.12.12.2 to-ports=80
Berdasarkan konfigurasi tersebut, kita dapat ambil kesimpulan dalam bahasa manusia seperti berikut. 
Apabila ada packet dengan protocol tcp dan menggunakan port 1122 yang menuju ke address 192.168.122.125, maka packet tersebut akan diteruskan kepada address 12.12.12.2 dengan port 80
Seperti itulah gambaran bagaimana kita memerintahkan mikrotik tersebut. Jika sudah seperti itu, lakukan verifikasi untuk mengakses address 192.168.122.125 dengan port 1122.


Berdasarkan hasil verifikasi diatas, kita dapat melakukan konfigurasi pada R-Client, walaupun R-Client berada pada jaringan local. Lalu mengapa bisa? Hal ini dikarenakan sebelumnya kita sudah melakukan konfigurasi forwarding pada R-Forwarding agar R-Client dapat diakses menggunakan jaringan publik.

ARP Protocol

Assalamualaikum, 

Pada kali ini saya akan kembali membahas sebuah materi yang bisa dibilang merupakan materi basic dan materi yang akan saya bahas adalah materi mengenai ARP Table.

Oke sebelum belajar mengenai ARP Table, lebih baik kita mengenal terlebih dahulu apa itu protocol ARP. Lalu apa sih protocol ARP itu? 


Protocol ARP merupakan sebuah protocol yang berfungsi untuk mencari tahu mac address dari sebuah host yang sudah terdaftar dalam sebuah jaringan dengan menggunakan perantara ip address. Jadi protocol ARP ini bekerja sama antara layer 2 dan juga layer 3 untuk mencari seluruh informasi yang nantinya akan dibutuhkan dalam jaringan tersebut. 

Untuk informasi mengenai ARP yang ada di dalam jaringan kita sendiri, apabila pada mikrotik, akan tersimpan di dalam ARP table. ARP table juga bisa dianggap sebagai ARP cache dikarenakan seluruh informasi yang berkaitan dengan addressing entah itu ip address ataupun mac address, semua akan disimpan di ARP table. 

Lalu bagaimana caranya protocol ARP bekerja? 

Pertama tama, sebuah perangkat jaringan akan mengirimkan sebuah packet broadcast yang dikirimkan kepada seluruh client, yang bertujuan untuk meminta informasi dari mac address yang ada pada setiap client. Seperti yang sudah dibilang sebelumnya, bahwa untuk mendapatkan informasi mac address yang ada pada client, maka client tersebut harus terhubung terlebih dahulu dengan jaringan yang sudah kita miliki. 

Apabila client sudah menerima packet tersebut, maka client akan memeriksa packet tersebut, dan apabila diperbolehkan, maka client tersebut akan mengirimkan informasi mengenai mac address yang dia miliki. 

Jika sudah seperti itu, router  yang menerima packet tersebut akan segera memasukkan informasi yang dikirim dari client tersebut, untuk didaftarkan ke dalam ARP table. ARP table inilah yang berisi kumpulan mac address beserta ip address yang digunakan oleh setiap host. 

Untuk ARP table ini sendiri bersifat dinamis. Ataupun dalam artian, apabila ada mac address dan ip address yang berubah dari sebuah client, maka ARP tersebut akan segera di update untuk mendapatkan informasi yang terbaru. 

Friday, 25 August 2017

Firewall Filter

Assalamualaikum, 

Pada kali ini saya akan membahas kembali mengenai mikrotik, dan materi yang akan saya bahas pada kali ini adalah materi firewall filter. 

Seperti yang kita ketahui sebelumnya, bahwa firewall sendiri merupakan sistem keamanan yang dimiliki oleh setiap perangkat untuk melindungi perangkat itu sendiri. Dalam hal ini, mikrotik juga memiliki firewall untuk keamanan pada dirinya, yang bertujuan untuk memperbolehkan, mentidakbolehkan, memanipulasi, dan masih banyak yang lainnya. 

Sekarang kita akan membahas beberapa teknik yang dapat kita gunakan untuk menggunakan firewall pada mikrotik. Untuk tekniknya sendiri ada 2 macam, yaitu :
  • Accept Few, Drop Any
Dalam teknik ini, nantinya beberapa packet yang telah di definisikan pada firewall, akan di bolehkan oleh firewall. Sedangkan setiap packet yang tidak didefinisikan, maka akan di drop. 
  • Drop Few, Accept Any
Dalam teknik ini, nantinya beberapa packet yang telah di definisikan pada firewall, akan didrop(ditolak) dan sedangkan packet yang tidak didefinisikan, maka akan diperbolehkan. 

Oke langsung saja, berikut topologi yang akan digunakan. 

Topologi 
 
Dalam topologi tersebut, kita akan menggunakan sebuah router, dan juga cloud yang digunakan agar pc kita terhubung ke dalam router tersebut. 

Konfigurasi 

Untuk konfigurasinya, konfigurasikan ip address terlebih dahulu pastinya. IP addressnya dikarenakan laptop saya terhubung dengan router yang memiliki koneksi internet, jadi pada mikrotik dikonfigurasikan agar mendapatkan ip dhcp. 
[admin@R1] > ip dhcp-client add interface=ether2 disabled=no
Lalu lakukan verifikasi bahwa address tersebut sudah terdaftar. 


Jika sudah mendapatkan address, sekarang kita akan melakukan konfigurasi firewall. Firewall yang akan kita terapkan pertama adalah accept few, drop any. Dalam hal ini, nantinya ada beberapa traffic yang akan router tersebut terima, dan seluruh packet selain yang diterima tersebut akan di drop. Konfigurasikan pada firewall filter. 

[admin@R1] > ip firewall filter add chain=input action=accept protocol=tcp port=22
[admin@R1] > ip firewall filter add chain=input action=drop protocol=tcp
Jika sudah, sekarang coba lakukan verifikasi pada sisi client dengan menggunakan nmap, apakah port yang sudah dikonfigurasikan tersebut sudah terfilter atau belum. 

Client


Berdasarkan hasil verifikasi tersebut, sudah terlihat bahwa hasil nmap menunjukkan bahwa router tersebut tidak dapat di scan. Hal ini dikarenakan seluruh traffic yang menuju ke router selain port 22 di drop. Jadi dikarenakan nmap sendiri juga menggunakan protocol tcp, dan nmap tersebut juga termasuk yang di blok. 

Oke selanjutnya, kita akan melakukan konfigurasi dengan teknik yang kedua, yaitu drop few, accept any. Hal ini berarti apabila ada yang di definisikan di firewall, maka akan di lakukan tindakan, dan yang lainnya diperbolehkan untuk lewat. Jadi nantinya ada beberapa packet yang akan di drop, dan packet yang lainnya akan dibiarkan saja. Oke langsung saja, konfigurasikan pada router. 

[admin@R1] > ip firewall filter add chain=input action=drop protocol=tcp port=22
[admin@R1] > ip firewall filter add chain=input action=accept
Jika sudah, sekarang coba lakukan verifikasi pada sisi client dengan menggunakan nmap.

Client


Berdasarkan hasil verifikasi tersebut, sudah terlihat bahwa hasil nmap menunjukkan bahwa port 22 statusnya menjadi filtered. Hal ini dikarenakan port tersebut sebelumnya sudah kita definisikan untuk di blok. Dan mengapa tidak seperti hasil pertama ketika router tersebut tidak bisa di nmap? Hal ini dikarenakan pada rule kali ini, traffic seluruh traffic untuk tcp, sudah di definisikan untuk di terima. Itulah mengapa kita dapat melakukan port scanning ke mikrotik tersebut.

Oh iya, untuk urutan pembacaan firewall di mikrotik, rule yang dibaca adalah dari atas ke bawah. Sehingga seperti contoh anda melakukan konfigurasi seperti berikut.

[admin@R1] > ip firewall filter add chain=input action=accept
[admin@R1] > ip firewall filter add chain=input action=drop protocol=tcp port=22
Dalam firewall tersebut, kita melakukan konfigurasi yang pertama kali untuk memperbolehkan seluruh protocol tcp yang menuju ke router. Dan yang kedua, anda akan mendrop port 22. Kembali lagi ke teori dari firewall sebelumnya, dimana pembacaan firewall dimulai dari rule teratas menuju rule paling bawah, maka rule yang anda tambahkan untuk mendrop port 22 akan percuma saja. Hal ini dikarenakan rule yang akan dibaca pertama kali adalah rule untuk menerima seluruh protocol tcp. Jadi rule yang kedua tidak akan berpengaruh terhadap apa yang akan di block.

Oleh karena itu, kita juga perlu memperhatikan posisi rule yang akan kita tambahkan.

Friday, 4 August 2017

Point to Point Wireless


 


Assalamualaikum, 

Oke setelah beberapa abad ngga ngeblog hehehe, sekarang saya akan share materi kembali, dan sekarang kita akan bergelut di dunia ghaib. 

Untuk materi dasar dari ilmu ghaib ini, saya tidak akan menjelaskan begitu banyak, dikarenakan ini merupakan postingan mengenai Lab. Jadi, kita akan bahas labnya saja yaaa. Oke langsung saja, berikut topologi yang akan kita gunakan pada kali ini. 

Topologi

Oke sedikit review mengenai materi yang akan kita bahas pada kali ini, sesuai namanya yaitu point to point, ini merupakan suatu nama hubungan dari suatu titik ke suatu titik lainnya secara langsung dan tanpa ada titik lainnya yang ikut bergabung. Jadi pada lab ini, kita hanya akan menggunakan 2 router saja, dikarenakan ini merupakan hubungan dari suatu titik, ke titik lainnya. Bukan dari suatu titik, ke beberapa titik. Oke langsung saja, kita akan mulai melakukan konfigurasi. 

Konfigurasi

Untuk konfigurasinya, sekarang kita akan menambahkan address terlebih dahulu untuk kedua router yang nantinya akan berhubungan. Untuk addressing sendiri, kita dapat menggunakan addressing agar membuat keduanya berada di dalam suatu network, ataupun kita dapat menggunakan point to point addressing. 

Router-Server
 

Router-Client
 

Jika sudah, sekarang lakukan konfigurasi pada bagian wireless. 

Router-Server
 

Pada konfigurasi diatas, kita melakukan konfigurasi untuk autentikasi yang nantinya akan digunakan oleh access point yang akan kita buat. Sehingga nantinya, apabila ada client yang ingin berhubungan dengan AP tersebut, maka harus memasukkan autentikasi terlebih dahulu, agar konektivitas keduanya terhubung.  

Selanjutnya, buat access pointnya pada server. 

Router-Server
 
 
Pada konfigurasi tersebut, kita melakukan konfigurasi pada Mode, SSID, dan juga Security Profile. Untuk modenya, kita dapat menggunakan ap bridge ataupun juga mode bridge. Sebenarnya untuk mode ap bridge sendiri, itu diperuntukkan untuk point to multipoint. Dan sedangkan untuk point to pointnya, kita menggunakan mode bridge. Namun tidak apa apa lah, karena kita juga cuma menggunakan 1 client hehehe. 

Jika sudah, sekarang kita akan melakukan konfigurasi pada client. 

Untuk konfigurasi pada client, kita juga perlu untuk memasukkan security profile pada wireless yangakan dibuat. Setelah itu untuk mencari wireless yang ada pada server, kita gunakan fitur scan yang ada pada wireless. Setelah itu pastikan status dari wireless yang ada pada client ataupun server itu sudah saling terhubung. 

Oke sampai sini aja untuk konfigurasi point to point wireless. Untuk melakukan verifikasinya,bisa di cek pada bagian registration table. 

Router-Server

Pada bagian tersebut, udah terlihat bahwa ada wireless yang berasal dari client, yang sudah terhubung ke server. Untuk melihat lebih jelasnya lagi, klik radio tersebut, dan maka akan muncul seperti berikut. 

Router-Server
 

Berdasarkan verifikasi tersebut, terlihat signal strength yang ada pada hubungan wireless tersebut. Terlihat juga CCQ yang ada pada hubungan wireless tersebut. Untuk CCQ sendiri, jangan bingung ya, karena jam praktek, banyak yang nyoba wireless juga, jadi ya mungkin adanya interferensi pada wireless tersebut hehehe. Terlihat juga  rate yang akan didapatkan. Selain dengan cara itu, kita juga bisa melakukan verifikasi dengan cara lainnya. 

Router-Server
  

Pada router server tersebut, kita juga dapat melihat rate yang bisa kita terima dari wireless tersebut. Selain itu juga kita juga dapat memanfatkan tools lainnya. Namun pada kali ini hanya sampai sini saja ya hehehe. Untuk pembahasan toolsnya akan dibahas pada postingan yang sebelumnya. 

Oke sekian dari saya, Wassalamualaikum.